intermittent WOL failure

gurus,

i can’t figure out how to troubleshoot this WOL problem, any advice (such as to appropriate log or configuration files) is appreciated. i have WOL enabled and working from both “suspend” (to mem, i assume) and hibernate … at least most of the time. manually putting the computer to sleep, waiting a few minutes, and then waking up remotely always works. after letting the machine sleep overnight, however, it won’t respond to me magic packets. how can the duration of sleep matter?

Release: 11.3
Desktop: Gnome 2.30.0
Kernel: 2.6.34

thanks, all

On Wed, 02 Nov 2011 17:36:03 +0000, icarroll wrote:

> manually putting the computer to sleep,
> waiting a few minutes, and then waking up remotely always works. after
> letting the machine sleep overnight, however, it won’t respond to me
> magic packets. how can the duration of sleep matter?

It shouldn’t. I use WoL with my laptop fairly regularly, and the sleep
duration never matters.

How is the device connected to the network - are you using a switch or a
hub?

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Uh, I have no idea. I’m plugged into the wall on a university campus network, and I’m not in the IT department. I can find out, if you’ll explain what we might be hoping to learn.

I should have also mentioned in the original post that WOL works (in the short term) whether or not I put the computer to sleep manually or gnome-power-manager does.

On Wed, 02 Nov 2011 18:56:03 +0000, icarroll wrote:

> hendersj;2399812 Wrote:
>>
>> How is the device connected to the network - are you using a switch or
>> a
>> hub?
>>
>>
> Uh, I have no idea. I’m plugged into the wall on a university campus
> network, and I’m not in the IT department. I can find out, if you’ll
> explain what we might be hoping to learn.

My initial thought was “throw a sniffer on the wire and see if anything
pops when trying to wake the device up” - but in order to sniff the magic
packets, you need to have a hub or a switch with port mirroring.

Then again, I don’t know that the magic packet generates any sort of
reply, so a sniffer might not tell you much beyond “are the packets
getting to the switch/hub the target machine is plugged into”?

While I can’t think that it would be the case, I suppose it’s possible if
the switch has power management that it might shut down the port after a
certain period of time not seeing a signal from the device plugged in -
but I don’t remember ever seeing that kind of power management on
networking equipment (not sure that it would save much - if any - power
at all anyways).

> I should have also mentioned in the original post that WOL works (in the
> short term) whether or not I put the computer to sleep manually or
> gnome-power-manager does.

WoL is implemented in hardware, so it wouldn’t matter how the system went
to sleep. As long as it’s enabled in the BIOS, it should be fine.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

Could be your site has one of those switches that forget the association of the device with the port after a period of no traffic. Not much you can do about that.

The most I was able to get out of the IT staff is that the switch has a MAC-Age-Time of 300 seconds. But that would be much too short a time-horizon to explain the problem, which take hours (not minutes) to appear. So the problem is still not resolved (although setting an alarm with rtcwake is a pretty good workaround), but thanks for the suggestions.