Interfacing iPod Touch 3G to openSUSE-11.3

As noted in a previous blog, my wife offered to let me play with her iPod Touch 3G when she is not using it. This is so that I can better refine my Tablet requirements, for when I ultimately purchase myself a Tablet. So this blog post is about interfacing 64-bit openSUSE-11.3 to an iPod Touch 3G.

Her Apple iPod Touch 3G is NOT jailbroken, and she is not keen on risking breaking her warranty with Apple by jailbreaking her iPod.

iPod Touch 3G

Creating movie for iPod Touch 3G:

So as part of this, my wife and I decided to check if we could play a .mp4 or .m4v video that I created with openSUSE GNU/Linux on her iPod. I created a .mp4 with the application ‘h264enc’ and also created a .mp4 and .m4v video with the application Handbrake (both apps are available from the Packman packager web site). The h264enc mp4 unfortunately introduced an audio/video desync on the video clip I tried. And Handbrake would produce a small 20KByte file and say it was done when clearly that very small file was worthless and not a video.

Some investigation revealed the input file I had may have had problems with the information in its wrapper. So I opened the input file with the program avidemux, and then had avidemux simply save the file again (copying both video and audio codecs so that no re-encoding was needed). Avidemux is available on the Packman packager web site. I then note that this re-wrapped video file could be properly processed by the application Handbrake and I was able to create .mp4 and .m4v videos using Handbrake’s iPod Touch/iPhone pre-defined settings.

Transferring videos to iPod over internet using DropBox

Now my wife was at work with her iPod and she wanted to test those videos now (with her work break coming up soon) ! So I had to get the files from my PC (running openSUSE-11.3) to her iPod at the office in time for her ‘work’ break. We don’t have a car, so a mad formula one car dash to her place of work was not an option ! We managed to do this file transfer by using the service/application “DropBox”. My wife installed the “dropbox” app on her iPod Touch 3G, and I installed the same on my openSUSE-11.3. I followed caf4926’s guide here: How to Install Dropbox (Gnome and KDE)

So with that setup, I then dragged the videos into DropBox and called my wife, and she could access them via her iPod.

My wife was able to play those videos on her iPod touch via the DropBox application on her iPod Touch. But she noted the control functions could not be removed when playing videos via DropBox on her iPod so it was not an ideal way to play videos (as the iPod screen was cluttered with fast forward/stop/reverse, … etc … ) . It was far better to play videos on her iPod with the basic video play that comes with the iPod, but unfortunately THAT video player can NOT access DropBox videos. Thus we needed to copy the videos direct to her iPod via the USB and THAT coping had to wait until she got home.

Transferring videos to iPod over internet using USB

So in preparation for transferring files to her iPod Touch 3G via USB, I installed on my 64-bit openSUSE-11.3 KDE-4.4.4. PC the following applications: gtkpod, libgpod, libimobiledevice, ifuse, libplist, and usbmuxd (and their dependencies). A good way to find these apps is to use the [openSUSE search] Search Results]( Note if one does not succeed initially, click on options and widen one’s search to include the various users repositories as well:](

My wife eventually returned from her shift work, and I then plugged my wife’s iPod Touch 3G into my openSUSE-11.3 PC. Unfortunately, I did NOT see the iPod when I typed with root permissions:

fdisk -l

BUT I still I had expected that above ‘fdisk -l’ command would not show the iPod (from researching this in advance) and so I then created a new directory to be my future mount point at /home/oldcpu/ipod and when I typed as a regular user:

ifuse /home/oldcpu/ipod

and voila, I could see the file structure of her iPod under /home/oldcpu/ipod with Dolphin file manager.

But the file structure was confusing, so I started up gtkpod and configured it to access her iPod. As part of the gtkpod setup, I had to tell gtkpod my wife’s iPod model # (which is a strange code buried in one of the iPod’s menus). I also had to tell it the directory I wanted it to use for the iPod sync (I told it /home/oldcpu/ipod).

Anyway, the sync worked and we could see all the pdf, text, and media files on my wife’s iPod with gtkpod. I dropped a couple of the .mp4 and .m4v video files into gtkpod, told it to save, and after some time the sync completed and the files were on her iPod. And they played great.

I note that when I went to unmount the iPod, with:

umount /home/oldcpu/ipod

it would NOT unmount as a regular user. I needed to unmount with root permissions (as opposed to mounting which only required regular user permissions).

I also noted it is likely not necessary to mount the iPod when using gtkpod. So one does NOT need to mess with the terminal once all of this is sorted.

side Android-3.x interfacing thoughts

There are today (early June-2011) threads in our openSUSE forums about users struggling to get their Android-3.0 OS (on their Xoom Tablet) interfacing with their openSUSE PC via a USB connection. Its possible Android-3.1 is necessary for Android users to have an easier interface to GNU/Linux, and thus it looks like to me that when it comes to interfacing one’s Tablet to a PC, all is also not rosy (for the average user) on the Android side of things, and it might even be JUST as complex if not MORE complex to interface an Android Tablet to GNU/Linux than it is to interface to an iPad/iPod.

**Conclusions **

So I am preparing myelf for the possibility that I may not be able to use a Tablet with a nominal GNU/Linux installed ( ie one that is not restricted such as Google have restricted with Android). A lot depends on MeeGo and already its clear Nokia are backing out of fully supporting that OS/GUI and hence I need to look at non-free (fully) proprietary options. Along those lines, I have now successfully interfaced to an older version of an Apple Touch capable portable device (the iPod Touch 3G) with a 64-bit openSUSE-11.3 KDE-4.4.4.

Unfortunately I have read that one needs to Jailbrake the iPad and iPod Touch 4G if one wishes to adopt what I managed to do, and hence more research into this is needed by me.