interface wlan0 detection problem

Hi everyone,

I’m pretty new to opensuse, I tried my hand at ubuntu at first but eventually decided to switch to suse. I’m working on my second suse install right now and like many others I’m having quite some problems with configuring my wireless card.

At the moment I’m working on an Acer Aspire 1800, I managed to install ndiswrapper after quite some tinkering and installed the drivers for the networkcard. Unfortunately the system still won’t detect a wlan0 interface. I’ve been googling like a madman but I just can’t seem to find a good solution to my problem so I figured I’d post it here to let some more intelligent people have a try at it :slight_smile:

Here are several command outputs:


0a:01.0 Ethernet controller: Broadcom Corporation NetXtreme BCM5788 Gigabit Ethernet (rev 03)
0a:02.0 Ethernet controller: Linksys, A Division of Cisco Systems [AirConn] INPROCOMM IPN 2220 Wireless LAN Adapter (rev 01)

**ndiswrapper -l**

neti2220 : driver installed
        device (17FE:2220) present

eth0      Link encap:Ethernet  HWaddr 00:02:3F:0B:7D:87
          inet addr:  Bcast:  Mask:
          inet6 addr: fe80::202:3fff:fe0b:7d87/64 Scope:Link
          RX packets:4011 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3630 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:3783780 (3.6 Mb)  TX bytes:639149 (624.1 Kb)

lo        Link encap:Local Loopback
          inet addr:  Mask:
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:96 errors:0 dropped:0 overruns:0 frame:0
          TX packets:96 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:6400 (6.2 Kb)  TX bytes:6400 (6.2 Kb)

Thanks in advance,

  • Frederik

Are you sure you have to use ndiswrapper?
Have a short look on Benutzeranleitung/Usersguide von/of collectNWData | to provide some more information :wink:

I ran the script and it gave the following warnings:

!!! CND0110E: For the selected connection type there was no active network interface found on your system
!!! CND0230W: IPV6 enabled                                                                               
!!! CND0240E: knetworkmanager for network configuration enabled but a YAST network card configuration for eth0 exist

The collectNWData.txt output can be found here.

I’m quite confident that I should use ndiswrapper because it’s suggested by the OpenSuse HCL.

Worked with “ndiswrapper -i WLIPNDS.INF”. WLIPNDS.INF was from “WPC54G v4 driver rev” from Linksys support.

  1. make sure to use either Yast or knetworkmanager for network configuration. deleting the current configuration in yast may help.
  2. as far as I can see ndiswrapper is not active. try modprobe ndiswrapper
    Maybe then your device will get ready to be setup via networkmanager :wink:

Hah, the system detected wlan0 after the modprobe command. I read the manual to figure out what the command did and now it seems logical.

I still can’t scan any interfaces with wlan0 but as you said it probably has to do with yast and the knetworkmanager trying to get access to it. I’ll look into it a bit further and see if I can solve it myself.

Thanks a ton for your help!

That command loaded the ndiswrapper module. Otherwise ndiswrapper is not active.

You can add the module to /etc/sysconfig/kernel → MODULES_LOADED_ON_BOOT to load it at startup :wink: