Inter VLAN configuration. How To ... ?


I decided to set up VLANs on my computer. I was able to set up the adapters by “vconfig” this way:

modprobe 8021q

ifconfig eth1 down

ifconfig eth1 netmask broadcast up

vconfig add eth1 11

ifconfig eth1.11 hw ether AA:AA:AA:AA:AA:11

ifconfig eth1.11 netmask broadcast up

vconfig add eth1 12

ifconfig eth1.12 hw ether AA:AA:AA:AA:AA:12

ifconfig eth1.12 netmask broadcast up

Then, I developed a simple echo server and client to communicate each other just test the vlans. Unfortunately, the client is not able to connect to the server.

The ping works, the traceroute works (after ‘traceroute -t nat -L’ !). I tried to add the adapters to a bridge ‘br0’ by ‘brctl’, but no result.

So, my questions are,

  • how to set up a inter-vlan in a opensuse 11.3 so the apps be able to communicate from one vlan to the other?
  • how to test the inter-vlan communication?

Thx in advance …

You need routing for inter vlan communication. The easiest way to do this is to set up the router with subinterfaces in your case in vlan 11 and 12 and configure the routes on your openSUSE so that they point to the router interfaces as next hop for reaching networks outside the vlan. What’s more different vlan’s are different subnets from the IP point of view so your IP addressing defeats the purpose for vlan existence.

If You really want to use vlans You should change the addressing so that each vlan is a different subnet and set up routing. A great way to do this is use the vyatta linux distribution, which is free to use and can convert almost any PC to a full fledged IP router.
Free Router, Firewall, VPN Download | Vyatta Core

Best regards,

If your opensuse11.3 is a gateway and connects to switch trunk (802.1q) port, so you need:

  1. enable ip forwarding on your suse box: “yast sysconfig - network - general” - IP_FORWARD = yes
  2. configure properly IP addressing. In your current setup is not properly (two interfaces in same IP subnet)

Or describe you task more detailed.