Intense disk IO (jbd2 and flush) blocks user interface

jdmcdaniel3 wrote:

> Happy to hear of your success and you can thank Carlos E. R. for
> finding this gem for us today.

Thanks Carlos! :smiley:

Chris Maaskant

On 2012-03-18 18:20, Chris Maaskant wrote:
> jdmcdaniel3 wrote:
>
>> Happy to hear of your success and you can thank Carlos E. R. for
>> finding this gem for us today.

I posted it 3 days ago :wink:

>
> Thanks Carlos! :smiley:

That’s OK, but if you want to know more of what it does, you have to ask
Lars Müller, I don’t know more. I suppose it is a new feature of the
kernel, and the option disables it. If this helps they want to know; so, as
this worked for you, please tell him ASAP.

It is possible that the documentation of the kernel
(/usr/src/linux/Documentation) says something else. I don’t have those
installed in 12.1


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Carlos E. R. wrote:

> That’s OK, but if you want to know more of what it does, you have to ask
> Lars Müller, I don’t know more. I suppose it is a new feature of the
> kernel, and the option disables it. If this helps they want to know; so,
> as this worked for you, please tell him ASAP.

Well i’m no expert, but i’ve been running my system for half a day on my
until now very stable system with this boot option and weird stuff happend
just a few minutes ago.
All of a sudden my sound stopped when i was playing music with amarok.
The player continued playing, only no sound.
When i openend pulse volume control i’ve got sound that was too loud for my
card to handle, very disorted.
I have backups so i could restore everything that anything to do with sound.
Still nothing.
Tried sound with a new user that i created, and still nothing.
Maybe i would have to turn my system of to reset something on my card.

So i did, clicked shutdown, the system was down and after a few seconds it
started to boot up all by itself.
Weird shit!

Just to make sure my card wasn’t broken i rebooted into windows and i worked
perfect.
Ok the card is good, so i booted again into linux, removed my card with
yast, rebooted, configured the card again, rebooted and still the same
broken sound.
But there was sound so i run alsamixer in a terminal, played with some
settings, and my sound came back OK :slight_smile:

Now i would think this was some program that messed up my sound settings,
but when my system starts to boot up all by it self just after i used some
kernel option that i don’t understand, i will keep it safe and not use that
kernel option again since i don’t know what i’m doing.

PS: i couldn’t find anything weird in the log files, but then again, i don’t
know exactly what to look for.


Chris Maaskant

On 2012-03-18 20:24, Chris Maaskant wrote:
> Carlos E. R. wrote:
>
>> That’s OK, but if you want to know more of what it does, you have to ask
>> Lars Müller, I don’t know more. I suppose it is a new feature of the
>> kernel, and the option disables it. If this helps they want to know; so,
>> as this worked for you, please tell him ASAP.
>
> Well i’m no expert, but i’ve been running my system for half a day on my
> until now very stable system with this boot option and weird stuff happend
> just a few minutes ago.

Instead of telling us, tell him.

Write that bugzilla, write it all, tell him in the mailing list, tell how
it broke later.

I have no idea what that option does, so tell and ask him!


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Carlos E. R. wrote:

> Instead of telling us, tell him.

I reply here for others that find this thread to see if this kernel option
is a safe thing to do.
>
> Write that bugzilla, write it all, tell him in the mailing list, tell how
> it broke later.

I don’t know if it broke anything!
Could be just a coincidence.
Writing something to bugzilla seems as complicated to me as building a
spacecraft.
I just don’t have the time to figure all this out.

Allthough it is the spirit of the open source community to do this kind of
stuff, i’m just a computer user.
My contribution used to be to help people out with configuring their system
in the days it was a real pain to get a linux distro running.
But now the big problems i see are very hardware/distro specific and the
easy problems are mostly answerd by others.

Also the trend that i see in the last years is that when something isn’t
working. the answer is to upgrade by some repository instead of breaking
down the problem.
So i don’t follow the usenetgroups/mailinglists anymore like i used to.
Most of what i see has got nothing to do with me.

Sometimes a thread gets my attention, like this one.
I read it, look if there is something in it for me.
In this case there was, so i thought.
The advice i saw maybe got me into trouble, i report that back here, where
the conversation is, for other people to read who are interested.
And that is where it stops for me.

like i said, i don’t have the time for this anymore.
I stick to default settings because they are good these days.
When i try something daring and it goes wrong, i revert to the defaults
again.
I don’t go figuring out why it didn’t work anymore.
Those days are over for me.


Chris Maaskant

On 2012-03-18 21:47, Chris Maaskant wrote:
> Carlos E. R. wrote:

> I don’t know if it broke anything!
> Could be just a coincidence.
> Writing something to bugzilla seems as complicated to me as building a
> spacecraft.
> I just don’t have the time to figure all this out.

It is not that complicated, and you are currently the only one that can do
the report. If you do, you will help the community. It is not often that
you have a developer eager to get your report to try solve an issue.

Let him do the hard work. We can help you with the details.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

I have the same problem - randomly some undetected app writes to the disk and freezes the whole system over. Holy ****, it really bothers. “transparent_hugepage” advice doesn’t fix the problem, so I think it’s not a source of the problem.

Here’s my /etc/fstab

/dev/system/swap swap swap defaults 0 0
/dev/system/root / ext4 acl,user_xattr 1 1
/dev/disk/by-id/ata-FUJITSU_MHY2200BH_K42WT862B5TM-part3 /boot ext4 acl,user_xattr 1 2
/dev/system/home /home ext4 acl,user_xattr 1 2
/dev/disk/by-id/ata-FUJITSU_MHY2200BH_K42WT862B5TM-part1 /media/C/ ntfs-3g rw,users,gid=users,umask=0002,locale=ru_RU.UTF-8 0 0
/dev/disk/by-id/ata-FUJITSU_MHY2200BH_K42WT862B5TM-part5 /media/D vfat users,gid=users,umask=0002,utf8=true 0 0
proc /proc proc defaults 0 0
sysfs /sys sysfs noauto 0 0
debugfs /sys/kernel/debug debugfs noauto 0 0
devpts /dev/pts devpts mode=0620,gid=5 0 0

On 2012-03-19 09:16, drunken cowboy wrote:
>
> I have the same problem - randomly some undetected app writes to the
> disk and freezes the whole system over. Holy ****, it really bothers.
> “transparent_hugepage” advice doesn’t fix the problem, so I think it’s
> not a source of the problem.

If it doesn’t help you, then it is not the same problem. However, you can
write in the mail list and talk to the dev there.

> Here’s my /etc/fstab

Next time, please post such text inside code tags (advanced editor).


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

OK, tried that. No improvement.

On 2012-03-19 18:16, gugrim wrote:
>
> OK, tried that. No improvement.

What is that you tried? :-?


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

Ooops, missed the quote. I tried “transparent_hugepage=never”.

/Gunnar