intellegacy crash X-Server for some application e.g. firefox

Hi

I am having some crashes of the X-Server. I am running opensuse 12.1/KDEF (=4.7.4) with all dotfiles cleaned out from home. Some application will send me back to the login screen. An incomplete list is

firefox, google-chrome, emacs (X-win, terminal is fine), gnucash

This raised some suspicion that it might be gtk related (although I could be totally wrong). So I tried gnome, but all I get after the log in screen is the background wallpaper, after a minute or so of no activity I have to kill the X-Server. Xorg.log and Xorg.log.old show no errors, so I started the X-Server form the console with startx and captured the output. The most relevant part seems to be


QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.
QDBusConnection: session D-Bus connection created before QCoreApplication. Application may misbehave.

Backtrace:
0: X (xorg_backtrace+0x37) [0x80a86b7]
1: X (0x8048000+0x64a0a) [0x80aca0a]
2: (vdso) (__kernel_rt_sigreturn+0x0) [0xffffe40c]
3: /usr/lib/xorg/modules/libfb.so (0xb70f3000+0x187ed) [0xb710b7ed]
4: /usr/lib/xorg/modules/drivers/intellegacy_drv.so (0xb720c000+0x63040) [0xb726f040]
5: /usr/lib/xorg/modules/drivers/intellegacy_drv.so (0xb720c000+0x63880) [0xb726f880]
6: /usr/lib/xorg/modules/drivers/intellegacy_drv.so (0xb720c000+0x64435) [0xb7270435]
7: X (0x8048000+0xe426b) [0x812c26b]
8: X (CompositePicture+0x21e) [0x8120b6e]
9: X (0x8048000+0xde66c) [0x812666c]
10: X (0x8048000+0xd9461) [0x8121461]
11: X (0x8048000+0x2d9d7) [0x80759d7]
12: X (0x8048000+0x207cc) [0x80687cc]
13: /lib/libc.so.6 (__libc_start_main+0xf3) [0xb743a003]
14: X (0x8048000+0x20ae1) [0x8068ae1]
Segmentation fault at address (nil)

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

Please consult the The X.Org Foundation support 
         at http://wiki.x.org
 for help. 
Please also check the log file at "/var/log/Xorg.0.log" for additional information.



lspci -nnk is


krailli:~ # lspci -nnk
00:00.0 Host bridge [0600]: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub [8086:27a0] (rev 03)
        Subsystem: Dell Device [1028:01c2]
        Kernel driver in use: agpgart-intel
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller [8086:27a2] (rev 03)
        Subsystem: Dell Device [1028:01c2]
00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
<snip>

I have to tell the Xserver to use the intellegacy driver in 50-device.conf to run a decent Xserver, opensuse on automatic configure only gave me the fbdev. Booting is with some vga address as only option.

Does any body know a solution?

Thanks
gl

What was it like before you added KDE 4.7.4 to 12.1? Did you upgrade to the standard 12.1 from 11.4 or do a clean install?

Hi -

I did a new installation, only left the home directories as they where (although I cleaned up all the dotfiles). The root user has the same problem and that is guaranteed a pristine suse user.

The upgrade to KDE 4.7.4 I did more or less in one go, so I am not sure if that is a possible cause. If needed I could revert back to the original…

gl

Well if it were my system, upgrading from 11.4 or clean install, I would have run the standard 12.1 (KDE 4.7.2) with no system variants (except for packman and must have driver alternatives) for a longish test period to establish some sort of baseline.

So I am still running 12.1 with KDE on my test partition only. I use the “intel” driver with hardly any problems so far. I will try “intellegacy” driver on that system and report back shortly. I have different chipset to yours. However, you may choose to delay your “revert back to the original” until I post the result. It’s up to you. :slight_smile:

Hi -

in the meantime I cleaned out all non-standard repos (except packman and libdvdcss) and zypper dup’ed the system. No change, still crashes and GNOME does not start (or needs longer than a minute). I also tried LXDE. It comes up with icons and panel, no background (or a black one). However, clicking anywhere crashes it. icewm comes up, but crashes when calling firefox.

I also tried to use a xorg.conf generated by Xorg -configure, no luck. The pure intel (no legacy) driver does not work. So, I guess my options are

  1. Do a proper clean re-install from DVD image, in case zypper dup does something unclean,
  2. Try to find a different combination of xorg/intellegacy versions, or even compile a driver myself
  3. Wait what the gurus have to say here and follow their advice :wink:

I hope for option 3, would be thankful for pointers on 2 and try to avoid 1 for now…

Thanks so far
gl

What exactly did you do to clean up all the “dotfiles” ?

Please do the following:

  1. Read http://forums.opensuse.org/english/get-technical-help-here/laptop/468968-firefox-konqueror-crash-opensuse-12-1-a-2.html#post2415736. Although not exactly your reported problem, it may help.

  2. Post your hardware configuration, especially your graphics and your PC manufacturer/model. The OP shows an Intel 865GM, so the above link should help. Then read (if you have not already), http://forums.opensuse.org/english/get-technical-help-here/hardware/468893-graphics-drivers-intel-intergrated-graphics.html.

  3. Post your GRUB (at least the entries that you boot with).

  4. Post the contents of /etc/X11/Xorg.conf.d/50-device.conf.

Well, I completed the intellegacy test on standard 12.1 KDE (upgraded from 11.4) and the only reason I can post this from that same system is that I am back on the “intel” driver.

With KDE apps (e.g. digiKam, konqueror browser, dolphin) no problem with “intellegacy” driver. :slight_smile:

With [gtk] apps (e.g. Firefox, SeaMonkey, Gimp) with “intellegacy” they crashed immediately on opening and X logged me out. :frowning:

It’s a bug for openSUSE bugzilla! Don’t waste any more time thinking about it. Raise a bug report if you need the "intellegacy driver.

Hi -

sorry, I meant I removed all files in home starting with a ‘.’ - I do that from time to time to get a clean start, I just move them into a new directory and let the system generate new ones.

  1. Read [http://forums.opensuse.org/english/get-technical-help-here/laptop/468968-firefox-konqueror-crash-opensuse-12-1-a-2.html#post2415736](http://forums.opensuse.org/english/get-technical-help-here/laptop/468968-firefox-konqueror-crash-opensuse-12-1-a-

2.html#post2415736). Although not exactly your reported problem, it may help.

Read that (before) and tried various settings (nomodeset with intel,intellegacy, no nomodeset etc). intel did not work, nomodeset for intellegacy does not seem to make a difference. but the bugreport Access Denied seems to be relevant and could mean that this is a xorg/intel problem (?)

  1. Post your hardware configuration, especially your graphics and your PC manufacturer/model. The OP shows an Intel 865GM, so the above link should help. Then read (if you have not already), http://forums.opensuse.org/english/get-technical-help-here/hardware/468893-graphics-drivers-intel-intergrated-graphics.html.

Laptop Dell Latitude D620, lspci -nnk is in the top post, is that enough?

  1. Post your GRUB (at least the entries that you boot with).

krailli:~ # more /boot/grub/menu.lst
# Modified by YaST2. Last modification on Sat Nov 19 12:51:18 CET 2011
# THIS FILE WILL BE PARTIALLY OVERWRITTEN by perl-Bootloader
# For the new kernel it try to figure out old parameters. In case we are not able to recognize it (e.g. change of flavor or strange ins
tall order ) it it use as fallback installation parameters from /etc/sysconfig/bootloader

default 0
timeout 8
##YaST - generic_mbr
gfxmenu (hd0,2)/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title Desktop -- openSUSE 12.1 - 3.1.0-1.2
    root (hd0,2)
    kernel /vmlinuz-3.1.0-1.2-desktop root=/dev/system/root nomodeset resume=/dev/system/swap splash=silent quiet showopts vga=0x317
    initrd /initrd-3.1.0-1.2-desktop

  1. Post the contents of /etc/X11/Xorg.conf.d/50-device.conf.

krailli:~ # more /etc/X11/xorg.conf.d/50-device.conf
<snip comments>
#
Section "Device"
  Identifier "Default Device"
#
Driver "intellegacy"
#
#  ## Required magic for radeon/radeonhd drivers; output name
#  ## (here: "DVI-0") can be figured out via 'xrandr -q'
#  #Option "monitor-DVI-0" "Default Monitor"
#
EndSection

@gluincth
Re 4:

krailli:~ # more /etc/X11/xorg.conf.d/50-device.conf
<snip comments>
#
Section "Device"
  Identifier "Default Device"
#
Driver "intellegacy"
#
#  ## Required magic for radeon/radeonhd drivers; output name
#  ## (here: "DVI-0") can be figured out via 'xrandr -q'
#  #Option "monitor-DVI-0" "Default Monitor"
#
EndSection

Same as mine, only for my test I had space(s) in first position(s) of uncommented lines.

If you have a “failsafe” boot entry that works, that will be your fallback to recover from the following suggested steps. (The “failsafe” boot will use the fbdev driver).

You may wish to proceed with consused suggestion of filing a bugzilla against the intellegacy driver.

I believe that the problem(s) here are the same as http://forums.opensuse.org/english/get-technical-help-here/laptop/468968-firefox-konqueror-crash-opensuse-12-1-a-2.html.

First, you need to insure that you can boot using “failsafe”.

Next, remove nomodeset from the GRUB entry you posted earlier. (===> Do NOT remove it from the “failsafe” entry!)

Boot the updated entry, specifying “3” (*sans * quotes) in the option line. This should boot to runlevel 3, and determine if KMS is working correctly. If you get a “black screen” (or any empty screen), then your problem is in the kernel, and NOT in Xorg. Conversely, if you get the init 3 login prompt, KMS is working correctly, and your problem is (at least partially) in Xorg.

For the kernel problem, reboot with your “failsafe” boot entry. Look at /var/log/messages for the following: dell_wmi or _wmi. If you see dell_wmi
reboot using “3” and acpi_backlight=vendor and acpi_osi=linux. Report back what you find.

If you find anothe _wmi, ror neither string, report that information back.
[/QUOTE]

[/QUOTE]

Hi -

First, thanks. I did as suggested. Result:

  1. Removing nomodeset, booting with to runlevel 3 shows black screen.
  2. Booting again into failsafe (runlevel 5), fgrep _wmi or fgrep dell on /var/log/messages finds nothing.

I willl continue to test more tomorrow and report back, it’s getting late and I have to start early tomorrow.

Again, thanks
gl

(BTW: I only thought, I had set and unset nomodeset in the tests I described above, because I did not see it at the boot prompt. Apparently it was always on, but only visible in the grub menu.lst line. Did not know that not everything was shown -sigh).

Hi -

The reason for the crash (at least under KDE) was the oxygen-gtk theme.

Details:
A tip of a colleague at work solved the issue. He told me that he experienced some crash with an application using a certain theme. Furthermore, my work laptop (Dell Latitude D430) has the same graphic card and does not crash the X server with gtk application, although they look somewhat ugly. So I checked the .gtkrc-2.0-kde4 file. Here as theme Oxygen-Molecule was given, but not installed. So apparently it falls back to something which looks suspiciously like good old Motif. Did the same with my laptop at home and voila, gtk applications work again. Installed afterwards the Oxygen-Molecule theme, and now have reasonable looking gtk apps under KDE.

GNOME still does not start, did not check LXDE yet (but I do not really need them). I will file a bug in bugzilla and could do some further testing if anyone is interested…

Thanks a lot for all your help
gl

Glad to hear you have resolved the problem. Are you still booting with nomodeset ? Are you interested in pursuing the resolution of this graphics problem, to wit, using the GA and display in full mode (intel driver) ?

I am willing to assist, but may be unavailable for a few days around December 25.

Hi -

I am still booting with nomodeset. Personally, I am satisfied with the graphics performance, desktop effects work, movies and streaming no problem. So I am a bit unclear on the benefits. However, if the exercise would be useful for other users, I am prepared to do further testing and try out things (the laptop is anyway not my main system and I use it to test e.g. KDE releases). I will also be away for some days around Christmas and am no hardware guy, so a bit of patience and explaining would be required on your side.

gl

Your choice. As I understand, the Dell D620 natively supports graphics in two (2) modes:

Displays: 14.1"WXGA (1280 x 800 resolution) 14.1"WXGA+ (1440 X 900 resolution)

I doubt that you are running at 1440 x 900 using nomodeset, as I have a PC with similar geometries, and nomodeset provides only 1024 x 768 with marginal, at best, desktop effects. I have heard of, but not actually seen, a nomodeset PC with 1280 x 800.

You may check your current display geometry, and determine whether any further change(s) are worthwhile.

Happy holidays!

OK let’s try to get to the bottom of this. First, more info that might be useful:

  1. I posted the output of hwinfo --gfx to SUSE Paste 88185748
  2. My Xorg.log is at SUSE Paste 66904223
  3. My current screen resolution (with nomodest and intellegacy) is 1280 x 800
  4. This is also the maximum resolution that is shown when I boot WIndows XP
  5. My Laptop is old, it is from 2006 or 2007

So, what would be the next steps?

And also happy holidays for you!
gl

Not been online much since that post. I don’t think I actually said “against the intellegacy driver”. That driver version may not be supported now, is particular to openSUSE as a package, and only used as a workaround. Yes, report the crashing apps and Segmentation fault error in the first posting, while using “intellegacy”. Mainly its a bug report against the original failure of KMS/“intel” driver on openSUSE 12.1, but also including info on problems with “intellegacy” as a failed workaround.

I now see there are some warning Markers “(WW) intellegacy(0)” and messages in the Xorg.0.log. That Xorg.0.log, if it applies to a run/test with the crashing gtk apps or Gnome desktop, should be attached to any bug report. Any logs showing original problem with KMS/Intel should obviously be attached.

That was a poor wording on my reply. The original wording was "*Raise a bug report if you need the “intellegacy driver. *”, with the report against the KMS/intel driver. My objective was to get away from use of the intellegacy driver, and to institute use of the intel driver using KMS.

One of these days, I will get this sorted. Perhaps we should write a FAQ addendum for Intel GMA’s (HD, 965, et al). Of course, such a suggestion is often perceived as volunteer offer. :wink:

No worries, just wanted to make the distinction as my original comment left some ambiguity. I can understand your objective to refocus investigations onto the current intel driver, a positive result there would be the best possible outcome. However it’s difficult to let go of the fact that intellegacy on 11.4 worked [for me], but is now involved in crashes on 12.1 with some types of apps. :slight_smile:

So summarising (from the point of view, who knows next to nothing about X11/graphic card drivers etc):

a) I should be able to run the XServer with the intel driver and KMS enabled, even with my rather old laptop
b) Instead, I have to manually add the intellegacy after the opensuse install, if I do not do it, I only get the fbdev graphics

a) is then a bug for the intel driver or at least for the combination of Xorg/intel version combination packaged with opensuse 12.1. b) could be a consequence of a), but in any case should be gracefully handled by the installation process of opensuse.

Correct?

In the meantime I found a bugreport for the oxygen-gtk crash and added a comment on that one.

Cheers
gl