Intel x3100--can't start x

I installed opensuse 11.0 on my new Thinkpad T61 which came with SLED installed. The graphics card is the Intel x3100 integrated card. When booting opensuse, x fails to start, and I get dumped to a text interface. I updated using the command line (zypper update) but that didn’t solve the problem. I assume there’s a problem with the driver. SLED and other distros I’ve tried boot into the graphical environment, though Fedora 9 has a bug in which icons and fonts fail to appear unless I use the vesa driver. Trying to switch to the vesa driver didn’t help with opensuse 11. Can anyone give me some help?

Have you tried running sax2 as root from the terminal?

The chipset should be supported out of the box. Try running sax with the specific intel driver specified, as root run: ’ sax2 -r -m 0=intel ’

I’m not familiar with the x3100, but maybe you will have better luck with the legacy i810 driver as I suspect SLED was using that driver? (instead of the intel one).

You could try running ’ sax2 -r -m 0=i810 ’ as root to tell sax to use the legacy driver.
If the i810 works the downside is 3D support is not an option in there using openSUSE 10.3 and up…

Running plain “sax2” as root worked! Thanks for the help!