Intel WiFi Link 5100 AGN issues

I have found several threads on trying to get this wireless card working; however, mine seems to be noticed by openSUSE, but remains nonfunctional. I can touch my wireless button on my Asus Aspire 6930 and it will check and uncheck the box for wireless access in the taskbar for the network manager, which seems like it would be in working condition. When I open the network manager, the tab for wireless is grayed out. The only available tabs are for wired access and VPN. In YaST it shows my Atheros card (wired ethernet port), but no Intel WiFi Link 5100. :frowning: It’s like it is there, but also not.

Network Settings:
Atheros AR8121/AR8113/AR8114 PCI-E Ethernet Controller (Not connected)
BusID : 0000:09:00.0
Unable to configure the network card because the kernel device (eth0, wlan0) is not present. This is mostly caused by missing firmware (for wlan devices). See dmesg output for details.

I have gathered most of the required information to get some help, and I hope it’s enough to get the wireless working. It seems to me - if I am reading this right - that it is being disabled for some reason. I haven’t dabbled in Linux in quite some time, so I might as well be considered a beginner.

Here is all the information I could find on my wireless card:

110: udi = '/org/freedesktop/Hal/devices/pci_8086_4232'
  pci.subsys_vendor = 'Intel Corporation'
  linux.hotplug_type = 2 (0x2)
  linux.subsystem = 'pci'
  info.subsystem = 'pci'
  info.product = 'Wireless WiFi Link 5100'
  linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1c.3/0000:07:00.0'
  info.parent = '/org/freedesktop/Hal/devices/pci_8086_2946'
  pci.linux.sysfs_path = '/sys/devices/pci0000:00/0000:00:1c.3/0000:07:00.0'
  info.udi = '/org/freedesktop/Hal/devices/pci_8086_4232'
  pci.product_id = 16946 (0x4232)
  pci.vendor_id = 32902 (0x8086)
  pci.subsys_product_id = 4609 (0x1201)
  pci.subsys_vendor_id = 32902 (0x8086)
  pci.device_class = 2 (0x2)
  pci.device_subclass = 128 (0x80)
  pci.device_protocol = 0 (0x0)
  pci.vendor = 'Intel Corporation'
  info.vendor = 'Intel Corporation'
  pci.product = 'Wireless WiFi Link 5100'
<6>    7.231485] iwlagn: Intel(R) Wireless WiFi Link AGN driver for Linux, 1.3.27kds
  <6>    7.231489] iwlagn: Copyright(c) 2003-2009 Intel Corporation
  <6>    7.246948] Linux video capture interface: v2.00
  <6>    7.250485] uvcvideo: Found UVC 1.00 device Acer Crystal Eye webcam (064e:a103)
  <6>    7.250778] iwlagn 0000:07:00.0: enabling device (0000 -> 0002)
  <6>    7.250812] iwlagn 0000:07:00.0: PCI INT A -> GSI 19 (level, low) -> IRQ 19
  <7>    7.250845] iwlagn 0000:07:00.0: setting latency timer to 64
  <6>    7.250947] iwlagn 0000:07:00.0: Detected Intel Wireless WiFi Link 5100AGN REV=0x1000001
  <3>    7.251025] iwlagn 0000:07:00.0: EEPROM not found, EEPROM_GP=0x810cc800
  <3>    7.251038] iwlagn 0000:07:00.0: EEPROM not found, EEPROM_GP=0x810cc800
  <3>    7.251045] iwlagn 0000:07:00.0: Unable to init EEPROM
  <6>    7.251080] iwlagn 0000:07:00.0: PCI INT A disabled
  <4>    7.251100] iwlagn: probe of 0000:07:00.0 failed with error -2
31: PCI 700.0: 0280 Network controller
  [Created at pci.318]
  UDI: /org/freedesktop/Hal/devices/pci_8086_4232
  Unique ID: aK5u.PDTfCPuk4g7
  Parent ID: Z7uZ.C0MkgLA2c85
  SysFS ID: /devices/pci0000:00/0000:00:1c.3/0000:07:00.0
  SysFS BusID: 0000:07:00.0
  Hardware Class: network
  Model: "Intel Wireless WiFi Link 5100"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x4232 "Wireless WiFi Link 5100"
  SubVendor: pci 0x8086 "Intel Corporation"
  SubDevice: pci 0x1201 
  Memory Range: 0xba000000-0xba001fff (rw,non-prefetchable)
  IRQ: 19 (47810 events)
  Module Alias: "pci:v00008086d00004232sv00008086sd00001201bc02sc80i00"
  Driver Info #0:
    Driver Status: iwlagn is active
    Driver Activation Cmd: "modprobe iwlagn"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #21 (PCI bridge)
 07:00.0 Network controller: Intel Corporation Wireless WiFi Link 5100
        Subsystem: Intel Corporation Device 1201
        Flags: fast devsel, IRQ 19
        Memory at ba000000 (64-bit, non-prefetchable) [size=8]
        Capabilities: <access denied>

If there is anything else needed, let me know. I have this dual-booting with W7, and I only have wireless access to the router.[/size]

I’m currently struggling with my Intel WiFi Linux 5300 AGN. thread is here: Intel PRO/Wireless 5300 AGN stopped working for me with openSUSE-11.2 - openSUSE Forums
… except in my case, after I got mine working, I start getting freezes. I’m suspicious that a recent kernel update caused the problem, and I may roll back my kernel to test that theory.

The bright side to this is that is that the wireless works very well in openSUSE-11.3 milestone releases with the 2.6.34 kernel as patched by SuSE-GmbH.

Ah, I was considering checking out the milestone due to a possibility of it fixing my wireless issue. I will give it a go! Thanks.

Well, that seems to have done it, but I’m curious as what was making it not work. If anyone can tell me, that would be great. Thanks again.

Did you have to do anything to get the wifi to work or was it more or less automatic. I have a Dell E6400 with an Intel 5100 card in it, but still no go with 11.3 milestone7.

What I did on the Intel 5300 (which is very similar to the 5100) is boot to the liveCD (for M6, M7 and now RC1). Then the 1st thing I did was I disabled Kwallet via Menu > configure desktop > advanced > KDE Wallet and disable it. Then exit “configure desktop”.

Then I went to the bottom right “network manager” icon and added our home LAN. It saw the “ssid” which I selected, and it noted WPA encryption which was correct. I selected ‘automatic connection’ and entered my password and applied that (via ok ? … I can’t recall). It then asked for the password again, and I entered that. And then it failed to connect. :\ Typically buggy behaviour.

I then opened a terminal, determined the pid of the knetworkmanager and I killed it via " kill -9 pid# " (wehre pid# is the actual number). I then restarted it in the same konsole by typing: 'knetworkmanager" and wireless then just worked (as the selection of “automatic connect” from before immediately automatically applied). :slight_smile:

That was on the KDE live CD. The Gnome may be easier as my experience is the Gnome wireless manager has been functioning better than the KDE one for a few openSUSE releases.

On openSUSE-11.2, I installed the 2.6.31.5 kernel (in a dual boot with the 2.6.31.12-0.2 kernel) and wireless works in the 2.6.31.5 kernel of 11.2. SuSE-GmbH did something in their 2.6.31.12 kernel that broke the wireless (5300AGN). I wrote a bug report on that.