Intel raid installation works on Suse Enteprise 11 but not Open Suse 13

Hi. I have managed to install Enterprise Suse 11 SP2 using the provided Intel Deployment Assistant but I can’t seem to be able to install Open Suse 13.1 I keep getting “No Disks Found”

The server/board is S2600GZ with ESRT2. I googled around and some people say disable the raid and use software. But same issue "No Disks Found.

If I use the Suse CDs as downloaded from suse websites Enteprise or Open they do not detect the raid. Only if I use the Intel Deployment CD for Enterprise Suse which at some point asks for the SE 11 SP2 CD

I downloaded the latest drivers from Intel which are from 2013, but installation can’t seem to find the drivers on the USB. The README of the downloaded driver sugests that the raid is LIS Mega Raid. I tried expert install and tried to load the module manually but that didn’t seem to work either.

1- What is intel doing that the default Suse installation disks can’t do. Where can I look and what can I provide here for people to help debug?
2- Can I use the intel drivers which are for Enteprise 11 with Open Suse 13 and if so how do i format the USB and what structure do i have to use for installation to detect?

If it is real hardware RAID then it should be transparent. But if it is BIOS assisted (ie FAKE) RAID all bets are off since this can be pretty proprietary.

It may be possible to use the Intel drivers on openSUSE but it is above my pay grade.

If it were me I’d do a low level format on the drive(s) and try again.

If this is a commecail installation you are better off with SES rather the 13.1 since openSUSE changes often and normally you want long term support in a commercial enterprise

It’s not a commercial installation it’s a research box.

I figure embedded ESRT2 is software raid no? I tried disabling it but maybe I did it wrong?
What should the bios setting be for ESRT2

Well not having that hardware at my disposal I have no idea. Maybe you might luck out and someone might have some experience with that hardware could show up… Server boxes can be a real pain.

Ok figured it out! I was able to disable ESRT2 FAKE Raid

In Bios

ACHI Controller: Set to ENHANCED
SAS Controller: Set to ESRT not ESRT2

Also make sure to clear the RAID settings if you set anything using the utility provided with BIOS.