Intel Pro Wireless

Yet again, I am having issues with openSuSE’s so called support of the Pro Wireless 2200BG chipset. I have tried everything i can think of to get it to work, and despite the fact that the HCL says 11.1 has built in compatibilty, it will not work. Firstly, it was originally recognized as Wireless Network Device, and so I tried deleting that in order to get the proper settings. It showed up as the Intel Pro Wireless 2200BG. I set up the connection, and it still wouldn’t connect. I have tried reinstalling ipw-firmware, and still no success. I realized after a while that the device was named eth0, and so i changed it to wlan0 just in case that was an issue. I have used ifup and Network Manager (I use GNOME), and still have had no success. ifup reports

    wlan0     device: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
DHCP4 client (dhcpcd) is running
. . . but is still waiting for data
wlan0 is up
5: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:0e:35:b1:88:d3 brd ff:ff:ff:ff:ff:ff
    inet brd scope global wlan0
    inet6 fe80::20e:35ff:feb1:88d3/64 scope link 
       valid_lft forever preferred_lft forever
    wlan0     IP address:
Configured routes for interface wlan0: - wlan0  
Active routes for interface wlan0:  proto kernel  scope link  src  scope link
  default via
1 of 1 configured routes for interface wlan0 up
wlan0     IEEE 802.11g  ESSID:"*****"  Nickname:"linux-3y4r"
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:18:39:84:CD:2C   
          Bit Rate:54 Mb/s   Tx-Power=20 dBm   Sensitivity=8/0  
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:****-****-** [2]   Security mode:open
          Power Management:off
          Link Quality=87/100  Signal level=-40 dBm  Noise level=-86 dBm
          Rx invalid nwid:0  Rx invalid crypt:174  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:15   Missed beacon:0

Any help i can get to make this work would be great. A laptop without wireless is kind of useless.

Maybe check here:
Intel® PRO/Wireless 2200BG Driver for Linux

What are you getting for this:

/sbin/lspci -nnk

Odd, I installed (the original) 11.1 32bit on my Toshiba tecra m2 a few weeks ago (exact same wireless card), and it worked straight away. Even before updates!

This was the DVD version, I believe the liveCD doesn’t have the wireless modules :(.

Always best to go with the DVD. Good point @growbag


Well both my Thinkpads work just fine with openSuse’s “so-called” (rightly called?) support - one 2200BG with the “original” 11.1 install and a 2915ABG with the 11.1 KDE4 re-spin. Out of the box and with subsequent kernel updates. Just like the HCL suggests !

Sure, both are labelled eth1 (and not wlan x) (eth0 being the wired i/f in each case), but recognized as requiring and using ipw2200 driver.

From the output posted it looks like it’s recognized there too and has acquired an IP. But is that a reference to IPv6 in there? Could it be unwanted IP6 that’s causing connection issue?


And these cards work “out of the box” since SuSE 9.2.

Yup, iwp2200 registers it’s interface as ethX by default, so this is perfectly normal (It’s just a name, if you like you can even call it after your mom’s maiden name).

Ahhh. That would be why. I had already downloaded the LiveCD for something else, and so I installed off of that. I shall try re-installing using the DVD. Just gotta find a blank dvd. Thanks

Where on earth did you get that from?

Even if it were true, then how do you explain the presence of a wireless interface?

If the CD would not contain “wireless modules”, then it would miss at least one kernel package, I bet you this is not the case (assuming the CD itself is OK and was burnt without errors).

No, certainly not.

Your outputs even show your device not only present but actually connected to the wireless AP and having an IP address.

Instead of most likely wasting bandwith and time on dowloading the DVD, you should consider fixing your setup and not ignore what you were told by “ignz” for a start.

I was not ignoring it, I did not have access to the machine in question earlier. But it is most definitely not an IPv6 issue. Everymachine on the network is using IPv6, and the router most definitely supports it. I do feel that it could be an issue with the live cd, since 11.0 supported the 2200BG on install, and i used the DVD. I know it isn’t a hardware issue, the wireless card was working fine 5 minutes earlier when I was running a different OS. As far as I can tell, it is a firmware or driver issue. I shall check the lspci and report back.

If it were a driver of firmware issue, you would not even have a wireless device (no matter if it was called ethX or wlanX) showing up and most certainly you would not have outputs showing the device connected to the AP and even having an IP address.

I have no idea what the issue was, but it is working now. Very very slow mind you, but it is working. I haven’t the slightest clue what changed, but something did.

For the third time, try disabling IPv6 and reboot.

If that does not help you can always reenable it.

I have no idea what the issue was, but it is working now. Very very slow mind you, but it is working. I haven’t the slightest clue what changed, but something did.

Posting “it doesn’t work” on a public forum or logging a support ticket usually does the trick - always works immediately afterwards :wink:

But seriously, although your local router might “support” IPv6, that’s all well and good for a pure v6 local network. How is it handling the translation to the rest of the v4 world?

So I think we’ve established that openSuse does actually happily support the 2200 out of the box (CD or DVD install), just like it says on the tin (or HCL), even if it doesn’t give it a “wlan” label. If the card wasn’t supported and the correct driver not installed you wouldn’t be getting a connection, slow or otherwise.

It’s a config issue and switching off the default “enable IPv6” option is the first obvious step.