Intel Pro Wireless BG 2200 11.0 issues

I upgraded a openSUSE 10.3 on my laptop with a Intel Pro Wireless BG 2200 built-in card (Gateway M460) and it worked sometime but was mostly broken (as compared to oS 10.3) so I installed a clean network install (KDE 3.5.x) and now the wireless does not work at all…

what kernel version are you using? have you tried to compile the wireless drivers yourself?

no, I have not. The only driver I can find is a generic one from Intel. Does openSUSE 11 not build the kernal correctly as it did in 10.3. ?

for me It worked out of the box with openSUSE 11 and KDE 3.5. Do you see the interface with “ifconfig”? If not check, if you have ipw-firmware installed by typing “zypper info ipw-firmware” or look for it in Yast. Then, if your lsmod looks like mine try “iwlist scan” as root. Maybe there you find some networks. Here it is:

 lsmod | grep ipw
ipw2200               158792  0
ieee80211              48456  1 ipw2200
firmware_class         25984  3 microcode,pcmcia,ipw2200

I hope my late-night post helped a little and you don’t find it too bad…

using zypper info command. I find that ipw-firmware is not installed. I will try to install it in yast.

just installed ipw rebooted, can see networks but when trying to connect KNetwork crashed…

does anyone have a step by step process to delete/ reinstall/ and reconfig this wireless card in openSUSE 11?

Very sorry for bringing this very old thread back to life, but just wanted to say that on a Compaq nc6220, running OpenSUSE 11.2 milestone 8, I had to do a

zypper install ipw-firmware

for wifi to work! Thanks for the tip, saved my day!