Intel PRO/Wireless 3945ABG again


I have this Intel Corporation PRO/Wireless 3945ABG on HP Compaq 6720s. It worked flawlessly on openSUSE 10.3. After upgrade to openSUSE 11, I have to either ifdown/ifup it or at least scan APs using iwlist after each boot. Without this annoying procedure, ifconfig shows everything is OK, but iwconfig shows that access point is invalid and wireless connection doesn’t work. Currently, I’m using iwl3945 module, and as I remember the module ipw3945 was used in 10.3, but it is not available in the distribution anymore.

Any suggestions how to fix this?

I have problems finding wireless ap too. It worked on the rc1, buggy, but worked. I reinstalled the opensuse 11 with the gold release and now I do not have any wireless in knetworkmanager. I am using the same card, on a lenovo r61i. The system settings shows the card has no problems.
Help :slight_smile:

you have the exact same card (and laptop as well!) as i do. it’s a nice laptop. this is odd, since suse 11 for me is working flawlessly. perhaps you need to check your set up in yast? what encryption method are you using for the wireless network? you should be able to not have traditional method with ifup, but control with knetworkmanager, it works fine for me, so no reason why it shouldn’t for you, with exactly the same hardware. except you may have more or less ram etc (im on 2gb) but this wouldn’t effect wireless.

I didn’t use knetworkmanager in several previous versions of openSUSE, since it didn’t work once when I tried it. After your suggestion I switched to knetworkmanager, and as you told-it works quite fine! Thanks!

yup, i too had big problems with knetworkmanager on previous suse versions, in 10.3 i used wifi-radar and that worked flawlessly, but now, knetworkmanager works fine. anyway…glad you got it sorted.

Network Manager works much better than it used to, and is more flexible. I have no problems using it with the same card. I don’t even need to use Profile Manager anymore when using various access points.

Hi there…

I’m new in here, and I’ve problems with that card, too, but on a Samsung Q45…
Well I didn’t want to start a new Thread on same issues so I post my problem here if that’s ok…

So here the issue:

On 10.3 the networkcard worked out of the box using networkmanager…and now I installed 11.0 and it doesn’t find any networks.
Here are some outputs for tracking…

/sbin/lspci -nn says:

2:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 3945ABG Network Connection [8086:4222] (rev 02)

hwinfo --wlan says:

08: PCI 200.0: 0282 WLAN controller
   [Created at pci.310]
   UDI: /org/freedesktop/Hal/devices/pci_8086_4222
   Unique ID: y9sn.EjEjpkprfHE
   Parent ID: z8Q3.yjCEx5JbDxB
   SysFS ID: /devices/pci0000:00/0000:00:1c.0/0000:02:00.0
   SysFS BusID: 0000:02:00.0
   Hardware Class: network
   Model: "Intel PRO/Wireless 3945BG Network Connection"
   Vendor: pci 0x8086 "Intel Corporation"
   Device: pci 0x4222 "Pro/Wireless 3945BG Network Connection"
   SubVendor: pci 0x8086 "Intel Corporation"
   SubDevice: pci 0x1034 "PRO/Wireless 3945BG Network Connection"
   Revision: 0x02
   Driver: "iwl3945"
   Driver Modules: "iwl3945"
   Device File: wlan0
   Features: WLAN
   Memory Range: 0xf0300000-0xf0300fff (rw, non-prefetchable)
   IRQ: 220 (no events)
   HW Adress: 00:1f:3c:1c:76:3b
   Link detected: no
   WLAN channels: 1 2 3 4 5 6 7 8 9 10 11
   WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462
   WLAN encryption modes: WEP40 WEP104 TKIP CCMP
   WLAN authentication modes: open sharedkey wpa-psk wpa-eap
   Module Alias: "pci:v00008086d00004222sv00008086sd00001034bc02sc80i00"
   Driver Info #0:
     Driver Status: iwl3945 is active
     Driver Activation Cmd: "modprobe iwl3945"
   Config Status: cfg=no, avail=yes, need=no, active=unknown
   Attached to: #18 (PCI bridge)

and something strange I recently found was…

dmesg says:

iwl3945: Microcode SW error detected. Restarting 0x82000008.
iwl3945: Error Reply type 0x00000005 cmd REPLY_SCAN_CMD (0x80) seq 0x4418 ser 0x0000004B
iwl3945: Can't stop Rx DMA.

My homenetwork is WPA-PSK encrypted is that is of relevance…

I really hope to get some help here, since I tried nearly everything I read in other forums…nothing worked yet…

Have you tried entering the SSID of the access point manually in Network Manager?

Yes I tried that all day long…

what happens is…

I go like
-“New connection” → “wlan0”
-enter my SSID
-Select WPA-PSK–>enter my passphrase
-don’t touch the rest of the settings
-it automatically tries to connect but fails
-the specified network appears in the dialog “connect to other network” but hat signal=0 and fails on connecting

-a thing I recognized is, that when I enter the
connections preferences again, the key looks very different to the one I entered…don’t know if that’s got something to say…

Occasionally, I have to keep trying to reconnect in order to get the connection to come up. Most of the time it just connects when I login, but as I said, sometimes I have to make it reconnect many times before it works. And I also get the WPA-PSK change, but that is fine. It eventually does work.

I tried like 100 times today…didn’t work so far…got to be something else

have you tried changing to traditional ifup method ? have you disabled ipv6 ( a common irritant when trying to connect ) check your firewall


shouldn’t need ifup with this card on suse 11, i don’t and it works fine, i’m typing this on a wpa-psk network right now. like Andy said, disable IPv6 as this can be a problem. check card configuration in yast would be my first bet. as i have the same card i will list my configuration below:

global: user controlled with network manager,ipv6 disabled.

now, edit your card:

general tab: activate at boot, firewall external zone, device control for non-root user via kinternet is checked (i.e. with cross in in).

address: by DHCP

hardware: module name iwl3945

click next and enter your SSID settings.

if this doesn’t work it’s not the set up. perhaps try disabling the security, then try to connect, then re-enable it. this worked for me with suse 10.3… remember the problems Andy? :eek:

hope this helps.

Well I now tried ifup…didn’t work…
Then I tried thestig’s advices didn’t work either…

So far…nothing worked…

are you dual booting with windows? sometimes windows can disable the card from connecting. there must be something wrong in your set up if i have the exact same card as you and i can connect and you can’t, like the initial poster can now connect…

you’re using knetworkmanager to connect, correct?

Yeah, I’m using knetworkmanager, and yeah I’m dual booting with Windows Vista…but it’s only still on there cause I neet I-Net at University…and since it doesn’t work with SuSe so far I gotta keep Vista…

So…what could be wrong with the setup in Vista, that would prevent SuSe from connecting?

I now set Vista to not beeing able to shut down the wifi card for saving energy…
And read things about AES encryption, cause I use that one, so I unchecked the TKIP things…but no connection for me so far…

Still I wonder about the Microcode SW error dmesg showed me…isn’t it possible that this is the problem?

here again for reference:


iwl3945: Microcode SW error detected. Restarting 0x82000008.
iwl3945: Error Reply type 0x00000005 cmd REPLY_SCAN_CMD (0x80) seq 0x4418 ser 0x0000004B
iwl3945: Can't stop Rx DMA.

i can’t understand why you would be getting these problems. as the the vista i-net program, there are work arounds for linux of course, deltaflyer seems to know all about these, he’s the wireless expert here. the dmesg error is very odd, and as i said i can’t understand the problems, since it’s the same card i have. what is the exact encryption type you are using again? just wpa-psk?

have you tried resetting the encryption on the router, and seeing if you can connect without any encryption…that would rule out one more variable.

Problem is solved now - I’ve installed compat-drivers few minutes ago and everything’s working fine now.

Thanks a lot for your help though!