Intel pro wireless 3945 Suse 11.0

Hallo
There are many posts around this subject but unfortunately no
proposed solution works for me.

The behaviour of the wireless card is erratic. First, there is
no green ligth on, it worked fine in SUSE10.2. Someone suggested
to load the compat drivers. OK, with them the green light shines, but the network manager either doesn’t find my wireless
router or it doesn’t connect to it in the rare occasions when
it finds the router (see below).

With the standard suse-11 drivers, no light and some network.
Most of the time, knetworkmanager does not see my wireless
router. After a number of restarts, and turning the card off
and on with FnF2 a couple of times, it sometimes detects my
wireless router and makes a connection. The connection is then
stable. This is the situation now, that’s why I can post this.

iwlist wlan0 scan gives an erratic response. There are four
wireless networks in the area. iwlist sometimes detects all
four, sometimes just one or two. Most strange, while I am
connected to the network, iwlist may not see my router but it
detects some of the other routers in the area. Below there
are two outputs of iwlist. The first one detects two networks,
Cell 02 is my own. Next run 15 seconds later, it just detects
one network, not mine!

Solutions?

The compat-drivers people suggest that with kernel version
2.6.26 onwards the problem is solved. My suse-11 distribution
has kernel 2.6.25.16. Is it possible to upgrade? Will suse 11.1
have an upgraded kernel? Will this really solve the problem?

Thank you for listening,

m.natiello

HW: Dell xps m 1710
0c:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
0c:00.0 0280: 8086:4222 (rev 02)

iwconfig:
wlan0 IEEE 802.11g ESSID:“syren”
Mode:Managed Frequency:2.457 GHz Access Point:
00:13:46:52:32:F7
Bit Rate=54 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Link Quality=74/100 Signal level=-60 dBm Noise level=-94 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

iwlistx2:

wlan0 Scan completed :
Cell 01 - Address: 00:18:F6:70:44:03
ESSID:“TeliaGateway00-18-F6-70-44-03”
Mode:Master
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=57/100 Signal level=-74 dBm Noise level=-96 dBm
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:tsf=000000b3dcf564cb
Cell 02 - Address: 00:13:46:52:32:F7
ESSID:“syren”
Mode:Master
Channel:10
Frequency:2.457 GHz (Channel 10)
Quality=72/100 Signal level=-62 dBm Noise level=-96 dBm
Encryption key:off
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=00000004dc887d95

wlan0 Scan completed :
Cell 01 - Address: 00:18:F6:70:44:03
ESSID:“TeliaGateway00-18-F6-70-44-03”
Mode:Master
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=58/100 Signal level=-73 dBm Noise level=-96 dBm
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:tsf=000000b3de4cc5f2

Hi
You might try repositioning your AP aerial as it may be some
interference and then rescanning. I use to have three AP’s around here,
with a bit of repositioning and channel changing I don’t get any issues.

To quote Larry
"A 802.11b/g signal occupies 5 channels, thus somebody on channel 1
uses -1 to 3, someone on channel 6 uses 4 to 8, etc. That is the
reason that channels 1, 6, and 11 are recommended to reduce overlap
and interference. "


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 7:44, 1 user, load average: 0.02, 0.08, 0.12
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Thanks but mine is not an antenna problem. The system worked perfectly
well one our before, when I was on suse 10.2. No inconsistencies whatsoever. Problems started with the upgrade to 11.0. Besides,
the fact that the green wifi-light on the laptop is not on although the
card is working, cannot be solved by moving the antenna or changing channel. The whole thing seems to be a driver problem in 11.0

M. Natiello

I would have thought the firmware from the iwl3945-ucode rpm would have
got things up and running then?


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel 2.6.25.16-0.1-default
up 4:46, 1 user, load average: 0.08, 0.04, 0.04
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Just upgraded to 11 on my laptop and used this get my 3945 working. Solution/How To For intel 3945 a/b/g wireless conn. issues - openSUSE Forums

FWIW, the newer iwlwifi driver doesn’t support the wifi indicator, whereas the old(er) ipw3945 did. I’m in the same boat; no wifi indicator light, but the interface works. This was a conscious decision, apparently, something to do with the polling in the driver required to keep the light lit reducing battery power, IIRC. There are hacks on the web that can patch against the driver to enable the indicator, but they will require compiling the driver and will not be formally supported.

I feel your pain. It’s a bit ridiculous that Intel can’t get the indicator working effectively in the newer driver, but given that the newer driver does work much better (IMHO), it’s a simple tradeoff.

I did have similar symptoms with the newer driver initially in openSUSE (ie. sometimes knetworkmanager simply wouldn’t see my network to connect and I couldn’t find them with iwlist scan), but that disappeared after a couple of updates. Sorry I can’t help you on that part.

Cheers,
KV

Dear forum members,

I appreciate how helpful you are. Unfortunately, no
suggestion so far has worked for me. I can live without
the green light for a while, but the erratic behaviour of
the card, driver or software is bothering. I believe I have
updated versions of the software, downloaded yesterday
from a suse mirror in Germany.

The compat-drivers do not seem to work properly. They
improve the original drivers in all respects except
connectivity: green light is on, iwlist never fails to detect
all networks in the area, but knetworkmanager will not connect to my network although it is seeing it all the time. Nor will ifup. Perhaps this is just because I don’t ask
the proper question to ifup? Is there a howto for
network connection bypassing yast?
Back to the original drivers: no green light. iwlist gives
different answers each time it is run, occasionally finding
my network or any other. ifup is not an option since the
system may fail to see the network at the moment it
is run. knetworkmanager connects to my network after a
couple of manual restarts of the card and the software.

No solution in sight ?

Thanks

else where wrote:

> I did have similar symptoms with the newer driver initially in openSUSE
> (ie. sometimes knetworkmanager simply wouldn’t see my network to connect
> and I couldn’t find them with iwlist scan), but that disappeared after a
> couple of updates. Sorry I can’t help you on that part.

There is something strange here with a similar situation. If I’m at the far
end of the house my AP signal gets a bit puny - about the same level as 3
or 4 of the neighbors - and iwlist scan will see only a couple of the
outside signals. To get my own AP to show up (and connect) I have to go
stand right in front of it and switch the adapter off and on a few times to
get it to finally connect after which it holds the connection until the
signal gets really weak even out in the yard. S2M suspends and even in
very weak signal areas I get a reasonably reliable re-connect on wake up.
None of the adjacent channels are interfering - they all use their default
ch 6 or 9 while I use 11 - but the initial scan seems to want only a
limited number of channels seen and often loses the weak sisters. If the
weaker signals don’t show on the initial scan, chances of getting them seen
on subsequent scans are nil - looks like some kind of threshold and cache
strategy with quirks to me.


Will Honea

Hallo

Some update on the problem. I loaded the compat-drivers and
attempted to restart with ifup since network manager did not
succeed.
I use the compat-old drivers since my kernel is 2.6.25.16.
Green light is on, iwlist works fine with no irregularities
whatsoever. BUT… the network does not come up. My card cannot
associate to the access point of the router. iwconfig says:
Access point: not associated
Even if I try to force association with iwconfig wlan0 ap HWADD.
In dmesg you see that it tries to associate 4 times and then
times out.
ALSO: The route command is slow. It may take a minute or more to
answer. Then it shows the “proper” lines, i.e., those I would
expect. Perhaps both facts are consequence of the same problem,
i.e., it cannot associate because route does not answer in time,
for reasons still unknown to me.
At this point it looks like a configuration mistake from me.
Hope somebody recognises it and helps.

Yours,
M.Natiello

Hello everybody,

My wireless connection can see different AP but doesn’t connect to any of them.

I have read and follow the sticky, and actually that’s how I was able to see AP, but still not connecting.

I tried to connect through Yast and ifup (not sure how works) but didn’t succeed.

Please help, I been trying to make it work for 5 days now :slight_smile:

Some outputs:

hwinfo --wlan
07: PCI 600.0: 0282 WLAN controller
[Created at pci.310]
UDI: /org/freedesktop/Hal/devices/pci_8086_4222
Unique ID: y9sn.xDGkhUDfcCA
Parent ID: Z7uZ.2DtjpW0qNEE
SysFS ID: /devices/pci0000:00/0000:00:1c.3/0000:06:00.0
SysFS BusID: 0000:06:00.0
Hardware Class: network
Model: “Intel PRO/Wireless 3945ABG Network Connection”
Vendor: pci 0x8086 “Intel Corporation”
Device: pci 0x4222 “PRO/Wireless 3945ABG Network Connection”
SubVendor: pci 0x8086 “Intel Corporation”
SubDevice: pci 0x1001
Revision: 0x02
Driver: “iwl3945”
Driver Modules: “iwl3945”
Device File: wlan0
Features: WLAN
Memory Range: 0xc2000000-0xc2000fff (rw,non-prefetchable)
IRQ: 4345 (no events)
HW Address: 00:1f:3c:31:9b:2a
Link detected: no
WLAN channels: 1 2 3 4 5 6 7 8 9 10 11 36 40 44 48 52 56 60 64
WLAN frequencies: 2.412 2.417 2.422 2.427 2.432 2.437 2.442 2.447 2.452 2.457 2.462 5.18 5.2 5.22 5.24 5.26 5.28 5.3 5.32
WLAN encryption modes: WEP40 WEP104 TKIP CCMP
WLAN authentication modes: open sharedkey wpa-psk wpa-eap
Module Alias: “pci:v00008086d00004222sv00008086sd00001001bc02sc80i00”
Driver Info #0:
Driver Status: iwl3945 is active
Driver Activation Cmd: “modprobe iwl3945”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #19 (PCI bridge)

iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11abg ESSID:""
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Tx-Power=15 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

iwlist wlan0 scan
wlan0 Scan completed :
Cell 01 - Address: 00:1B:63:24:71:D9
ESSID:“NetNut”
Mode:Master
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=43/100 Signal level:-83 dBm Noise level=-127 dBm
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=000000082e54718d
Extra: Last beacon: 1012ms ago
Cell 02 - Address: 00:18:39:30:AC:9A
ESSID:“traadloes”
Mode:Master
Channel:3
Frequency:2.422 GHz (Channel 3)
Quality=71/100 Signal level:-63 dBm Noise level=-127 dBm
Encryption key:on
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=0000007c976a9177
Extra: Last beacon: 792ms ago
Cell 03 - Address: 00:12:17:DE:39:B8
ESSID:“disable”
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=63/100 Signal level:-69 dBm Noise level=-127 dBm
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP

                    Pairwise Ciphers (1) : TKIP
                    Authentication Suites (1) : PSK
                Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                          24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                          12 Mb/s; 48 Mb/s
                Extra:tsf=000000142b07f18d
                Extra: Last beacon: 96ms ago
      Cell 04 - Address: 00:14:D1:C3:A6:6C
                ESSID:"JNET"
                Mode:Master
                Channel:6
                Frequency:2.437 GHz (Channel 6)
                Quality=45/100  Signal level:-82 dBm  Noise level=-127 dBm
                Encryption key:on
                IE: WPA Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (2) : TKIP CCMP
                    Authentication Suites (1) : PSK
                IE: IEEE 802.11i/WPA2 Version 1
                    Group Cipher : TKIP
                    Pairwise Ciphers (2) : TKIP CCMP
                    Authentication Suites (1) : PSK
                IE: Unknown: 2D1A4C101FFFFF000000000000000000000000000004000000000000
                Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                          9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
                          48 Mb/s; 54 Mb/s
                Extra:tsf=00000196f9bae180
                Extra: Last beacon: 744ms ago

I forgot to mention that I’m using:

uname -a
Linux linux-juan 2.6.25.16-0.1-default #1 SMP 2008-08-21 00:34:25 +0200 x86_64 x86_64 x86_64 GNU/Linux

In advance thanks for your help.

Dear forum participants

I have done further tests on my problem. It puzzles me that
nobody encountered this issue before, there are a number of
similar complaints on other forums (ubuntu, etc).

I don’t repeat my data, It’s in the first post.
The problem with wireless seems to be the following:
Apart from the annoying missing green light and the erratic answers from iwlist, the network configuration using the
standard method with ifup seems to do its job properly:
iwconfig shows the correct access point, and it has spoken with
somebody since it shows also the signal quality, etc.
ifconfig shows the correct associations.
BUT… it doesn’t work. Why? I believe that the problem is
that /sbin/route takes over one minute to display the routing
table. Other programs may get tired and timeout? Why route does
this? I don’t know. Knowing this may be the solution?
Restarting the network with /etc/init.d/network restart
fixes the route problem and the wireless is up, still with the
erratic iwlist and no green light of course.

With the compat drivers I have green light, correct answer from
iwlist, correct configuration as given by iwconfig and ifconfig
but still slow response from route. It is however worse, because
it does not get better after restarting the network: It is
always slow response and no connection.

Is it possible that nobody has seen this before?
How did everybody else with the same card fix this problem?
Can anybody suggest some path of action?

Thanks,

mnatiello

I’m not sure if this is mentioned here already… but good news for the iwl3945 driver in openSUSE 11.1.

With kernel 2.6.27 there is an updated driver. This does support led activity again and the wireless issues that seem to have started with openSUSE 11.0 (switch from ipl3945 to iwl3945) also have been addressed.

I’d urge all that can to test the openSUSE 11.1 Beta 3 coming out this weekend so any issues still in the driver can be reported so we can get a solid iwl driver in 11.1! :slight_smile:

Cheers,
Wj

When you said you loaded the compat-wireless drivers, you followed all the steps listed here - Compat-Wireless Install - especially the make load part. I was experiencing the same issues on a Compaq Presario with the 3945 drivers. The write-up references the wrong download -
Compat-Wireless Drivers (old)

I just tried with ipw-firmware, but didn’t work.

I also tried with another ap without any security and didn’t work either…

my wireless card can see the aps, but it can’t connect to them!

I reinstall Suse 11, made the test for the Internet connection during installantion, updates and now the wireless works.

My advice, re-install!

Good luck and have fun.

[QUOTE=msharnden;1883399]When you said you loaded the compat-wireless drivers, you followed all the steps listed here - Compat-Wireless Install - especially the make load part.

Hallo

Thank you for answering. Yes, I followed everything there. I installed-deinstalled-reinstalled the compat drivers some 10-12 times without any success.

To todos27: I also reinstalled suse11.0 without success.

I didn’t succeed in installing kernel 2.6.27, I’ll wait until
11.1 for that. To upgrade the kernel seems to me like burning
the forest because I can’t kill the mosquito. Some sound reason
should exist behind the fact that route takes too long to answer
although it behaves fine after a network restart. Also there
should be a reason behind the erratic response of iwlist. I enabled/disabled hardware scan a couple of times, without
improvement.

Hope somebody sees a way out.

I am experiencing similar problems - the interface is functional but will not associate - is this problem associated around the WPA2 standard? It is imperative for security considerations that the iw3945 support WPA2 considering the latest vulnerabilities identified with WPA