Intel Pro Wireless 2200 on Acernote 290

My wireless connection is recognised but won’t connect or scan available networks.
Looking at the boot message log, the ipw2200 driver module is loaded but there is a message that the radio kill connection is set to ON.
How do I set this to off?
Using opensuse 11.1 and gnome.

That message is set by the radio disable switch. You may need to issue
the command

sudo /sbin/modprobe -v acer-wmi

This module is used to activate the various control panel options.

Thanks, will give it a try in the morning (00:27 here) and not at the notebook right now.

When I ran:
sudo /sbin/modprobe -v acer-wmi
I get the message that the module is not found.
Is there any other way of enabling the rfkill so that it sets the wireless to ON?

I bet there was another message (assuming the command was typed correctly).

If I have a sift through the boot messages, there is an entry to the effect that no wmi is found when it tries to start acer-wmi.
This is different to the message when I run/sbin/modprobe/… which just says acer-wmi is not found.
The wired network is not up by the way to produce any conflict.

And again, I bet the message is not that acer-wmi is not found as it is enabled by default on any openSUSE standard kernels since 11.0 (no matter if i586 or x86_64).

As it seems you are reluctant to just cite the message (working for CIA/FBI and not allowed to quote terminal output?) I suspect, I will do it for you:

modprobe -v acer-wmi
insmod /lib/modules/
insmod /lib/modules/
FATAL: Error inserting acer_wmi (/lib/modules/ **No such device

which is something completely different than “the module is not found”.

The module is found but your device (BIOS that is) is not compatible with acer-wmi.

You will need one of the many other “software switches” like acerhk, fsam7440, fsam7400 or wistron_btns (to name just a few candidates).

Not reluctant to post the full message, but I am replying from memory from a different computer each time.
What you have posted seems to ring a bell as being the message.
Do you know if the later bios versions on the acer site fix this problem or should I go with one of your other suggestions?

No, I don’t and I also doubt it.

Thanks Akoellh, I’ll try one of the other options and report back.

I finally resolved the problem of the intel 2200bg wireless on an acer 292LM.
I downloaded acerhk from the
To run the module, run the following commands as root:

modprobe acerhk force_series=290 usedritek=1
echo 1 > /proc/driver/acerhk/wirelessled

Reboot and a the wireless network now works.