Intel Pro 3945 won't connect

Thinkpad 61p with Intel Pro/Wireless 3945 ABG (as identified by WinXP and openSuse(lspci attached)). iwl3945-ucode and iwlwifi-kmp are installed, as is the deamon (automatically by yast)
Using Knetworkmanager, I can see wireless networks but the connecting process stops at 28% (activation stage: configuring device) and does not continue. This behavior is independent of the (unprotected) network, I want to connect to. It works under WinXP.

I tried to install any wireless program in the repros and consulted some installation guides for Thinkpads but none reported this problem. Could you guys help?
Thanks, Steffen

03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
Subsystem: Intel Corporation Unknown device 1010
Flags: bus master, fast devsel, latency 0, IRQ 17
Memory at df2ff000 (32-bit, non-prefetchable) [size=4]
Capabilities: <access denied>[/size]

Oh, ups, I have openSuse 10.3 installed

1 ) check your firewall
2 ) check your encryption
3 ) try changing the router’s wireless channel


Tried 1): Disabled Firewall > no change.
2) The network is not-encrypted. And it works with my old OpenSuse10 on my old Laptop,
3) same as 2)
Do you perhaps have some other ideas?

Thanks for your help.

Perhaps you might want to try the compat-wireless modules from this repo:- Index of /repositories/home:/schmolle1980/openSUSE_10.3_update

With 10.3 you might be using the older ipw3945 drivers…with this you get the latest iwlwifi drivers. Its possible that the wireless LED might stop functioning…however your wireless will work. I’ve used this repo successfully on my Thinkpad R61i w/ the 3945 wireless card on Opensuse 11.0. This should also work for 10.3.


Also did not work. Many thanks, though.

When connecting, the indicator light is blinking, then on for a few seconds, this is repeated 2 more times. The network card finds the networks, but cannot connect to them. I somehow think, that perhaps the configuration is wrong b/c I had the wireless switch turned off during installation or on or I did something else stupid.
Any more suggestions??

Thanks for the help so far, I learned a lot.