Intel PRO 2100 not working, RF killswitch button not working at all

Hi All,

I followed the sticky about setting up wireless and I have come to an issue where the WLAN switch which is on this computer can be pressed, the light comes on, but no WLAN. When I looked in dmesg, this is what I get:

ipw2100: Detected Intel PRO/Wireless 2100 Network Connection
firmware: requesting ipw2100-1.3.fw
eth0: Radio is disabled by RF switch.

When running iwconfig wlan0 heres what I get:

home/j-dub # iwconfig eth0
wlan0 unassociated ESSID off/any Nickname:“ipw2100”
Mode:Managed Channel=0 Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power off
Retry short limit:7 RTS throff Fragment thr off
Encryption key off
Power Management off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Notice it says that the ‘Radio is disabled by switch’ in dmesg. I can press that switch until the end of the world comes and it does absolutely nothing but make the WLAN light put on a light show. And it shows the wlan to be unassociated with any clients. So, what are my options to get this Wireless up and working? I have already looked into the ‘getting your wireless to work’ thread and there is nothing there to help. Give me some advice please.

Computer/OS info:

Fujitsu-Siemens Amilo M7400
1.4GHz Intel Centrino R
Suse 11.1 KDE

You want to search for “fsam7400”.

And if there are ANY windows drivers and/or ndiswrapper installed, REMOVE them FIRST!

so remove ndis and remove drivers, install fsam, then re-install drivers?

Yes, Yes, Yes, No. (if “drivers” means some Windows-drivers).

ok, did it all. Light goes out now, but after pressing it does not come on…:stuck_out_tongue:

is there anything I am missing here? Maybe something was overlooked? Whats the next step?

dmesg reports:

ipw2100: Detected Intel PRO/Wireless 2100 Network Connection
firmware: requesting ipw2100-1.3.fw
ipw2100: eth0: Firmware ‘ipw2100-1.3.fw’ not available or load failed.
ipw2100: eth0: ipw2100_get_firmware failed: -2
ipw2100: eth0: Failed to power on the adapter.
ipw2100: eth0: Failed to start the firmware.

Let me google that for you.

See,s as if the firmware and drivers are gone as well as ndiswrapper. The connection does appear to be in ‘online mode’ in NetManager, but the named connection does not appear. When i right click onto NetManager, it shows only a cable connection present. When I go to edit connections, it shows a wireless connection present. I can edit the connection, try to connect and save, but it still gives me no WLAN. Bummer.

I would say that since the ip2100 is recognised, you don’t need any extra drivers or modules.
I seem to remember when I was trying to get my acer 290 working that some fujitsu models also use acerhk to control the wireless switch.
It’s in the
Look at this thread on how to enable it:
Intel Pro Wireless 2200 on Acernote 290 - openSUSE Forums

Make sure that if there is a wireless switch on the notebook that it is set to on.

Another thing is to search for you notebook model and enable wireless.

Might work with Amilo 7400, but not sure, acerhk-packages exist on OBS (though obviously unmaintained for updated kernels).

Fun thing is, the OP already was on the right track, but instead of doing exactly what he was told (remove ndiswrapper and Windows drivers) he obviously removed the firmware for linux, too (which was installed by default, and could have been reinstalled easily, if he had followed my link to google search).

Don’t know, if he actually installed the matching fsam7400-packages (fsam7400 + fsam7400-kmp-$flavor), as -by coincidence- I did only a few weeks ago on some friend’s laptop and it worked as expected, but now it’s too late anyway, because -by another stroke of coincidence- I removed fsam7400 from my repos yesterday, so if acerhk does not do the trick, he will have to search, patch and compile fsam7400 for himself.

I own an Amilo M7400 with the Intel PRO 2100 wireless.

Its currently running openSUSE-11.1. Before then it was running 11.0, 10.3, 10.2, 10.1, 9.3 …

Wireless has always “just worked” on this laptop, except for maybe 9.3 where I vaguely recall having to update the BIOS … In every case starting with 10.1 I simply installed openSUSE and the wireless functioned.

I’m surprised at j-dub’s problems, because wireless is really good with this old laptop. Unfortunately I do not know enough about this to offer a suggestion … But I do know this is NOT a nominal laptop hardware compatibility problem nor is it a nominal openSUSE problem if everything is configured correctly (ie default settings work).

This gives two possibilities.

  1. That BIOS update fixed this Bug (Yes, this is a Bug if ACPI events are not implemented by the standard ways on every compliant OS but by some strange OS-Software acting as the 50 cent part, a real switch would have been).


  1. There are several, different “Amilo M7400” around and the vendor has a brain dead naming schmeme (like i.e. some “Wireless Vendors”) where different machines have (practically) the same name (sometimes with an innocent “revX” behind it, but not always).

After replying to this thread, I did a bit of googling and found acerhk works with his notebook as well as a few others. Seems like Acer supplies equipment to other manufacturers to rebrand.
I also found references to fsam7400, but they were from older posts.
Strange thing is that if you try intel’s own kernel modules for the IntelPRO, the 2100 and 2200 are the same and are now built into the newer kernels … So he never needed the ndiswrapper in the first place.

Maybe, but, there are only very few “real” hardware vendors, especially when it’s about BIOS, so most likely those “other vendors” buy the same parts for their laptops (and not really from Acer).

Yes, that’s why I told him to uninstall it in my first answer.

(That he was using ndiswrapper was pretty clear on seeing the “wlan0”, ipw2x00 gives an “ethX” by default, so actually I tried to fix what he already broke.)

Indeed, I have never used the ndiswrapper on this laptop.

For everyone on this thread, my wife typically keeps this laptop at the organization where we both work, so for exercise on this Good Friday holiday, we walked into the office, picked up the laptop, and brought it back home. I’m going to plug it in to the Internet and update its openSUSE-11.1 software, and while I do that, if there are any configuration files I can check, please advise.

I will have the laptop until Monday, when either Monday afternoon, or 1st thing Tuesday morning, I will likely need to return the laptop to the office, and I will no longer have access.

Ok, so I am now typing this on this Amilo 7400M laptop using its wireless to connect to the internet.

Here is some selected information on this laptop:
From: lspci -nn

02:06.0 Network controller [0280]: Intel Corporation PRO/Wireless LAN 2100 3B Mini PCI Adapter [8086:1043] (rev 04)

From: lspci -vv

02:06.0 Network controller: Intel Corporation PRO/Wireless LAN 2100 3B Mini PCI Adapter (rev 04)
	Subsystem: Intel Corporation MIM2000/Centrino
	Control: I/O- Mem+ BusMaster+ SpecCycle- MemWINV+ VGASnoop- ParErr- Stepping- SERR+ FastB2B- DisINTx-
	Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 64 (500ns min, 8500ns max), Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 10
	Region 0: Memory at e0203000 (32-bit, non-prefetchable) [size=4]
	Capabilities: [dc] Power Management version 2
		Flags: PMEClk- DSI- D1- D2- AuxCurrent=0mA PME(D0-,D1-,D2-,D3hot-,D3cold-)
		Status: D0 PME-Enable- DSel=0 DScale=1 PME-
	Kernel driver in use: ipw2100
	Kernel modules: ipw2100

Selected dmidecode output:

# dmidecode 2.9
SMBIOS 2.31 present.
37 structures occupying 1196 bytes.
Table at 0x000D8010.

Handle 0x0000, DMI type 0, 20 bytes
BIOS Information
	Vendor: Phoenix Technologies LTD
	Version: R01-S0Z   
	Release Date: 12/28/04
Handle 0x0001, DMI type 1, 25 bytes
System Information
	Manufacturer: FUJITSU SIEMENS
	Product Name: AMILO M        
	Version: -1             
	Serial Number: 9142DZ100834300DA7KS00

Selected hwinfo information:

  14: udi = '/org/freedesktop/Hal/devices/computer' = 'Linux'
  system.kernel.version = ''
  system.kernel.machine = 'i686'
  system.board.serial = '9142DZ100834300DA7KS00'
  system.firmware.vendor = 'Phoenix Technologies LTD'
  system.firmware.version = 'R01-S0Z'
  system.firmware.release_date = '12/28/04'
  system.hardware.vendor = 'FUJITSU SIEMENS'
  power_management.type = 'acpi'
  system.hardware.product = 'AMILO M'
  power_management.acpi.linux.version = '20080609'
  system.hardware.version = '-1'

  82: udi = '/org/freedesktop/Hal/devices/pci_8086_1043'
  info.product = 'PRO/Wireless LAN 2100 3B Mini PCI Adapter'
  pci.vendor = 'Intel Corporation'
  pci.subsys_product = 'MIM2000/Centrino'
  pci.product = 'PRO/Wireless LAN 2100 3B Mini PCI Adapter'
  info.linux.driver = 'ipw2100'
  pci.subsys_vendor = 'Intel Corporation'
  pci.product_id = 4163 (0x1043)
  linux.hotplug_type = 2 (0x2)
  pci.vendor_id = 32902 (0x8086)
  linux.subsystem = 'pci'
  pci.subsys_product_id = 9511 (0x2527)

The internet connection via the wireless is working well !!

j-dub, Please check. Is this the same hardware?[/size]

And of course unlike the pure motherboard vendors who supply regular bios updates, notebook/laptop vedors seem to forget to support them as soon as their newest version is released.

It’s a pity nobody supplies a standard laptop case and a range of components so you can build your own in the same way as you can with a desktop.
This would really bring down the prices of new laptops.


Post output of

lsmod | sort

to see if there is any other “potential candidate” for a software switch loaded (actually, two come to mind, but one IIRC would be only for x86_64).

Output of “lsmod | sort” :

ac                      4480  0 
ac97_bus                1584  1 snd_ac97_codec
aes_generic            27792  1 aes_i586
aes_i586                7580  1 
af_packet              16356  4 
agpgart                32148  3 drm,intel_agp
arc4                    1728  4 
ata_piix               16600  4 
b44                    25116  0 
battery                11176  0 
binfmt_misc             7740  1 
button                  6568  0 
cdrom                  32288  2 ide_cd_mod,sr_mod
container               3636  0 
cpufreq_conservative     6440  0 
cpufreq_powersave       1640  0 
cpufreq_userspace       3112  0 
crc_t10dif              1704  1 sd_mod
crypto_blkcipher       16800  1 ecb
dm_mod                 62596  0 
dock                   11844  1 libata
drm                    74128  3 i915
ecb                     2672  4 
edd                     8620  0 
ehci_hcd               47488  0 
ext3                  124020  1 
fan                     4720  0 
fat                    45800  1 vfat
ff_memless              7132  1 usbhid
fuse                   50656  5 
hid                    35568  1 usbhid
hwmon                   2916  1 thermal_sys
i2c_core               29892  1 i2c_i801
i2c_i801               10500  0 
i915                   28192  2 
ide_cd_mod             29140  0 
ide_core               97108  2 ide_disk,ide_cd_mod
ide_disk               12868  0 
ieee1394               83692  1 ohci1394
ieee80211              26656  1 ipw2100
ieee80211_crypt         5212  3 ieee80211_crypt_tkip,ieee80211_crypt_ccmp,ieee80211
ieee80211_crypt_ccmp     5132  1 
ieee80211_crypt_tkip     8528  2 
intel_agp              24736  1 
ip6_tables             12496  0 
iptable_filter          2548  1 
iptable_raw             2056  1 
ip_tables              11276  2 iptable_raw,iptable_filter
ipt_LOG                 5708  12 
ipt_REJECT              2760  3 
ipw2100                66508  0 
iTCO_vendor_support     3368  1 iTCO_wdt
iTCO_wdt                9940  0 
jbd                    52808  1 ext3
joydev                  8948  0 
libata                161080  1 ata_piix
loop                   14112  0 
lp                      8644  0 
mbcache                 7592  1 ext3
michael_mic             2240  4 
mii                     4968  1 b44
mmc_core               55104  1 wbsd
Module                  Size  Used by
nf_conntrack           67336  4 xt_NOTRACK,xt_state,nf_conntrack_netbios_ns,nf_conntrack_ipv4
nf_conntrack_ipv4      10480  4 
nf_conntrack_netbios_ns     2152  0 
nls_cp437               5432  1 
nls_iso8859_1           3768  1 
ohci1394               27396  0 
output                  2732  1 video
parport                33196  3 lp,parport_pc,ppdev
parport_pc             34632  1 
pci_hotplug            27392  1 shpchp
pcmcia                 32656  1 ssb
pcmcia_core            33144  4 ssb,yenta_socket,rsrc_nonstatic,pcmcia
pcspkr                  2344  0 
ppdev                   6876  0 
processor              43340  2 thermal
rsrc_nonstatic         10440  1 yenta_socket
rtc_cmos               10744  0 
rtc_core               17384  1 rtc_cmos
rtc_lib                 2816  1 rtc_core
scsi_mod              149832  5 st,sr_mod,sg,sd_mod,libata
sd_mod                 31588  5 
serio_raw               5096  0 
sg                     29392  0 
shpchp                 28228  0 
snd                    56800  13 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_intel8x0m,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
snd_ac97_codec         99756  2 snd_intel8x0m,snd_intel8x0
snd_intel8x0           28256  2 
snd_intel8x0m          13848  0 
snd_mixer_oss          14288  1 snd_pcm_oss
snd_page_alloc          8048  3 snd_intel8x0m,snd_intel8x0,snd_pcm
snd_pcm                76744  4 snd_pcm_oss,snd_intel8x0m,snd_intel8x0,snd_ac97_codec
snd_pcm_oss            43132  0 
snd_seq                51920  0 
snd_seq_device          7168  1 snd_seq
snd_timer              20204  2 snd_seq,snd_pcm
soundcore               6660  1 snd
speedstep_centrino      5400  0 
sr_mod                 13344  0 
ssb                    38372  1 b44
st                     34220  0 
thermal                19976  0 
thermal_sys            11376  4 video,fan,thermal,processor
uhci_hcd               22976  0 
usbcore               165556  4 usbhid,uhci_hcd,ehci_hcd
usbhid                 45548  0 
vfat                    9656  1 
video                  20312  0 
wbsd                   16280  0 
x_tables               14420  9 xt_tcpudp,xt_pkttype,ipt_LOG,xt_limit,xt_NOTRACK,ipt_REJECT,xt_state,ip_tables,ip6_tables
xt_limit                2056  12 
xt_NOTRACK              1544  2 
xt_pkttype              1560  6 
xt_state                1904  4 
xt_tcpudp               2728  15 
yenta_socket           22776  1 

I’m currently updating about 300MB of Packman packaged rpms in the background as I type this. Internet is working well on this wireless. In fact this Intel Pro 2100 wireless always worked better on Linux than WinXP on this laptop.

Nope, neither “acer-wmi” nor “wistron_btns” loaded, so we’re back at #12.