Intel i915 Flickering and CPU pipe A FIFO underrun Error

In Syslog :
i915 0000:00:02.0: [drm] ERROR CPU pipe A FIFO underrun

And screen flickering in KDE as well as on a terminal tty

I had the same issue with the i915 driver on previously installed Ubuntu and it was fixed by setting a few parameters for the driver in /etc/modprobe.d/i915.conf

I tried the same parameters for open SuSE Tumbleweed, put them in /etc/modprobe.d/21-i915.conf.
I checked the setting with modprobe -c
Here are the used parameters :

options i915 enable_guc=2
options i915 enable_fbc=1
options i915 fastboot=1
options i915 enable_psr=0

I also played around with these additional ones :slight_smile:
#options i915 enable_rc6=1
#options i915 powersave=1
#options i915 modeset=1

No success though on Tumbleweed.

It is a Huawei MateBook with the following CPU and embedded graphics:
Intel(R) Core™ m5-6Y54 CPU @ 1.10GHz
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 515 (rev 07)

Any hint ?

Which DRI driver are you using?

Which X display driver are you using?

I don’t need any of those options with the Intel graphics generation following yours.

# xdriinfo
Screen 0: **iris**
# pinxi -Gaz --vs --zl --hostname
pinxi 3.3.24-01 (2022-12-10)
  Device-1: Intel HD Graphics 630 vendor: ASUSTeK driver: i915 v: kernel
    arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports:
    active: DP-1,HDMI-A-2,HDMI-A-3 empty: DP-2,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:5912 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 **driver: X: loaded: modesetting**
    unloaded: fbdev,vesa alternate: intel **dri: iris** gpu: i915 display-ID: :0
    screens: 1
  Screen-1: 0 s-res: 3600x2640 s-dpi: 120 s-size: 762x558mm (30.00x21.97")
    s-diag: 944mm (37.18")
  Monitor-1: DP-1 pos: primary,bottom-l model: Acer K272HUL serial: <filter>
    built: 2018 res: 2560x1440 hz: 60 dpi: 109 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 2560x1440 min: 720x400
  Monitor-2: HDMI-A-2 mapped: HDMI-2 pos: top-right model: Dell P2213
    serial: <filter> built: 2012 res: 1680x1050 hz: 60 dpi: 90 gamma: 1.2
    size: 473x296mm (18.62x11.65") diag: 558mm (22") ratio: 16:10 modes:
    max: 1680x1050 min: 720x400
  Monitor-3: HDMI-A-3 mapped: HDMI-3 pos: top-left model: NEC EA243WM
    serial: <filter> built: 2011 res: 1920x1200 hz: 60 dpi: 94 gamma: 1.2
    size: 519x324mm (20.43x12.76") diag: 612mm (24.1") ratio: 16:10 modes:
    max: 1920x1200 min: 640x480
  API: OpenGL v: 4.6 Mesa 22.2.4 renderer: Mesa Intel HD Graphics 630 (KBL
    GT2) direct render: Yes

pinxi is the devel version of inxi. inxi is just fine for a reply.

Those instances of ** seen in my prior post were supposed to designate bold text. I didn’t notice they weren’t doing what they were supposed to do before the edit period expired. :frowning:

@zaphod68 is there any output from dmesg | grep -iE "huc|guc|dmc" Have you tried the Option "TearFree" "true" in a xorg .conf file of course this assumes your running Xorg and not Wayland?

Hello, I get this from inxi :

$ inxi -Gaz --vs --zl --hostname
inxi 3.3.23-00 (2022-10-31)
Device-1: Intel HD Graphics 515 vendor: Huawei driver: i915 v: kernel
arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: eDP-1
empty: DP-1, DP-2, HDMI-A-1, HDMI-A-2 bus-ID: 00:02.0 chip-ID: 8086:191e
class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.5
compositor: kwin_x11 driver: X: loaded: modesetting unloaded: fbdev,vesa
alternate: intel dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 2160x1440 s-dpi: 96 s-size: 571x381mm (22.48x15.00")
s-diag: 686mm (27.03")
Monitor-1: eDP-1 model: BOE Display built: 2016 res: 2160x1440 hz: 60
dpi: 216 gamma: 1.2 size: 254x169mm (10x6.65") diag: 305mm (12") ratio: 3:2
modes: 2160x1440
API: OpenGL v: 4.6 Mesa 22.2.4 renderer: Mesa Intel HD Graphics 515 (SKL
GT2) direct render: Yes


I tried Tearfree, but that didn’t change anything.

From dmesg :

[ 3.436571] i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/skl_dmc_ver1_27.bin (v1.27)


Sorry, took me a while to be back online, this developed into a very weird issue :

A recent “zypper up” fixed the flickering issue, however after that, the WiFi interfaces are gone !

Lucky opensuse feature, using a snapper diff, I reverted back ONLY the following files, which made the WiFi work again, but … surprise … brought the screen flickering back again …

snapper undochange 26…27 /usr/lib/firmware/brcm/brcmfmac4356-pcie.bin.xz
snapper undochange 26…27 /usr/lib/firmware/brcm/brcmfmac4356-sdio.bin.xz

The WiFi is indeed a brcm4356 and the brcmfmac driver is loaded.

With the new firmware, there is the following error in dmesg, the ieee* part is different between a working and non working config.

[ 115.118940] usbcore: registered new interface driver brcmfmac
[ 115.170346] brcmfmac 0000:01:00.0: enabling device (0000 → 0002)
[ 115.277601] brcmfmac: brcmf_fw_alloc_request: using brcm/brcmfmac4356-pcie for chip BCM4356/2
[ 115.278353] brcmfmac 0000:01:00.0: Direct firmware load for brcm/brcmfmac4356-pcie.HUAWEI-MateBook HZ-W19.bin failed with error -2
[ 115.525569] ieee80211 phy0: brcmf_c_process_clm_blob: clmload (5750 byte file) failed (-52)
[ 115.526348] ieee80211 phy0: brcmf_c_process_clm_blob: get clmload_status failed (-52)
[ 115.526361] ieee80211 phy0: brcmf_c_preinit_dcmds: download CLM blob file failed, -5
[ 115.526365] ieee80211 phy0: brcmf_bus_started: failed: -5
[ 115.526373] ieee80211 phy0: brcmf_attach: dongle is not responding: err=-5

Firmware package version (doesn’t work) :
Informationen zu Paket kernel-firmware-brcm:

Repository : Haupt-Repository (OSS)
Name : kernel-firmware-brcm
Version : 20230110-1.1
Arch : noarch
Anbieter : openSUSE
Installierte Größe : 11,0 MiB
Installiert : Ja
Status : aktuell
Quellpaket : kernel-firmware-20230110-1.1.src
Upstream-URL : kernel/git/firmware/linux-firmware.git - Repository of firmware blobs for use with the Linux kernel
Zusammenfassung : Kernel firmware files for Broadcom wireless drivers
Beschreibung :
This package contains compressed kernel firmware files for
Broadcom wireless drivers.

Now this is interesting … what the h* does the WiFi driver have to do with screen flickering ???

This seems to be the zypper up update part that causes the effect.
I did not revert the i915 firmware files … so, this could not be the issue

v | Haupt-Repository (OSS) | kernel-firmware-all | 20221130-1.1 | 20230110-1.1 | noarch
v | Haupt-Repository (OSS) | kernel-firmware-brcm | 20221130-1.1 | 20230110-1.1 | noarch
v | Haupt-Repository (OSS) | kernel-firmware-i915 | 20221130-1.1 | 20230110-1.1 | noarch

If on Tumbleweed DO NOT USE zypper up it is zypper dup only!!!

Yes, I used zypper dup.

Anyway, if I update thg package kernel-firmware-brcm to anything newer than 20221130-1.1 then loading the brmfmac fails with the above ieee* errors. If I downgrade to 20221130 the WiFi interface works.

However, screen still flickers :wink:

If you tried the suggestions here, I would either comment in that bug about your trouble, or or report a new bug that includes HD 515 & SKL in the summary. Include the URI to this thread if you do.

1 Like

So, after months of trying, I gave up.

Back to Kubuntu on that device again, with modifying the /etc/modprobe.d/i915.conf as per my initial post, it works perfevtly fine again.