Intel i830 video not working in RC2

Only gives me 800*600. The Display application in Personal Settings offers nothing else, and Sax2 has disappeared from Yast. Great for noobs, I suppose, who have to work the terminal to change their screen resolution. However, sax2, while allowing me to change the settings, does not implement them.
Tried Ubuntu Karmic on the same hardware, installed without a glitch… It’s an elderly ASUS laptop.

You can still run sax2 -r
from a su terminal
Or it is in the main menu - (But as you say not in Yast)

I did run it from terminal but without the -r… Would that explain why my attempt at reconfiguration wasn’t saved?

Check the:

man sax2

for details on the options

Yes I did that, and understand what -r does (clear the hardware recognition data or something like it). I just wondered if my omission of the -r option would explain in itself that sax2 could not reconfigure the video. Because if it does, I’m happy to install Suse over Ubuntu and try again. But if it doesn’t, I’ll just stick with Karmic on that machine for now.

OK I’ve taken the plunge and reinstalled RC2 over Ubuntu but still no go. Dropped into runlevel 3 and ran “sax2 -r”, entered the required details but still get the same 800x600 (rather than 1024x768) resolution, and that not even centered but in origin 0,0 with the top of another right below it. What can I try next?

I do not know what is best tried next, but I suspect those who might know, will want more information.

openSUSE-11.2 does not nominally need an /etc/X11/xorg.conf file. However, if one’s graphics does not work without an /etc/X11/xorg.conf file, then one can create such a file, and that file will be used insted of the auto configuration.

You could let us know what driver the “sax2 -r” command applied when it created an xorg.conf file. You can do that by typing something like (I’m not at a linux pc to test this - so I’m going by memory):
cat /etc/X11/xorg.conf | grep river
and you could type with root permissions:
**sax2 -p **
and provide the output, as that will tell us what sax2 detected.

There are other options one can apply in the sax2 command. Whether or not those options will help you improve the resolution beyond 800x600, I do not know. Type with root permissions: man sax2
and that will tell you the sax2 options.

Thanks, oldcpu. I’ve run those commands but as I don’t have a network connection on that machine I can’t paste the output here. Both confirmed that the i830 was correctly identified, though, and the driver used was “intel”. There don’t seem to be any more sax2 options that could be useful to resolve this.
No worries: after all, I was just playing around with a pre-release to see if it was an improvement on 11.1 which had exactly the same symptoms. I can wait for the full release, or use Ubuntu on the same machine. RC2 works great on my Eeepc, and I’m sure 11.2 will be equally good on my main desktop workhorse when it is finally released.

Hmmm …

There was a time, when there was more than one graphic driver for Intel hardware, that might work with one’s PC. In addition to “intel”, there was also “i810”, and “i740”

16-May-2008 - list of xorg PCI vendor/drivers: X.Org PCI Vendor, Device and Driver List I confess I do not recall i740 ever being used, and I think I recall something stating i810 was no longer in use (but I’m not sure) and if that is the case, then “intel” is your only Intel choice.

If the Intel i810 was still in use, one would try (to force it):
sax2 -r -m 0=i810but like I note, I think the i810 may be depreciated. Honestly ? I do not know. Some one who does needs to chime in here.

Did you try the VESA driver?

sax2 -r -m 0=vesa

or even the fbdev? ie
sax2 -r -m 0=fbdev

Also, and my apologies for stating the obvious, but when sax2 runs, it typically gives one the option to select the configuration, or select a more optimal configuration (I do not know the exact wording as I am not at a linux pc right now). By selecting the option, one is taken to a sax2 menu where they can select the option of a higher resolution.

Also, this should be done from run level 3. I assume you are doing this from run level 3 ? DO NOT just open a terminal and type “sax2 … whatever”. You MUST exit X window to run level 3.

This may be a long shot . . .
But I had a similar problem with RC2 only showing 800X600 and unable to chang in sax 2

I have an intel onboard 915GM by the way.

As I understand it the i810 driver support was dropped from 11.1

Anyway - ripping out my hair for days - then I noticed that Suse had detected my monitor incorrectly & had installed it as standard vesa monitor.

Simply found my monitor in th list in sax2 and I could pretty much set any resolution that my monitor supports after that.

I don’t have a monitor attached, only the built-in LVDS.

Thanks for your suggestion, oldcpu, but none of these worked (and yes, I’d been dropping into runlevel 3 all the time before that: some people actually benefit from the advice you and others have given them over the months since fleeing Redmond). Yet it is solved now, and you probably won’t believe how I did it:

following no more than a hunch, I reinstalled for the third time, but this time I set the video to 1024x768 on the first screen of the installer (F3, VGA mode I think). Nothing else to be done later, everything beautiful…

This surely must be a bug???

but sax will still show something as a monitor. Make sure that it hasn’t defaulted to a vesa lvds as it had done for me.
The fix you mention above had also worked for me which indicates you may be having the same problem. Which can be corrected post install i fmissed with the sax2 setting

Yes I know. But see solution above… :wink:

Has Sax2’s GUI fully left us in RC2?
I hope its there, whoever suggested it be removed was a brainless twit seriously as I was NEVER able to get KDE4 to keep my desired resolution of 1024x768 as it fails to save my desired res and reverts to 800x600 leaving me to configure xorg like in Kubuntu.
I thought openSUSE was supposed to be easy, removing a useful tool is surely the work of a idiot.

it is still there but not in yast. Instead they have put it under system in kicker (on KDE4)

as long as they keep it I am cool, but seriously the idea of removing it must have been done by someone who does a lot of LSD.

Several YaST utilities can be accessed from various places, but the beauty of YaST has always been that it’s a kind of one-stop shop for system configuration. I can’t understand either why it’s been dropped from YaST: offering it somewhere else is no excuse as it could be (as it always has been) elsewhere AND in YaST…
But I am downloading updates as we speak, including to YaST. Wouldn’t be at all surprised to find it reinstated…
On a more cynical note, I’ve never ever been able to solve a single screen configuration issue with Sax2, that’s on four different computers running openSUSE Gnome and KDE at different times, some laptops, some dual monitor setups, all different video cards. ALL issues had to be resolved either by hand-editing xorg.conf or various other tricks. So I can’t say that, personally, I’d be missing it.

Perhaps because it is NOT a YaST module but a seperate program?

Also it’s not really needed anymore as auto detection in Xog should more or less do everything.

Well I think we know that “autodetection” doesn’t always work…