Intel HDA: no sound, unable to resolve

Hello,

this is my first post, and I hope that it is appropriate.

After being away from linux for a number of years, I just installed LEAP 42.1 on my ASUS laptop V1JP. I can’t get it to output any sound.

I have followed these two procedures without success:
[ul]
[li]https://en.opensuse.org/SDB:Intel-HDA_sound_problems [/li][li]https://en.opensuse.org/SDB:Audio_troubleshooting [/li][/ul]

This is the information I am working with:
[ul]
[li]ALSA Information: http://www.alsa-project.org/db/?f=2016a54a721cccb502c700dbfe3ea86d4ca047c5 [/li][li]> head -n 1 /proc/asound/card0/codec*[/li]

==> /proc/asound/card0/codec#0 <==
Codec: Analog Devices AD1986A

==> /proc/asound/card0/codec#1 <==
Codec: Motorola Si3054

[li]This is /etc/modprobe.d/50-sound.conf created by YAST:[/li]

options snd slots=snd-hda-intel
# u1Nb.Igk_bJzDER9:NM10/ICH7 Family High Definition Audio Controller
alias snd-card-0 snd-hda-intel

[li]The respective section in /usr/src/linux-4.1.20-11/Documentation/sound/alsa/HD-Audio-Models.txt:[/li]

AD1986A
=======
  3stack    3-stack, shared surrounds
  laptop    2-channel only (FSC V2060, Samsung M50)
  laptop-imic    2-channel with built-in mic
  eapd        Turn on EAPD constantly

[/ul]

I made sure:

[ul]
[li]Deleted sound configuration in YAST, deleted /etc/modprobe.d/50-sound.conf, recreated configuration in YAST [/li][li]No personal backups in /etc/modprobe.d/ [/li][li]Nothing muted [/li][li]I installed kernel-source [/li][/ul]

For test sounds I used: speaker-test -Dplug:front -c2 -l5 -twav

Because of the version differences I guessed what might be appropriate to apply:

[ul]
[li]In 50-sound.conf I tried these syntaxes:[/li][LIST]
[li]options snd slots=snd-hda-intel model= (the syntax produced by YAST) [/li][li]options snd-hda-intel model= (the syntax given in the above tutorials [/li][/ul]

[li]I tried all models (3stack, laptop, …) [/li][li]Restarting ALSA:[/li]

alsactl kill quit
alsactl init

[/LIST]

Still it doesn’t produce any sound. I don’t have any more ideas.

I would appreciate any help. Thank you for reading my post.

Many regards :wink:

I also have an ASUS laptop and I’ve experienced that problem both in opensuse and other distros.

the only thing you haven’t done (you might as well try) is to reinstall alsa and pulseaudio (probably it won’t do a thing).

in my case the only “fix” that would work is to turn off and unplug the computer, remove the battery, wait half a minute, and put everything back on - only then I’d have audio working again. I had to do this every time after dualbooting to windows.

however, with opensuse tumbleweed, after an update (about a month ago) I’ve not experienced any sound problems at all - as far as I know it’s some issue fixed in the latest updates to pulseaudio.

Have you tried installing pulse audio volume control (pavucontrol) and checked to see if that has the audio muted ?

Have you tried unmuting the headphones and check to see if any sound going to the headphones ?
.

Further to my above post, do you get any errors with the above in the konsole or xterm when you run it ?

wrt pulse audio volume control (pavucontrol) note that the sound volume and sound output device selection can be controlled on a per application basis. Hence its important with pavucontrol we confirm that pavucontrol is not muting the sound, and that it is not being sent to the wrong audio device (although in your PC’s case I think there is only one audio device, which is your ASUS laptop V1JP).

Thank you for your replies.

I tried all of your proposals, nothing really worked.

I get some faint, distorted output via headphones though, when I use the KDE audio control module (in the mixer menu) to produce a test sound. It is distorted, but creates a stereo effect. And it is independent of the model setting in 50-sound.conf

The speaker test (speaker-test -Dplug:front -c2 -l5 -twav) runs normally. I get a complaint about a bad address, though, in the moment I interrupt it with Ctrl-C.

I used pavucontrol, reinstalled alsa and pulseaudio, removed power and battery for a while.

Is there a chance to use some Tumbleweed modules, or would it break my dependencies?
@salhelder: Which pulseaudio version do you have now?
Cheers

it’s the 8.0-3.1 (according to yast2’s software manager), I believe in 42.1 the latest is a patched version of 7.0.

Is there a chance to use some Tumbleweed modules, or would it break my dependencies?

it probably will.

From what I read, your laptop is not that new and there is good Linux support.

Lets confirm there is no files on your /home that could be causing this. Remove any /home/Lorchi/.pulse ; /home/Lorchi/.config/pulse ; restart and test.

If that does not work, I’m wondering if the alsa driver that is installed with the kernel is at fault. My recommendation would be to try forcing a re-install of the kernel.

Failing that working , write a bug report on openSUSE Leap-42.1. There is guidance here: https://en.opensuse.org/openSUSE:Submitting_bug_reports You can use your openSUSE username and password to log on to bugzilla. Ensure your bug report complete as the openSUSE packager will not read a forum thread. Attach to the bug report the output file from running


/usr/sbin/alsa-info.sh --no-upload 

and then upload the /tmp/alsa-info.tx.somenumber and attach that to the bug report. Then watch the bug report and an openSUSE packager, who is also an alsa sound driver developer will answer. if anyone can solve this probem, he can.

I would recommend the bug report approach. Or you could try installing a newer kernel from one of the openSUSE Leap kernel support repositories.
.