Intel HD - Wrong Display


I am trying to setup openSUSE 11.4 x64 on my Latitude E6510 with Intel HD chipset and Core i5.

Already the installer is displayed only through VGA output, thus on my external monitor. The builtin one is just black. And this keeps staying the same … well forever. After installing the whole system, a small text portion at kernel boot time and the BIOS splash screen appear on the builtin monitor but that’s it. In the display config GUI “Identify Monitors” displays both “eDP1” and “VGA1” on my external monitor, so it seems like SUSE thinks they were both the same while actually “eDP1” should be my builtin monitor!? I already tried installing latest drivers also from the official reprository and from source (Xorg Intel Driver, version 2.15). Nothing has changed. Then I tried the tutorial here at openSUSE to solve display problems. The result is that the system is broken by now :). But that doesn’t matter much. I just want to know what I have to do on a freshly installed system or better at boot time, since I couldn’t install OpenSUSE if I didn’t have an external Monitor and this is a serious issue I think!!

No I can’t disable the VGA output in the BIOS…

Please note: Windows as well as all other Linux distributions I’ve tested so far work correctly!

The last two weeks were very frustrating. I tried almost any Linux distribution out there and while all others like Ubuntu, Debian and Mint were able to detect my hardware correctly, they were either unstable as hell (ubuntu) or had some annoying hardware bugs (debian) or whatever. OpenSUSE seems to be great. But after all it doesn’t function correctly on my Laptop. I hope one of you is able to solve my hardware issues.

thanks and best regards

When the external monitor is NOT plugged in, does the integrated display work ?

When you have the external monitor plugged in, did you try typing the command “xrandr” to see if that allowed you to configure things ?

No it never works… As I said without the external monitor I couldn’t install it. So no, it really only works through the VGA connector, in either case my builtin display is BLACK, but active (which actually means that I can change the LCD backlight but thats it).
I don’t really know what to do with xrandr… I used the graphical configuration utility. But as long as it thinks both displays are the same…

Isn’t there any way to use /etc/X11/Xorg.conf?
At least that’s the way I could always solve these issues but since OpenSUSE is not using it, I am just lost.

Uh it seems like the LVDS (laptop display) is not detected at all.

>xrandr -q

only outputs one display and as I read it, DP1 is display port and VGA, both mapping to the same screen which is quite logical. But the builtin display seems to be completely missing…

I now also tried Linux Mint again, and it works like a charme, so it really has to be an issue of OpenSUSE…

Hmm now I did a BIOS reset. At least the installer seems to work now on my native monitor. I hope this also applies to the installed system…

NO it doesn’t work after installation. This is really strange. Another thing that really annoys me is that I enter my password for drive encryption with my non-us keyboard layout and after restart I have to enter it with US only keyboard layout. This is something like a no go. I don’t understand why some sort of bug like this makes it way into the final release…

Did you try booting with different boot codes, such as ‘nomodeset’ ?

In truth, you likely need to provide more information for anyone to have any hope of helping. One needs more than Latitude E6510 with Intel HD chipset and Core i5.

What is the output of:

/sbin/lspci -nnk | grep VGA -A3

Note Linux is case sensitive.

You could also post output of /var/log/Xorg.0.log file to SUSE Paste and then share here the URL indicating where the file contents are pasted.

I confess I did not ask for ouput of " xrandr -q " but I am curious to see output of ‘xrandr’. I assume they provide the same, but I’m not sure. Again, copy output of ‘xrandr’ to SUSE paste and post output here.

Also, knowing it works in another distro (such as Linux Mint) is great, but unless you advise what version of Linux Mint X server, what version of the Intel driver, what kernel version, etc … its not much help (other than provide a massively vague sense that it can be made to work elsewhere).

Edit - and please confirm you have NO /etc/X11/xorg.conf file clouding the situation. Also confirm you made NO EDITS to the /etc/X11/xorg.conf.d/various-files.

No I really didn’t change anything… It just doesn’t work directly after installation. Thanks for your help :), I really appreciate it! But I’ve installed Kubuntu 11 now and it looks very similar, so I guess its the KDE theme that got the great look. Kubuntu also works out of the box while Linux Mint seems to have trouble as well. Since Kubuntu is using the latest kernel (.38) and all other distributions with an outdated kernel (< 2.6.38) seem to have these issues (if not the very same but all graphic and sound related) I guess this is something fundamental just that in openSUSE it generates the most critical situation in which you just can’t use it. So I guess a kernel upgrade to the latest would do the job if someone else has similar issue but I can’t be sure and I also had enough kompiling and try&error the last weeks. I am really done by now ;), and will just stick with Kubuntu which seems to work great out of the box, in contrast to the overall unstable ubuntu, which I have used in my first attempt of switching to linux.

A little final update… Kubuntu says “eDP1” is indeed my primary display which means that openSUSE is really messing up the internal display with the VGA port or let’s say it just seem to output all graphics through the VGA output, thinking that this would be my primary (and more critical, my ONLY) device.

Glad to read its working for you with Kubuntu.

For anyone else, if you wish to try the 2.6.38 kernel with openSUSE-11.4, its very easy to do by adding the tumbleweed repository and updating the kernel from there.

Ok thanks, then maybe I will try this on another hard drive… But as I said, I am not sure if that alone would fix the problem.