[intel graphics] opengl

Greetings !!

I have had some issues with the installation of a sufficient version of opengl to open the road to big applications for my students in my lab.
We have bought some “new” computers equipped with G4400 processors and HD 510 video chipset.

The problem is that I don’t want to upgrade to LEAP, I have my reasons, (my test machine with LEAP has the same issue as I have a i5 processor in it).
I also have another i5 with 13.2 and I experience the same issue.

I shortcuted the issues as related to intel familly processors as all the amd computers have a working opengl environment.

The problem is that I never found a driver for the intel equipped computers.

The window manager (KDE/Gnome) has loaded the MESA driver (10.3.7 for most of all, on the LEAP computer I got 11.0.8)
In the 14 computers equipped with intel processors I got lot of skylake, one haswell and one ivybridge chipsets. As far as I’m correct.

The focus here will go straight on the skylake computers.

I tried to install the lastest MESA driver on those computers… I got kinfocenter telling me that 12.0.2 was installed, but once rebooted the computer I have no more opengl installed.
I got a message in the kinfocenter telling me “can’t intialize opengl” when trying to get graphical environment informations related to opengl.

Same when trying to launch opengl applications developped by my students: can not intialize opengl or something more precise I did not write down.
I switched back to MESA 10.3.7 (it’s so simple, it’s amazing).
My question is: is somebody or a crew are interrested to tell me how I could install the correct intel drivers in order to have the great joy to exploit the full opengl capabilities of the intel’s chipsets ??**

I know that X rely not only on MESA to use opengl so installing MESA 12.0.2 without telling X to use it with KDE/Gnome may be the point I missed (that the poor explanation I have regarding the failure I described above).
As the 13.2 and LEAP 42.1 have their proper MESA drivers I think it’s normal kInfoCenter won’t do nothing more than display that MESA 12.0.2 is installed (note that code executed under this environment uses MESA 12.0.2) but once rebooted there is no more tracks of 12.0.2, the opengl is simply kicked off.

I tried to download and install the intel drivers from their site but none of those I tried were working… they seem to provide ubuntu, fedora drivers but nothing for our beloved opensuse distrib :{
The source code have to be modified to avoid compile code for fedora/ubuntu/… and I never succeeded to make the whole stuff work. I have no sufficient patience and knowledge :{

Thanks for your patience…

Try Leap 42.2 Beta 1 since the 4.4 kernel has better skylake support. You could also try using a later kernel on an existing system.

I was thinking to tell how compile new kernel with my students but I wasn’t sure in the fact to put a 4.x kernel on a 13.2 version will open the gates of the opengl 4.5 (we need at least uniform features) on intel based graphic chipsets.

I saw on the intel’s website that they provided stuffs in this way (https://01.org/linuxgraphics/downloads/2016q2-intel-graphics-stack-release) but personaly I find it scary regarding the list of the stuff that doesn’t belong to a distrib repo as 13.2.

The horror in such site is that we can not have an idea of what is the opengl version provided for each driver… and which chipset it supports AND, again, opensuse is aside of their interrests… I don’t think fedora is a opensuse alike.

It’s all bleeding edge, but present in Tumbleweed or greater in the Intel list you provided the link for…

For 13.2 it’s an older kernel,. so hard to support…? How to know what’s around the corner hardware wise when shipping a release…

For example I have a HP ProBook (circa 2013) with AMD APU/GPU it needs the fglrx driver to enable the boost states (Clock the CPU up to 3.3GHz), no more fglrx, amdgpu-pro for Ub* only… so upgrade means stuck at 2.7GHz…

I have a DELL 5555 (circa late 2015) with the Mullins R5 gpu, it’s only just started working in Tumbleweed (once added from a bug report) and rebuilding xf86-video-amdgpu from git, on Leap 42.2 it needs a kernel module tweak (missed the MULLINS entry) as well as a rebuilt xf86-video-amdgpu from git. It also still has an open bug report when the screen saver fires up with a kworker sitting on one core at 100%.

If you keep an eye on for example https://lists.freedesktop.org/archives/dri-devel/ you will see lots of patches/issues with intel, but the big problem will be looking at backporting and the effort involved…

Perhaps you need to look at adding a discrete card (eg Nvidia) for your needs…