Intel Graphics on openSUSE 11.4

I upgraded my mother’s computer from openSUSE 11.3 to openSUSE 11.4 last night and now we’re having some issues with the video display. The resolution isn’t set correctly, and I can’t seem to set the correct resolution in KDE with systemsettings, nor from the command line with xrandr.

The right side of the screen is black/empty, and I can’t see the bottom of the screen because it is displaying the wrong resolution.

Even more odd is that systemsettings shows two displays active. This is an All-In-One PC with the monitor built in. I’m not doing any video out.

VGA1 shows the correct resolution (native resolution) of 1680x1050.

LVDS1 shows 1600x1200, which explains why I can’t see the bottom, and why the right side has empty space.

The problem is that if I disable LVDS1, I get a blank screen. And I can’t set LVDS1 to the correct resolution. It doesn’t show as an option.

Looking at lspci, I see the Intel i915 driver is being used, but I don’t know if that is the correct driver. lspci -v isn’t telling me the specific chipset.


/sbin/lspci -nnk 

It reads like your all in one display is the LVDS1 display.

Can you help us on this thread understand better your problem by copying the output of:


and posting it to SUSE Paste and then post here the output URL/webaddress where that content is located.

and also copying the content of /var/log/Xorg.0.log file and post it to SUSE Paste and then post here the output URL/webaddress where that content is located.

Sadly, still no help.

00:02.0 VGA compatible controller [0300]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e22] (rev 03)
        Subsystem: Sony Corporation Device [104d:9044]
        Kernel driver in use: i915
00:02.1 Display controller [0380]: Intel Corporation 4 Series Chipset Integrated Graphics Controller [8086:2e23] (rev 03)
        Subsystem: Sony Corporation Device [104d:9044]


xorg log:

I tried manually adding modes and modelines in xorg.conf.d but that just crashes X.

When I surf on the 8086:2e23 I get this page: PCI Devices which suggests your graphic hardware is the Eaglelake HECI Controller or 4 Series Chipset Integrated Graphics Controller. So that does give some info.

I see the LVDS1 has 1400x1050 resolution available. I take it that is not the correct resolution either ?

Further to this post of mine, I note from the /var/log/Xorg.0.log file :

#    28.270] (II) intel(0): Integrated Graphics Chipset: Intel(R) G45/G43
#    28.270] (--) intel(0): Chipset: "G45/G43"

further identifying your graphic chipset.

I’ve been Googling G45 xorg.conf or G45 Linux for hours and I’m still at a loss. It seems that using the “intel” driver is recommended (which I’ve done by editing 50-device.conf)

The video card supports 1680x1050 resolution. It certainly did with intel drivers under openSUSE 11.3. It shows that it will handle that resolution over VGA out. The odd thing is that it thinks VGA out and LVDS1 are both enabled at once, despite the fact that I’m not doing video out. And it doesn’t seem to think the built-in monitor can handle the resolution (even though it always has). I used cvt to generate a modeline to put in 50-monitor.conf but when I use it, X won’t start.

Option "PreferredMode "1680x1050"
Modeline "1680x1050"  146.25  1680 1784 1960 2240  1050 1053 1059 1089 -hsync +vsync

I also tried a line I see most people use with this video chipset.

Modeline "1680x1050"  146 1680 1784 1960 2240 1050 1053 1059 1089

X just doesn’t seem to believe this monitor can handle that resolution, and it won’t scale any other resolution to fill the screen, so I get empty areas on the screen. I dual-boot into Windows and the monitor is handling 1680x1050 just fine. And under openSUSE 11.3, I achieved that resolution just fine.

There may be a bug with 2.6.37+ or the newer Intel drivers. But if X is determined not to support that resolution on this monitor, I’m not sure what recourse I have other than wiping the partition and reinstalling openSUSE 11.3. Then I’d have no upgrade path moving forward.

Any other suggestions?

Sadly, Intel lists this as a bug with their Windows drivers where sometimes they can’t read the native resolution of LCD screens and can’t change to resolutions like 1680x1050. The fix is to install the latest Windows drivers and hope for the best. And unlike Nvidia, Intel doesn’t support pointing to a custom edid.bin file.

My “fix” wasn’t a good one. I didn’t want to wipe and reinstall from scratch, especially since this PC didn’t have a separate home partition. That surprises me as I normally do that on PCs I install.

I added the 11.3 OSS repo to an 11.4 install, and installed the old 2.6.34 kernel, and old version of Xorg. Now it only sees one display as active, and it defaults to the native 1680x1050 resolution. So there is definitely a bug with the new version.

Sticking with the 11.3 kernel forever isn’t a real solution. I tried the latest 2.6.39 kernel from Tumbleweed and have the same problem again.

I’m only using one monitor (this is an all-in-one PC) but xrandr shows two video devices active with new kernels, VGA1 and LVDS1. VGA1 is set to 1680x1050 (the correct resolution) but that doesn’t show as a valid resolution for LVDS1, and the intel driver doesn’t support the CustomEDID option.

I’m really at a loss here and would appreciate some help.

On 07/15/2011 03:06 AM, enderandrew wrote:
> I upgraded my mother’s computer from openSUSE 11.3 to openSUSE 11.4 last
> night and now we’re having some issues
> [snip]
> (this is an all-in-one PC) but xrandr shows two video devices active with new kernels, VGA1 and LVDS1.
> [snip]
> this PC didn’t have a separate home partition.

this is a bit confusing to me, because:

  1. i wonder which of these supported paths did you follow to ‘upgrade’
    from 11.3 to 11.4:



c. fresh format and full install (having saved data off machine)

d. a new way, you invented (please explain)

2 my wonderment increases when you say the “PC didn’t have” a separate
home…because i wonder how that happened:

e. was the PC purchased with 11.3 pre-installed by the maker/seller,
without a home partition?

f. was the PC bought with something older than 11.3 installed (without a
home partition) and you ‘upgraded’ (from say 10.x)? if so, explain how
you made that upgrade…

g. what is the file system in use for the install partition? (is there
another OS on board? what?)

  1. hardware with two video devices and one screen sounds interesting:

h. would you mind telling us the maker and model of this device?

i. does it perhaps have a touch screen (which might be showing up as a
second video device)

  1. general:

j. do you have a complete system backup made with the working 11.3
(prior to the 11.4 ‘upgrade’) which you can revert to?

k. was there an active xorg.conf file in the 11.3 (or previous) install?
do you have access to any xorg.conf which worked on the hardware?

l. since it seems this device might have had a life prior to 11.x (as
10.3 by default, had a home partition), please tell us its age and
hardware info…that is, does it meet the recommended (not minimum)
hardware requirements of 11.4, found here:

note: you may see no logic in my questions, but they spring up because i
get the notion you may need to save off the collected data (music,
emails, whatever) and do a complete format and then a fresh install of
11.3 (which used to work, right?)

because, it sounds like maybe part of your problem is a series of
upgrades which has left ‘stuff’ lying around in the corners to mess up
the soup…

and then figure out what is the best way forward with the hardware
limitations you have…

like, “Sticking with the 11.3 kernel forever” may be the only real
solution available to mom, with that hardware…and, that might be
the only real solution for you that is possible when (if?) 11.3 falls
under Evergreen’s purview…

or, maybe (depending on hardware limitations) the only real solution for
keeping this hardware in use safely and securely is to transition to a
different distro with less hardware demands, but with updating of
security patches, etc (like Puppy or one of the other ‘slimmer’ distros)…

openSUSE®, the BMW® of operating systems!

Trying the latest 2.6.39 kernel from Tumbleweed was a reasonable attempt. Unfortunately for the very latest thats not quite enough, as Tumbleweed has only the version 7.10 of Mesa and xorg-x11-server version 1.9.3 where the latest Mesa is 7.11 (and there is already heavy development on 7.12) and the latest xorg-x11-server is 1.10 … But its not a trivial matter to update to those on openSUSE and best to WAIT until they do show up in Tumbleweed.

Did you try the opposite approach, going for the Intellegacy driver ? ie assuming you have no /etc/X11/xorg.conf file (you need to tell us if you do) then edit the /etc/X11/xorg.conf.d/50-device.conf file, changing it to:

Section "Device"
  Identifier "Default Device"

  #Driver "radeon"
  Driver "intellegacy"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"


reboot and test. Also do NOT keep backups in /etc/X11/xorg.conf.d/ directory, but keep them elsewhere. Backups in that directory with an inappropriate file name will still get executed.

One futher note - the help you want here is VERY specific to obtaining certain resolutions (from what I can read). Frankly, your title for the thread you started is HORRIBLE for achieving that. Our most knowledgeable volunteer users in this area will likely never pay attention to this thread due to its far too general title. If it is resolution support you wanted, you really should have had a title like:

OpenSUSE-11.4 Intel graphic driver resolution help requested 

or something like that.

Having a moderator change the thread title is NOT an option, as it will break the thread for our NNTP users.

Anyway, good luck with your efforts.

I actually just wiped the computer last night and did a fresh install of OpenSUSE 11-4 and had the same problems.

I found that if I used the intellegacy driver, and turned off KMS by adding nomodeset to Grub, I would pull the correct resolution and it only showed one display as active.

So this appears to be a bug with KMS with the intel driver and this particular hardware. I’m not sure how much longer the intellegacy driver is going to be supported in the future, so I suspect I need to open a bug against the intel driver. Does Intel have a bug tracker upstream?

Well done on sorting this.

I have my 85+ year old mother on openSUSE-11.3 GNU/Linux (but in her case her PC has AMD Radeon hardware). Its worked well for me in helping her and her PC operating system works better now than it did when running MS-Windows.

What I would do in a case like this (if it were me) is write a bug report on openSUSE-11.4 following the guidance here: openSUSE:Submitting bug reports - openSUSE You can use your openSUSE username and password to log on to Bugzilla.

Now its possible that the bug will be closed immediately as it is an upstream problem. So to be ready for that, if it were me writing the bug report, I would ask at the end of the bug report if the openSUSE packagers knew of the website I should go to in order to write the same bug report on the upstream tracker. … And then sit back and see what I could learn from their response. :slight_smile:

Good luck and thank you for your efforts.

On 07/15/2011 04:36 PM, enderandrew wrote:

> Does Intel have a bug tracker upstream?

if you have the correct driver installed (see and then feel the need to, please open the
bug in our bugzilla, here

so far the openSUSE developers have a reputation of bumping problems
upstream when that is warranted (which is unlike some other distros who
are known to not do that)…

but, be prepared to fork over the needed hardware info or nothing will

openSUSE®, the BMW® of operating systems!