Intel GPU 8xx issues, will 11.3 have them too?!

My laptop has an Intel graphics 8xx chip(card?) and when Ubuntu 10.04 came out I tried to run it on the laptop. It didn’t work.

Research led me to find out I wasn’t alone and while the temporary work-around (i915.modeset=1) work, the system crashes when trying to view video.

I just received an email (quoted below) regarding this bug from Linux.com.

Is openSUSE aware of this and will it be effected when openSUSE 11.3 comes out (next month?)?

from Re:Intel 855GM Woes - Linux.com: Linux Forums | Linux.com (1 Month, 1 Week ago)

Basically, the Intel Linux developers have decided to screw with the i915 gpu Linux kernel driver which used to work for the Intel 855GM or Intel 85x graphics chips. They have decided to drop ums (user mode setting) for the driver without providing a working kms (Kernel mode setting) alternative. So in short, if you have an Intel 85x graphics card (Extremely common on slightly older Pentium M Centrino Notebooks) You have practically zero chance of using any current distribution release which uses a current version of the Linux kernel and be able to use any kind of working xserver (Say for instance to use a desktop, kde sc, gnome, xfce, etc.)
<… snip …>
This issue has been known for and was reported over six months ago now. The developer who pushes the updates to the i915 driver was told that the commits he was about to push were a regression but still he pushed them and it was merged anyway.

The problem manifests itself as a complete lock up when the x server has started or shortly after the xserver has started. No magic sysrq key combination or ctrl + alt + backspace key combination achieves any kind of escape from the lock up and the only solution is to power down the machine manually by holding down the power button.

Conversely, there is a patch for Ubuntu that is linked to here Live-CD of Ubuntu 10.04 with updated Intel-drivers and 855gm-patched kernel-modules « Glasens Blog which includes 855GM - fixed kernel modules](https://launchpad.net/~glasen/+archive/855gm-fix).

A problem with the Intel 855GM has bit many people.

I reported on this a long time ago:

I note a bug reports on openSUSE:

  • here for openSUSE-11.2 closed because the bug is upstream;
  • here for openSUSE-11.3 still open, but I do not anticipate a fix (although one never knows).

and what might be important is a possible fix here in post#61:

As for the email you received from linux.com, I do not know who you received that from, and I do not know if the “reason” quoted in that email is 100% accurate, although it may well be. … and it may not be. The lockup that happens is definitely the case. In my laptop’s case using “acpi=off” works around the problem, but I refuse to accept that work around on a laptop. I see no reference in the email you quote to there being a possible solution, which I noted in the bug reports.

I currently have my laptop with the Intel 855GM running openSUSE-11.1 (where support is going to disappear in around 5 months) with a non-official KDE-4.3.5 from the KDE stable repository. I am very careful with updates to KDE as an inappropriate update could break KDE (as KDE-4.3.5 is NOT supported in openSUSE-11.1, which is packaged with KDE-4.1.3). My guess is I will have to stick with 11.1 for another year or so on that laptop (unsupported) until this situation can be sorted.

I do NOT have regular acess to that laptop (as my wife (a very big winXP fan) uses it all the time with its winXP partition) so fortunately openSUSE on this laptop is not “mission critical” software in my case.

I agree, I don’t fully believe all of the statements he made in his post on Linux.com.

I wonder if it would be wiser to go with an older or enterprise version (CentOS or SLED). I don’t know if these will be holding off on the kernel/Intel updates the same as the community ones.

What gets me is that this is the FIRST issue I’ve ever had with my laptop. The Broadcom has been working fine and is only a couple extra (expected) steps, but this is annoying.

I’m wondering if anybody with openSUSE is watching what others are doing, since it looks like there is a (temporary at least) patch available from Launchpad (linked in my original post, under the quoted portion).

Will be interesting to see how Fedora handles it, since they are coming out with 13 next week. At least with openSUSE there is still time before 11.3 comes out.

I guess it depends on what you mean by “anybody with openSUSE” ?? If anybody, then I would say YES as you and me are watching.

If you mean SuSE-GmbH (as being “anybody with openSUSE” ), and if you mean “watching” wrt the 855GM, then I don’t know. I imagine they are pretty busy with 11.3 M7 preparations, and there are far more serious issues for them than kernal hacks/patches for relatively old hardware associated with the 855GM when the problem is UPSTREAM and not their fault, nor a problem associated with their direct packaging of openSUSE. The problem is with the kernel interaction with the 855GM and the Intel driver/Mesa/Xorg. For SuSE-GmbH to address this would be to apply a patch that someone else created onto the openSUSE kernel, making the kernel diverge even more than normal from a standard vanilla kernel.

I hope they do find a fix and patch, and I have been updating the openSUSE-11.3 bug report I raised with information as I find it, but I am just a regular user like you, and whether my efforts have any impact is not something I can say. I do believe they are very busy, so I am not going to hold my breath on a patch for an old piece of hardware.

Its always interesting to watch Fedora and Ubuntu (and debian in general) as to what they come out with. But I disagree with you in your saying “there is still time before openSUSE-11.3 comes out”. IMHO the time may have come and gone already for such a fix, as openSUSE-11.3 is very close to a freeze, and only major bug fixes are addressed, and the 855GM hardware is old and not likely on the top of the list for SuSE-GmbH fixes to openSUSE-11.3 (although I would like to see this fixed).

The time to ask for a fix is not 2 months before a release. That is too late. FAR FAR FAR too late. Even my bug report on openSUSE-11.3 M4 was likely too late in the milestone process to have anything done in 11.3 (and at that time of my bug report being raised, the possibility of there being a fix was not yet known).

No, my view is openSUSE-12.0 may be the first time we see a fix on this, in April-2011 or so. …

ouch. 2011?

Here is another bug report … this one on the kernel with KMS broken on Intel 855GM broken with 2.6.32/33
https://bugzilla.kernel.org/show_bug.cgi?id=15248 with a status " RESOLVED PATCH_ALREADY_AVAILABLE "

… IMHO it was broken before 2.6.32 (ie broken in 2.6.30 and 2.6.31) …

I do not know enough about this to tell nor recommend what is the current status/fix (if any).

Ubuntu does have a patch, although it isn’t perfect, available. It is FAR from idea, but better than nothing.

I’ll be testing it on the ubuntu box tonight, but I really hope they are going to continue to try and fix the issue.

I don’t like the idea of having to go out and purchase a new system to run my Linux on it. That’s too Windows~ish!

According to some feedback here, based on our input the bug report on 11.2 was reopened by SuSE-GmbH (I think):
Access Denied Which suggests the 11.2 kernel could be updated with the fix IF we can do a bit more … which is … they want input (from me ??? ) telling them when the Linux git tree has been updated with the patch.

I have NO idea how to tell them that. :confused:

I can confirm that this 855GM Ubuntu “community” liveCD runs on my 855GM fitted laptop. The Ubnutu release appears to have the 2.11 Intel driver an 2.6.32-22-generic kernel. I checked the Xorg.0.log file and it is the Intel driver that is loaded when X runs. Ubuntu uses Gnome, and I do not know anything about Gnome, so I can not tell if special desktop effects work with this patch.

We need to see if there is something relevant in the patch that can be applied to openSUSE.

I documented applying the patch for the computer club here](http://www.dacs.org/forum/viewtopic.php?f=12&t=222) and performed it last night. I used this location because in the Ubuntu forums I had some back-and-forth with the person who developed the patch as he was correcting my procedures.

(found out I misspelled repository in one place too :open_mouth:)

I can attest that it does allow for video playback without crashing, but hooking up to an external monitor still doesn’t work (unless you want to feel sea-sick from all the jumping around), and trying to set the desktop effects crashed the system.

These were kinda known limitations when I was applying the patch, but still a heck of a lot better than it was before.

True, but if that is the case, I am still inclined to stay on openSUSE-11.1 where with the 2.6.27 kernel connecting to an external monitor does work, as does special desktop effects. I may just accept the fact that support for 11.1 will stop (and I will use an unsupported 11.1 anyway), and I’ll keep tracking/supporting the bug reports until as much as possible is fixed.

As you note, the entire impact of the i855GM regression has not yet been addressed.

I did not try desktop effects (I do not know how to do that in Gnome).

I can state that the external monitor (on a projector in one of our conference rooms) did WORK with that special Ubuntu test liveCD with the patch. There was no jumping around on a MASSIVE screen, and hence it was acceptable for my use for presentations (at least it was acceptable on that projector).

I do not know how this is supposed to work in Gnome (as I am a KDE user). When I plugged in the external monitor there was nothing. I then typed only “xrandr” and obtained some message about xrandr not working due to the CRT being “out of range”. I noted the external projector was called “VGA1”, and so I typed a more useful command:

xrandr --output VGA1 --auto

and it “just worked”. I’m not a Ubuntu fan, and while I like Gnome, I still prefer KDE, … but that was not difficult and that is workable for myself. So it does not appear to be as bad for someone with my use. I am curious about Special Desktop effects with that patch, but I have NO IDEA as to how those are launched in Gnome nor in Ubuntu hence I could not test that.

I’m a Gnome user… whether Ubuntu, Fedora or openSUSE.

For an external monitor you can go into System and I under either Preference or **Administration **there should be an icon for Monitors or Displays.

There you should be able to Detect Monitors and there may be an option to enable the other monitor, clone, etc. (not sure what options are available with which version).

My external monitor jumping around existed before I ran the patch last night, so running the patch only didn’t change a thing in that department.

Oh, and desktop effects you can get to by going into System > Preferences > Appearances.

You’ll find the last tab (not sure what it’s labeled right now) provides 3 options basically for None, Some and All desktop effects. I think you have to download something else if you want a GUI for managing what desktop effects to enable. I don’t normally use this so I can’t tell you the name of it.

OK, I have special desktop effects running on that test liveCD on the i855GM with a 2.6.32 kernel (at least the “wobbly window” when one quickly drags a window up and down). I do not know how to do anything else in Gnome in this respect, but it does appear that some special desktop effects work. I have had no crash thus far.

This fix appears signficantly better than I initially anticipated. I may start pushing the two bug threads to adopt this patch , although I have provided a lot of (possibly confusing) input to those threads the past few days, so I may just wait and see what sort of possibly upset comments I get back in return.

I think I’m going to have to try out the Live-CD version and see if it rectifies any of my other issues.

“compiz” as well as some setting GUI. On my laptop the 11.3 Milestone 6 worked ONLx well if 3D graphic=compiz was turned OFF. The newest kernel from HEAD for factory (…34-34…) did not help.

Two days ago I tested Ubuntu 10.4 LTS with a live DVD and all 3D effects worked well on the same laptop. Even more effects worked with the Compiz stuff installed from the internet on my RAM disk.

In my openSUSE 11.2 system (out of which I write now) I have 10 packages with “compiz” in name or description installed:


1. "compizconfig-settings-manager" epoch="0" ver="0.7.8" rel="7.1" arch="noarch"/>
2. "compiz-manager" epoch="0" ver="0.0.1_git080201" rel="60.2" arch="noarch"/>
3. "compiz-gnome" epoch="0" ver="0.7.8" rel="43.44.1" arch="i586"/>
4. "compiz-fusion-plugins-main" epoch="0" ver="0.7.8" rel="14.2.1" arch="i586"/>
5. "compiz-branding-openSUSE" epoch="0" ver="0.7.8" rel="43.44.1" arch="i586"/>
6. libcompizconfig" epoch="0" ver="0.7.8" rel="8.1" arch="i586"/>
7. simple-ccsm 0.7.8-18.1  (i586)
8. simple-ccsm-kde 1.1-4.1 (i586)
9. python-compizconfig 0.7.8-2.1  (i586)
10. "compiz" epoch="0" ver="0.7.8" rel="43.44.1" arch="i586"/>

If I recall it right: In Ubuntu were newer versions/packages installed (one package even with 1.? - could not remember which one).

Greetings pistazienfresser

I note you put a similar post on the Fedora forum.

In addition to openSUSE and Fedora, did you also start a similar thread on other Linux distro forums?

… ahh … I see also Linux Mint forum. Any others?

I was reading the kernel log article on the 2.6.32 kernel, and it noted numerous bugs with Intel series 8xx chip-sets that have occurred since GEM was introduced in 2.6.27, however those fixes have not been enough to help in the case of my Fujitsu-Siemens Amilo M7400 (with i855GM) as I still get the freeze.

I also attempted the i915.modeset=1 kernel code (and also acpi=off kernel codes) earlier today on the 11.3 M7 KDE liveCD, and it made no difference. Again, a freeze soon after X windows comes up. Thus far I have only been able to get X to work on that laptop (with i855GM) with 11.3 M7 by using the FBDEV driver.

wow… cool trick considering I don’t have an account in Mint :slight_smile:

I frequent the “big 3” as I call them (in no particular order); Ubuntu, Fedora and openSUSE.

Actually it came up first in the Ubuntu one since I didn’t have any issues until 10.04 came out and in searching found out I wasn’t alone and some of the back-information on the bug.

So I started thinking, Fedora 13 is coming out (tomorrow, if they don’t push it back again) and openSUSE 11.3 in a couple of months, so I wanted to know if they (a) know about it, and (b)have any solutions.

I downloaded and burned the Live-CD but I better recheck the download/burn because it doesn’t succeed for me on a second laptop I have which has exhibited the same issue and has an Intel GPU.

(btw… you’ll know it’s me… I use the same moniker because otherwise I’d go insane trying to remember all the different usernames. I have enough trouble with passwords!)