Intel GMA 3650 driver- 3D acceleration and brightness adjustment

I bought netbook Acer Aspire One D270 with Intel Atom N2800 CedarView processor (probably with Intel GMA 3650). There was Linpus for MeeGO operating system installed out-of-the-box but I tried to install openSUSE 12.2 as second OS. I have found using Yast that openSUSE uses gma500_glx as GPU driver:

lsmod | grep gma500
gma500_gfx            138220  2 
drm_kms_helper         45453  1 gma500_gfx
drm                   231978  2 gma500_gfx,drm_kms_helper
i2c_algo_bit           13197  1 gma500_gfx

Also I glxinfo says that there is 3D acceleration enabled:

glxinfo | grep direct
direct rendering: Yes

Nevertheless 3D performance is very poor.

824 frames in 5.0 seconds = 164.797 FPS

Moreover brightness adjustment with shortcut Fn+(left_or_right_arror) is not working.
Is there any other driver for this GPU, which support hardware 3D acceleration and brightness adjustment?

Enter this command in a terminal as normal user:


What happens and/or what is output?

On my intel GM45 chipset, glxgears only gives 62.550 FPS and 3D performance is ok. It’s well known that glxgears cannot be relied on as a benchmarking tool for 3D performance as its 3D output is too simplistic (i.e. the image rendered).


No outputs have backlight property 

I tried use

echo 10 > /sys/class/backlight/psb-bl/brightness
as mentioned here but it is not working. Now I am using little script but it is just a workaround:

sudo su -c "setpci -s 00:02.0 F4.B=$1"

As for 3D acceleration: in MeeGo glxgears generates about 600 FPS. There is some binary driver for GPU (quote from Xorg.0.log):

133.333] (II) LoadModule: “pvr”
133.391] (II) Loading /usr/lib/xorg/modules/drivers/
133.428] (II) Module PVR: vendor=“X.Org Foundation”
133.428] compiled for 1.9.0, module version = 1.7.2405
133.428] Module class: X.Org Video Driver
133.428] ABI class: X.Org Video Driver, version 8.0
133.428] (II) pvr: Driver for PowerVR chipsets: PowerVR SGX

I wonder if there is similar driver for openSUSE.

Definitely don’t compare glxgears results across different systems. You are hunting in the right area for both symptoms pointing to inadequate driver/kernel module support. It maybe too early for a properly working driver cross-linux. Have a read of this thread on GMA 3650 aka. PowerVR sgrx545 and…

Particularly read right down pages below item 80 onwards. Meego and Ubuntu is mentioned. It goes back to July 2012, but there may be some clues in there as to a source for that pvr driver. I flipped through it rather quickly. :slight_smile:

Take a look at this more recent discussion about the driver ( Apparently oS 12.2 skipped Xorg release 1.11 and that driver was only built for that release. See near the bottom of that page.

You are right, ReleaseNotes from package says the same thing:

The following dependency sets are supported:

Bundle "Ant"
 * Kernel: 3.0.0
 * Mesa GL: 7.9
 * Xorg: 1.9

Bundle "Bee"
 * Kernel: 3.1.0
 * Mesa GL: 7.11
 * Xorg: 1.11

Moreover it needs kernel recompilation with some patches provided in this package. It’s a little too much for me. I hope that someone more talented will find solution for it and will create package for openSUSE.

Indeed. Thanks for confirming and posting the important details. That will save others some anxiety in the same situation.

Sorry the status is not better at this time. However the availability of a driver for Xorg 1.11 is somewhat encouraging, and so is the presence of recent internet discussion on the driver shortfall. Let’s hope Intel take notice, especially if the requirement hits their own forum. :wink: