Intel Device 8a52 - fbdev

Hi all,

I just got a new laptop with an integrated graphics from Intel. The CPU is an Icelake and when I run inxi -G it shows the card as “Intel Device 8a52” and the driver in use is fbdev which is obviously bad.

Does anyone have experience with this one on how to get it to properly recognize it?


I followed this guide to update the kernel and that seemed to have solved the problem completely in addition to fixing a couple of other minor issues with this laptop.

However, I’m wondering if there is a better way to get support for this hardware while still using the default kernel in opensuse. Anyone else solved this in a different way?

Create a bug report against the kernel requesting support be backported to the Leap kernel if possible. Else the kernel developers may have some insight on how to run the newer hardware.

openSUSE:Submitting bug reports - openSUSE

PS, post back the bug report number :wink:

Ordinarily I would think someone might spot a clue of you were to share Xorg.0.log from booting the stock kernel, but Icelake is so new I suspect there’s no chance unless your bug gets the kernel devs to backport, or they already have it scheduled but not yet done. Leap’s 4.12 does get a lot of it. The latest 4.12.x 15.1 kernel-default changelog is 879,476 lines, while for the 5.3.8 15.2A it’s a mere 155,091. :stuck_out_tongue:

In 6 months 15.2 will be released. Its alphas have been using 5.3 for more than a month. Betas begin in Feb.

Yes, that’s an important point. People having issues with newer hardware might want to consider moving to 15.2 when it goes to Beta.

Thanks all for the great answers! That’s pretty good news that the next version of Leap will have kernel 5.3. The hardware in this laptop works perfectly with that version. So I guess what I’ll do is just leave the kernel on this repo until the next update and then change vendors back to the default. :slight_smile: