Intel CPU doesn't idle on minimal frequency.

I’ve recently installed OpenSUSE Leap 42.3, and I’ve noticed that my CPU (Intel Core i5-4260u @ 1.4 GHz) works at 2.4 GHz all the time, even when CPU is not loaded.
Kernel is 4.4.126-48-default[FONT=arial], and I’ve tried kernel-vanilla, and it worked at 800-900 MHz as it should. Is it possible to fix without changing kernel?
Beforehand I’ve tried tumbleweed with [/FONT]4.16 kernel and everything worked just fine as well.
UPD: Also it doesn’t want to boost to full 2.7 GHz.

You might like to take a look at this Forum thread from the past few days…

It isn’t exactly what you’re asking about, but somewhat related.


If I’m understanding you correctly, I have had a similar problem.

I did this and have had no problem since.

Good luck!

Hi nicomunet123

Install cpu_freq in gnome applets…

then in terminal in root

ls -1 /lib/modules/`uname -r`/kernel/drivers/cpufreq/

modprobe cpufreq_conservative
modprobe amd_freq_sensitivity

(or Intel according to your configuration in the command - ls -1 /lib/modules/uname -r/kernel/drivers/cpufreq/ -)

modprobe cpufreq_powersave
modprobe cpufreq_userspace
modprobe cpufreq_stats
in your applet cpu_freq

click on install

then : Disable service : “irq_balance” on your system


My i7 4790K has this problem with 42.3 as well, always bobbing around 4.3 GHz.

I can make it behave more as expected by adding intel_pstate=disable to the “Optional Kernel Command Line Parameter” in the YAST Boot Loader control panel.

My understanding is that it’s a bug related to Intel p-state that is fixed in kernel 4.5. I’ve since been just accepting it as a bug while waiting for 42.3 to reach kernel 4.5

Your screen pics are of Debian 8.9 running kernel 4.9. Probably not a good comparative reference.