Intel Corporation 82801G (ICH7 Family) sound woes

Hello Everybody!!

I just can’t get sound to work on SuSE 11.1 desktop system.

Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01) is my sound card.

I’ve tried everything from raising the volume on each and every channel to updating the kernel specific alsa driver. You name it, I’ve done it!!

Here’s the link to my /usr/sbin/ output:

Looking to hear from you guys.


Whoa, 30 views and no replies!!

C’mon u guys there must be some Sound Card Guru out there.

> C’mon u guys there must be some Sound Card Guru out there.

unfortunately (for you) the sound guru is a guy named ‘oldcpu’ and
he is on vacation (i have NO idea who told him he could go)…

there are about a billion posts here from him on sound…you could try
searching the forum for his answers to similar problems…if i were
you i’d use the advanced search at

and put oldcpu in the “Search by user name” block and intel sound (or
something like that…wiggle it around until you find the answer
you need) and look for replies in (say) the last six months or so…

-good luck- i think he is back in four weeks, or less…

oh look, you ARE lucky: search on 82801G sound with oldcpu turns
up 30 hits going back to july 08, in .9 seconds

HINT: do not read just one and start ‘fixing’ because it might not be
THE one for you…read several…maybe you become THE expert and you
can take over until oldcpu comes back…


I’m still on vacation. I tried to look at that link, but its no good !!

Now the general advice I give for sound problems is to start trying to work your way through the openSUSE audio troubleshooting guide: SDB:AudioTroubleshooting - openSUSE .

Do NOT use the startup system sound as your criteria for stating sound does not work. Also be certain to check your mixer. Its not uncommon for a mixer setting (master, pcm or speaker) to be muted upon boot. In KDE your mixer is “kmix” (the small speaker in right hand corner). In Gnome your mixer is “alsamixer”.

Note, when testing if you have sound, please copy and paste the following speaker-test into a Gnome terminal or a kde konsole:

speaker-test -Dplug:front -c2 -l5 -twav
Note Linux is case sensitive, and “D” is not the same as “d”. To stop the above test, while the konsole/xterm has the mouse focus, press <CTRL><C> on the keyboard. Note you should check your mixer settings (kmix if using KDE, and alsamixer if using Gnome) to ensure that PCM and Master Volume are set around 95%. Once you have basic sound established you can back off to lower volume levels. Note the test for surround sound is different.

If that test yields errors (and its not uncommon to get errors there), try instead this more simple test: speaker-test -c2 -l5 -twavYou should hear a female voice saying ‘FRONT LEFT’, ‘FRONT RIGHT’ five times. Its quite common that one of those speaker tests will work and one will NOT work, so don’t be distressed if that is the case. IF that test gives sound, stop now, post that the sound test gives sound, and we will look at other possible causes for your applications not giving you the sound you want (such as missing codecs, using the wrong packaged version … etc … ).

Or alternatively, for testing the simple playback, use aplay program. Prepare a WAV file and simply run like:

aplay -vv somefile.wav

With the option -vv, aplay shows the verbose information of the PCM device, and a VU-peak meter during playing the file.

Try those speaker-tests as both a regular user, and also with root permissions. If you have a headset, try with your headset plugged in, and also with your headset not plugged in (for speakers).

Assuming no sound, can you provide more very detailed information so a good recommendation can be given? For openSUSE-11.1, you can do that, with your laptop connected to the internet, by opening a gnome-terminal or a kde konsole and twice copy and paste the following into that terminal/konsole


Run it the 1st time with root permissions. It will ask if you wish to do an update of the script. Select YES.

Then run it again (as either a regular user or as root). This time it will diagnose your PC’s hardware and software configuration for audio, and it will post its output on the Internet/web. It will give you the URL of the web site. Please post that URL here. JUST the URL.

Also, please copy and paste the following commands one line at a time into a gnome-terminal or a konsole and post here the output: rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a
cat /etc/modprobe.d/sound… with that information I may be able to make a recommendation.

Also, do NOT waste too much time on this. Simply post on our forum if you get stumped, and continue to look for help that way.

I’ll be off vacation in a few days.

All the information as requested:

/usr/sbin/ output:

rpm -qa | grep alsa:

rpm -qa | grep pulse

rpm -q libasound2

uname -a
Linux linux-xmbu #1 SMP 2008-12-04 18:10:04 +0100 x86_64 x86_64 x86_64 GNU/Linux

cat /etc/modprobe.d/sound:
options snd slots=snd-hda-intel
options model=3stack-dig enable=1 index=0

u1Nb.7ZjyjPlwJnC:82801G (ICH7 Family) High Definition Audio Controller

alias snd-card-0 snd-hda-intel


I note a 64-bit openSUSE-11.1 with the kernel (ie it has not been updated yet to on an HP dx2280 MT(RA529AV) with an ALC883 hardware audio codec and a mix of 1.0.18 and 1.0.21 of alsa audio driver.

Your /etc/modprobe.d/sound file suggests you tried to apply the model option 3stack-dig but there is no indication in the diagnostic script that has been applied. Was there a particular reason why you elected to use the option “3stack-dig” ??

I note from the HD-Audio-Models.txt file for alsa the following list of model options for the ALC883 (of which only one option can be applied at a time):

  3stack-dig	3-jack with SPDIF I/O
  6stack-dig	6-jack digital with SPDIF I/O
  3stack-6ch    3-jack 6-channel
  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
  6stack-dig-demo  6-jack digital for Intel demo board
  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
  acer-aspire	Acer Aspire 9810
  acer-aspire-4930g Acer Aspire 4930G
  medion	Medion Laptops
  medion-md2	Medion MD2
  targa-dig	Targa/MSI
  targa-2ch-dig	Targs/MSI with 2-channel
  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
  lenovo-101e	Lenovo 101E
  lenovo-nb0763	Lenovo NB0763
  lenovo-ms7195-dig Lenovo MS7195
  lenovo-sky	Lenovo Sky
  haier-w66	Haier W66
  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
  6stack-dell	Dell machines with 6stack (Inspiron 530)
  mitac		Mitac 8252D
  clevo-m720	Clevo M720 laptop series
  fujitsu-pi2515 Fujitsu AMILO Pi2515
  fujitsu-xa3530 Fujitsu AMILO XA3530
  3stack-6ch-intel Intel DG33* boards
  auto		auto-config reading BIOS (default)

But before we go into that list, I note in your installed rpms you updated the alsa user space to 1.0.21, but you did not try the daily snapshots.

I recommend you remove your PCs /etc/modprobe.d/sound file (do NOT put a backup in the /etc/modprobe.d/ directory, as ALL files are in that directory are loaded, even if labelled something different) and then run with root permissions “alsaconf”. That will recreate the file. Then test your sound.

If that does not work, update to the daily alsa snapshots by sending the following six commands with root permissions with your PC connected to the internet (one at a time in sequence):

zypper ar multimedia
zypper install alsa alsa-utils alsa-tools alsa-firmware alsa-oss alsa-plugins alsa-plugins-pulse libasound2
zypper rr multimedia
zypper ar multimedia
zypper install alsa-driver-kmp-default
zypper rr multimedia

If you are told the app is already installed, carry on anyway (don’t stop). Then restart your PC and test the sound.

Reference for applying daily snapshots: Alsa-update-snapshot - openSUSE

If that does not still work, we can then look at applying the model options again, using the list I provided (I can walk you through the edits to the /etc/modprobe.d/sound file, where the model option should be in the 1st line).

Wow, just checked my /etc/modules.d directory and it has a file named “sound” and another named “sound.Yast2save”. Both have exactly the same contents.

As this backup is generated by Yast, is there a problem with it staying there? Do you think it may cause a problem?


Not if they are exactly the same.

they’re equal just because I didn’t change anything in Yast, I was just exploring the options. But it may cause problems, as the backup will usually have different previous options. Or is it just a safety backup, identical to the current config? Have to test it sometime.

I’ll keep this in mind, thank you.

Hi oldcpu,

I performed all the steps you suggested in your last post, but sadly no sound was heard.

What’s next to be done? All my channels are at max volume and I can hear my PC Speaker(beep) perfectly.

My /etc/modprobe.d/sound* files look like these:

cat /etc/modprobe.d/sound.YaST2save
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

cat /etc/modprobe.d/sound
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel

Best Regards,
Satan Lair

When testing for sound, please use the 3 different methods for testing for sound from the openSUSE audio troubleshooting guide, step-3: SDB:AudioTroubleshooting - openSUSE [ie the same as noted in post#4 above]. If any one of them give sound, then your sound functions. Ensure you move up both PCM and Master volume (and speaker volume if there is such a control). You can do this in your mixer. Test this as a regular user, with speakers and headphones. Also test with regular user permissions, and open a terminal and test with root permissions.

I would also like to do a quality check on the software you installed. Please provide the output of:
rpm -qa | grep alsa
rpm -qa | grep pulse
rpm -q libasound2
uname -a

Also provide output URL of running


Select Edit model

add ref

select ok

follow it though and reboot your sound.

Close Yast, restart kmix or what ever it is in Gnome.

open kmix or … un-mute and turn the volume up on everything, in my case I chose ‘right’.

Close mixer, make sure volume is at a reasonable level.

Reboot your puter. after you login, you should be hearing the startup file play.


China_Jobs, welcome to openSUSE forums.

I note you replied to a number of sound support threads, and in every case recommended the application of the model “ref”.

In fact, that model option does NOT work in most cases. If one looks at the 1.0.18 version of alsa-configuration.txt file, and does a search for ref, one will find that option “might” only work for the following options …

STAC9200, STAC9205/9254, STAC9220/9221, STAC9202/9250/9251, STAC9227/9228/9229/927x, STAC92HD71B*, STAC92HD73*

In the case of user satanlair911 the hardware audio codec on their PC is an ALC883 and not a “stacxxxx”. Hence I believe ref would likely break their sound, as opposed to fix it. One needs to be very precise on the model options that are applied, and they must be selected from the alsa-configuration.txt or hd-audio-models.txt file that is documented by the alsa packagers.

We can use all the help we can get in the forums, so if you get the chance you could read the following files (comes with the documentation in every alsa tarball):

  • alsa-configuration.txt
  • hd-audio-models.txt
  • hd-audio.txt

and that should shed some light on this, and the various aspects associated with troubleshooting Linux sound.

Did you ever find a solution? I am having the same issue on SLED 11. I fixed it back in March by updating to alsa 1.0.19, but I just rebuilt my system and cant find that build anymore.

I updated to alsa 1.0.21 but I seem to have to restart alsasound after rebooting in order to get sound to work.

What is interesting is some sound works before restarting. System sounds do not, youtube doesn’t, but mplayer does, and the yast test sound does.

IMHO this is a symptom that some device has seized the audio device and has not let go of it. And thus the only applications that will play audio are those who have an output audio model selected that allows sharing of audio.

In the past only the alsa api would allow sharing of one audio device between multiple applications. Recently pulse audio is supposed to allow this, but it is still buggy in its implementation. Note just because you have alsa installed, does not mean an application will use the alsa api (in addition to using the alsa underlying driver). Some openSUSE sound concepts: Sound-concepts - openSUSE

The openSUSE audio troubleshooting guide has some parts that might be applicable to SLED. For example, take a look this section which provides advice on determining which application is using the sound device: SDB:AudioTroubleshooting - openSUSE

Run the code (in a terminal) to characterize your sound application use:

lsof /dev/dsp* /dev/audio* /dev/mixer* /dev/snd/*

ie run it when your sound works well, … copy the output and save it to a text file, and keep that file. Then next time you reboot (or on another occasion) when you have a problem, run that code again. Copy the output and save it to a text file. Then compare the files. Are they different? If different, they might point to an application that is badly behaved and is not letting go of your PCs sound device when the application is closed.

The following works in 11.2 (and maybe earlier versions as well)

Open YAST Sound
Select and Edit the 82801G card
Use the Advanced option
Set position_fix to 1
Set model to 3stack

That’s it!!
Music at last!

Congratulations. I take it then you solved your segfault problem ? Sudo segfaults on clean install of 11.2 - openSUSE Forums

It should not have been ncessary to set position_fix=1 nor model=3stack.

Reference your sound fix, can you write a bug report on this, noting your fix? Guidance on how to raise bug reports here: Submitting Bug Reports - openSUSE please
Please be certain to raise the report against openSUSE-11.2 component “sound”. This will get the attention of the SuSE-GmbH packager for sound, who is also an alsa developer. They will hopefully be able to fix the alsa driver auto probe, and they then send the fix upstream, such that all Linux distributions can benefit from your fix.

I’ll submit the sound fix - thanks for the suggestion
Unfortunately the sudo problem persists, but it doesn’t affect anything other than sudo on the command line so I can run all the desktop configs fine. Sudo works fine on my laptop anyway (prompt for root password) - it is just the desktop machine that prompts for pam_mount password and segfaults.