Intel Azalia audio (Realtek ALC888B), Cant get 5.1 audio to work

Installed 11.4 KDE on a desktop, managed to get everything working (except the paperweight lexmark printer hehe). But for the life of me, i just cant get 5.1 audio working. At first only one speaker worked, and after i disabled Pulse audio, the sound is fine, but only normal stereo (2 channels), not 5.1.
The PC has audio built into the motherboard, Intel Azalia High Definition audio (Realtek ALC888B chip).

Under windows, the driver included a nice application to configure the audio outputs, and to use 5+1 speakers you had to reasign the rear line in and mic jacks to be the outputs for rear satellites and center/woofer channels. But the motherboard manufacturer (gigabyte) does not provide a similar application for linux. And i have been searching and messing arround with settings for hours now, but i just cant get it to work :frowning:
I tried “Disabling Pulse Audio” option in Yast->Sound, installed every alsa related package i could find (including alsa mixer), but no luck.
Any sugestions of what i can do? is there a linux application to do “advanced” configuration of the audio devices (like the windows one that came with the MB)?

I managed to convince the owner to try out linux instead of windows 7, but he spent big bucks on his 5.1 speakers, and i dont think he will “settle” for stereo sound just to use linux. hehe

Any help would be appreciated.

Holly Cr@p! i finally got it working! :slight_smile:
for others that might have the same problem…

1.- Download the realtek driver source code here: Realtek
2.- Download the neccesary stuff to compile modules (make, patch, gcc, kernel-devel, etc)
3.- Follow the instructions in the readme.txt inside the tar you downloaded (dont worry its just a ./install command)
4.- Go to Yast, and MAKE 1000% SHURE PULSEAUDIO IS DISABLED, and reboot your pc
5.- just open kmix->configure channels, and viola! you should have sliders for front, surround, center, etc.

The catch here is to make shure you disable pulse audio, otherwise it wont work even after compiling and installing the driver.
On a side note, i am a newby, but i just cant understand, what the heck is pulse audio anyway? from what ibe read, it causes nothing but grief, and alsa works perfectly!
Am i missing something? does pulseaudio add extra funcionality? i just dont get it.

Here is one description of pulse:

PulseAudio - Wikipedia, the free encyclopedia

It seems that our developers are set on using/switching to it. The way I look at it is instead of working like a standard mixer, think Windows XP audio mixer, it is working from the application side, more like the Windows 7 audio control, to permit multiple applications to work at the same time with a selected output. Most likely you did not know about the **PulseAudio Volume Control **(pavucontrol) where you could have selected the output device. It is OK to use what works like switching to Alsa, but you will be swimming upstream in the future, if you can’t figure out how to work with PulsAudio in my opinion.

Thank You,

Thank you for your reply.
From what i read in the link you gave me, PulseAudio is an aditional layer that sits on top of, and uses ALSA. Correct?

About the PulseAudio Volume Control (pavucontrol) you mentioned, the wikipedia link mentions this…

Starting with version 4.5 (and further enhanced in 4.6) PulseAudio is also integrated into KDE primarily by PulseAudio contributor Colin Guthrie, adding support to Phonon (the KDE multimedia framework) and KMix (the integrated mixer application) as well as writing a new “Speaker Setup” GUI to aid the configuration of multi-channel speakers.

Is this the one you ment?
In any case, if the one you ment is in the kde main menu, i must have tried it (i tried every mixer, volume control gadget there).
For some reason i never got the option to add the aditional channels (surround, center, etc) in Kmix, even after installing the driver/codec from the realtek page. Then i disabled pulse audio, rebooted, opened Kmix options again, and the channels where there to add.
I dunno, maybe the driver i installed doesnt support pulseaudio?

I wish i still had that PC to do some more testing/learning, and to try to find the PulseAudio Volume Control (pavucontrol) you mentioned, but that PC is gone now. Its owner picked it up yesterday :frowning:

I too have 5.1 speakers on my main working PC, and my MB has the same chip, but as much as i would like to, i just cant make the full switch to linux on that PC. Because apart from tech support, i am also a developer, i develop business applications for small/medium companies, and i do that in C# with visual studio and .net platform. (a #ell of a lot faster that using straight C++ and a GUI kit like wxWidgets like i did before! haha).
Thanks again for your reply and info :slight_smile:

Intrigued by this issue, i decided to investigate and test some more, so i booted my PC (same audio chip, 5.1 speakers) with a linuxmint 11 live CD i have, and went to do some testing…

by default, i had stereo audio on my front speakers, then i opened synaptics and installed the PulseAudio Volume Control (pavucontrol) package.
I opened it from the multimedia menu, and it only has sliders for “left right” channels. after exploring every option in it, i found no feature to add aditional channels.
Then i went back to synaptics, this time i installed Gnome alsa mixer package, and opened it from the same multimedia menu…

http://img30.imageshack.us/img30/9324/audiowd.jpg](http://imageshack.us/photo/my-images/30/audiowd.jpg/)

Uploaded with ImageShack.us
Here are both volume controls on screen. Alsa mixer on top, pavucontrol on bottom.
As you can see, in Alsa mixer my card is properly detected, and i automatically got controls for front, surround, center and woofer channels. I dint even have to mess arround with its settings, nor download compile and install the realtek driver!
It just works “out of the box”.
pavucontrol on the other hand, only offers controls for 2 channels.

So im guessing in the original case with the other pc, it would have made no diference to try pavucontrol either (maybe i did, tried so many that i cant remember).
It seems to me that the problem is Pulse Audio.
Is this a bug in pulse audio, or just lack of functionality?

You need to go to the configuration tab where you select your output configuration. Consider that normally most all sources are in stereo and not 5.1 format. My receiver is set to multi-stereo mode which just makes all left speakers left channel and all right speakers right channel. When playing a DVD, I am using Kaffeine/KDE3, designed to use xine where I can set it to work as 5.1 Dolby digital spdiff passthrough which is the only time I get real 5.1 audio. So, when you say a 5.1 setup, who is doing what? Now with the Realtek driver loaded, which may only work with Alsa, it may be doing what my receiver can do with a stereo source, but Pulse per say is not stopping 5.1 Dolby Digital passthrough from getting out to my speakers when it is needed. Further, it is OK to take the steps that you did. If it works it works, nothing else to do.

Thank You,

If i understand you correctly, you mean that i dont get 5.1 audio in pulseaudio because the source is in stereo only?
But even if the source had 6 channel audio, how would i configure the channels, if there are no sliders anywhere for center, surround, etc?

Anyway, Did another test, booted the mint11 live cd, and followed the steps here:
Linux surround sound with PulseAudio (mini-HOWTO)
Worked like a charm! :slight_smile:
I got 5.1 audio with pulseaudio. The aditional sliders for woofer, surround, etc. finally appeared in the pulse audio volume control app.
Tested it with a 5.1 audio test video, and worked perfectly. Also tested it with a stereo .mp3 file, and still got audio from all of the 6 channels.

My Conclusions…
1.- It is my opinion that this whole issue, and how to fix it (as described in the above link) should be properly documented. One shouldnt have to google for an hour just to get something this basic working.

2.- the developers of pulseaudio, should address this issue. And make proper corrections, like adding the functionality to do what the above link tells us to do, from inside the volume control application.
This is no “small issue”, for example: when working on my customers PC (when i started this thread), and after hours of scratching my head, i was about 5 minutes away from telling my customer “sorry, but i will install W7, because it seems your sound card is not compatible with linux”. And its my job! im betting 90% of normal, home users would have quit after the first hour.

3.- I wish i had found that link earlier! it would have saved me hours of scratching my head! :slight_smile:

NE way, the above solution (in the link) seems to work perfectly, i hope it spares someone hours of intensive-head-scratching! hehe

EDIT: i think ill make a small how to and submit it to the howto section, but first ill verify that the solution works as well on opensuse, because testing was done with mint. I see no reason why it shouldnt work with suse, but just to make shure.

I have a 5.1 surround sound system.

I am an openSUSE-11.3 user, as I have not yet migrated to openSUSE-11.4. Note openSUSE-11.3 does not have pulse enabled by default in KDE and I have not enabled pulse on my openSUSE-11.3.

Having stated that (not having migrated to openSUSE-11.4) I do have openSUSE-11.4 running in a test partition on my PC with the surround sound system and with pulse audio. I have also installed the application pulse audio volume control (pavucontrol) and surround sound with proper selection in pavucontrol, just worked.

So I confess I simply scratched my head over this thread.

Now its a bit of a pain for me to reboot to 11.4 just to offer support (I’m a non-paid volunteer enthusiast and I have my own hobbies, typically with a lot of encoding running in the background in my PC with the surround sound system and any reboot is a MASSIVE disruption to my ongoing hobby/work).

Anyway, one thing I have learned over the many years that I have been a moderator on this forum, is while things often just work for me, they often do not just work for others, and I probably do things for tuning that are obvious and easy for me and not obvious nor easy for others. So perhaps if you have this working, and since you found it difficult and needing non-obvious steps, you could write the guide that you feel is needed, as I think I am not a good person to write such a 5.1 pulse audio guide ? I simply works for me. No special steps needed.

I definitely did NOT need to follow the link you provided (for pulse) although MANY thanks for posting that link. It was … interesting.

Thanks and best wishes.

pavucontrol is NOT installed by default in openSUSE-11.4. Instead one must make an extra point out of installing pavucontrol themselves.

Fortunately pavucontrol is in the OSS repository and one can find it easily in YaST > Software > Software managment for installation, or one can simply type with root permissions (when connected to the internet) :


zypper in pavucontrol

and then pavucontrol needs to be run the 1st time one runs any multimedia (with audio) application and then pulse audio can be tuned on an application by application basis. Once one has tuned pulse audio for a given appliciiton, it need not be run again for that application as pulse is ‘supposed’ to store the settings.

Here is a typical screen shot of pavucontrol:


Configuration is where one MUST select their 5.1 system.

The above is NOT set for a 5.1 system and I am NOT on a GNU/Linux PC right now and I can not in the time I have currently, provide anything more explicit.

Note under output-devices it is important that one have the SHOW filter set to show ‘all devices’ . In playback I also find it important to have the SHOW filter set to show ‘all streams’.

Edit - I am a KDE user, but I note in one of your Gnome screen shots you illustrate something that looks like pavucontrol. You do not show the ‘configuration’ tab and it is in there that the setting is very important for a 5.1 system. If you do not have the 5.1 system configuration selected then you will not get the appropriate 5.1 controls elsewhere.

I note some Ubuntu users (who are Gnome users) have reported a bug with pulse wrt surround sound … Bug #519374 “pavucontrol missing pulseaudio “Digital Surround” o...” : Bugs : pavucontrol package : Ubuntu but I don’t have time to pursue this. There is a possibility that some hardware has a problem with pulse audio and surround sound. Given it worked for me, I have a suspicion that any problems may be on a hardware specific basis.

This is what I see with pavucontrol running on my 64-bit openSUSE-11.4 test partition:

Configuration tab:
http://thumbnails11.imagebam.com/14068/1d5eb0140676246.jpg](ImageBam)

Playback tab:
http://thumbnails52.imagebam.com/14068/a87af4140676249.jpg](ImageBam)

I found an extra hard drive i had in a drawer, pluged it into my pc (as mentioned before, it has the same audio chip and 5.1 speakers), and installed opensuse 11.4, then ran zypper update.
Here is what my pavucontrol looks like. I opened 2 instances of it so you can see both the configuration and output tabs…

http://img546.imageshack.us/img546/3794/pantallazop.jpg](http://img546.imageshack.us/i/pantallazop.jpg/)

Uploaded with ImageShack.us

As you can see, there is** no** 5.1 output channels, and if i click on the “Profile” list on the configuration panel, the only options i get are:

  • stereo analog output
  • stereo analog input
  • off.
    I wanted to show you the available options on the list in the screen capture, but for some reason the “print screen” key does not take snapshots when the list is displayed.

EDIT: I forgot to mention…
in my opensuse 11.4 Gnome installation, pavucontrol was installed by default

Well, I’m not a Gnome user, but I would be, … well, ok, I would be VERY SURPRISED if that was true. Apologies. … IMHO you do not understand all the features of the Gnome print screen. And if it can not be done with the Gnome print screen (for some bizarre Gnome design reason) it IS possible with the application Gimp.

What you encountered is very common in GNU/Linux where just pressing ‘print screen’ may not work. The simple solution there is to NOT select the area you want to print (and do not have the app configured ‘yet’ for the print screen) but rather press print screen else where. LEAVE the print screen application running and set it up to capture a print screen in , say , 10 seconds.

THEN in pavucontrol press appropriate menu in pavucontrol and wait the 10 sec (or whatever chosen) for the screen capture. Its too simple. This works in KDE. This works in LXDE. I would be very suprised if it does not work in Gnome. Its very simple to do.

Here is from one of my PCs (this was on a KDE desktop)
http://thumbnails21.imagebam.com/14078/8cf0fd140776833.jpg](ImageBam)

When I see a difficulty with a user doing such a basic print screen/capture, I can’t help but wonder about the rest … apologies.

Maybe you can tell me more about your basic audio config ? With PC connected to the Internet, run the diagnostic script:


/usr/sbin/alsa-info.sh

and select the share/upload option and post here the URL provided. I want to see if possibly it is ALSA that is misconfigured and NOT PULSE.

I’m not a Gnome user. I am a KDE4 user. I am also an LXDE user. In both those cases pavucontrol needs to be installed separately.

On a completely different PC, where nothing special was done OTHER than have to install pavucontrol (because this is an LXDE desktop on openSUSE-11.4), here is the screen capture:

http://thumbnails45.imagebam.com/14078/21b035140778378.jpg](ImageBam)

I concede being LXDE which is a more basic desktop than KDE4 or Gnome, it was a bit trickier in finding the delay control for the print screen. But it is standard on all GNU/Linux screen print applications to have a delay feature. Definitely Gimp has this capability and even though I am not a Gnome user, I do know Gimp runs in Gnome.

This being the same audio chip makes me even more suspicious of an alsa misconfiguration and NOT pulse audio (or if it is pulse audio, it may be specific to your hardware).

Please if you can, post the output URL/website address provided at script execution end when you run the diagnostic script (selecting the SHARE/UPLOAD option) with PC connected to Internet:


/usr/sbin/alsa-info.sh

Further to my post, if one looks under /usr/src/linux-2.6.34.8-0.2/Documentation/sound/alsa (substitute one’s kernel in the place of linux-2.6.34.8-0.2) one will find a directory full of documentation on the alsa sound driver. In that directory, for example, is the file "HD-Audio-Models.txt file. In that file is a series of configurations that can be forced for an ALC888 (which I assume may be the same for an ALC888B) in case alsa is not configured properly upon boot:


ALC882/883/885/888/889
======================
  3stack-dig	3-jack with SPDIF I/O
  6stack-dig	6-jack digital with SPDIF I/O
  arima		Arima W820Di1
  targa		Targa T8, MSI-1049 T8
  asus-a7j	ASUS A7J
  asus-a7m	ASUS A7M
  macpro	MacPro support
  mb5		Macbook 5,1
  macmini3	Macmini 3,1
  mba21		Macbook Air 2,1
  mbp3		Macbook Pro rev3
  imac24	iMac 24'' with jack detection
  imac91	iMac 9,1
  w2jc		ASUS W2JC
  3stack-2ch-dig	3-jack with SPDIF I/O (ALC883)
  alc883-6stack-dig	6-jack digital with SPDIF I/O (ALC883)
  3stack-6ch    3-jack 6-channel
  3stack-6ch-dig 3-jack 6-channel with SPDIF I/O
  6stack-dig-demo  6-jack digital for Intel demo board
  acer		Acer laptops (Travelmate 3012WTMi, Aspire 5600, etc)
  acer-aspire	Acer Aspire 9810
  acer-aspire-4930g Acer Aspire 4930G
  acer-aspire-6530g Acer Aspire 6530G
  acer-aspire-7730g Acer Aspire 7730G
  acer-aspire-8930g Acer Aspire 8930G
  medion	Medion Laptops
  targa-dig	Targa/MSI
  targa-2ch-dig	Targa/MSI with 2-channel
  targa-8ch-dig Targa/MSI with 8-channel (MSI GX620)
  laptop-eapd   3-jack with SPDIF I/O and EAPD (Clevo M540JE, M550JE)
  lenovo-101e	Lenovo 101E
  lenovo-nb0763	Lenovo NB0763
  lenovo-ms7195-dig Lenovo MS7195
  lenovo-sky	Lenovo Sky
  haier-w66	Haier W66
  3stack-hp	HP machines with 3stack (Lucknow, Samba boards)
  6stack-dell	Dell machines with 6stack (Inspiron 530)
  mitac		Mitac 8252D
  clevo-m540r	Clevo M540R (6ch + digital)
  clevo-m720	Clevo M720 laptop series
  fujitsu-pi2515 Fujitsu AMILO Pi2515
  fujitsu-xa3530 Fujitsu AMILO XA3530
  3stack-6ch-intel Intel DG33* boards
  intel-alc889a	Intel IbexPeak with ALC889A
  intel-x58	Intel DX58 with ALC889
  asus-p5q	ASUS P5Q-EM boards
  mb31		MacBook 3,1
  sony-vaio-tt  Sony VAIO TT
  auto		auto-config reading BIOS (default)

The ‘trick’ here is to know what configuration file to edit, what syntax to apply, and what option to apply (as one can ONLY apply one at a time, and then restart alsa). Clearly that is NOT trivial, but it is a way to configure alsa for an ALC888 if it is not configured properly upon boot.

I’m hoping we may learn something from the diagnostic script.

Also, could you provide the output of:


cat /etc/modprobe.d/50-sound.conf

as that is the configuration file that will need to be edited if you do elect to try and better tune alsa for surround sound. Clearly, whether successful or not, we are into openSUSE bug reporting territory as this should ‘just work’ (like it does for me) and it does NOT ‘just work’ for you. Ergo - there is a bug (or a missing feature).

Fortunately the sound packager for openSUSE is also an alsa sound driver developer, so bugs written on openSUSE sound have a better chance of being addressed than those written on some other distributions.

oldcpu, you are talking to yourself again. It can be troubling when it happens more than three times in a row. lol!

Thank You,

Hi!, thank you for all your help and advice, sorry i took so long to reply. It was my birthday yesterday and shortly after my last reply i went out for a few drinks with some friends, and when i returned… well, lets just say i was in no condition to do linux troubleshooting stuff rotfl!

About the screen capture issue, thanks for the tip. Im actually quite embarrassed, that after using linux for so long (at a superficial level at least), i dint know how to properly use such a basic feature. Now that i know how, Here is the proper screenshot of my pavucontrol…
ImageShack - Best place for all of your image hosting and image sharing needs](ImageShack - Best place for all of your image hosting and image sharing needs)

Uploaded with ImageShack.us
As you can see, no option for 5.1 (yet).

I also opened a terminal and ran alsamixer, i was suprised here, because on my previous testing i did on linux Mint 11, there was an option to select 2 or 6 channel output, and now on my suse installation there was no such option…
ImageShack - Best place for all of your image hosting and image sharing needs](http://img838.imageshack.us/i/alsamixer.png/)

Uploaded with ImageShack.us

Upon doing some more research, (and following your advice) i think i finally found the problem. And even though i am by no means a linux expert, i do think this is a bug in opensuse, and that yast is not detecting and configuring my card properly. (see below)

But first, here is the information about my setup (without doing any tweaking or modifications. Just “out of the box”)…

output of the alsa-info.sh script is here
http://www.alsa-project.org/db/?f=b1198a4432e885148565718bb852d2c8c5bd789e

output of cat /etc/modprobe.d/50-sound.conf

options snd slots=snd-hda-intel,snd-hda-intel

u1Nb.kFNviVz3E80:5 Series/3400 Series Chipset High Definition Audio

alias snd-card-0 snd-hda-intel

NXNs.5nzgvdJ9iO5:nVidia Corporation

alias snd-card-1 snd-hda-intel

The Problem
Now, i visited these links and read so i could learn more about alsa…
Help To Debug Intel HDA - AlsaProject
and
git.alsa-project.org Git - alsa-kernel.git/blob - Documentation/sound/alsa/HD-Audio-Models.txt

After that, i went to yast->audio, selected the audio card, and clicked on “Edit” to see its properties. Here is the screen…
http://img195.imageshack.us/img195/3443/yastsnd.png](http://img195.imageshack.us/i/yastsnd.png/)

Uploaded with ImageShack.us

I noticed that the highligted item “Use the given board model” is set to empty, wich dint make much sense to me. So, using the second link i visited and the info you provided on a previous reply, i changed that value to something that made more sense to me.
First i tried “auto”, but it dint work (everything was the same).
Then i tried 3stack-6ch and after a reboot…

pavucontrol still had no option for 6 channel, however, i opened a terminal and alsamixer again, and this time…
http://img232.imageshack.us/img232/455/alsamixer2.png](http://img232.imageshack.us/i/alsamixer2.png/)

Uploaded with ImageShack.us

Notice the last control on the right. Now i do have an option to select 2 or 6 channel output (like i had on LinuxMint11). And After setting that to 6ch (instead of 2ch as it is by default), and rebooting the PC, here is pavucontrol again…
http://img9.imageshack.us/img9/1779/pavc2.png](http://img9.imageshack.us/i/pavc2.png/)

Uploaded with ImageShack.us

http://img841.imageshack.us/img841/4489/pavc3.png](http://img841.imageshack.us/i/pavc3.png/)

Uploaded with ImageShack.us

Now thats more like it!

However, it still doesnt work 100%. The subwoofer slider doesnt do anything, and overall sound is not 100% normal. Its like a little “muffled”.
My guess is that 3stack-6ch is not the correct value i should put it yast->audio->card properties.

Can you sugest a proper value to put instead of 3stack-6ch? maybe i also need to edit other options in the same yast dialog?

and more importantly, am i correct to assume that this is a bug, and that opensuse is not properly detecting the card? if so, and theres anything else i can do to help solve this issue (you need more information, need me to do some tests, etc), please let me know and ill be happy to help anyway i can.
Thanks again.