Intel 6235 - firmware load failed with error -2

This occurs on an HP Spectre XT laptop. Leap 42.1 installs and wifi works perfectly. Have tried booting from Tumbleweed Live cd and also tried using the Update function from the Tumbleweed dvd.

Live cd boot:

  • dmesg:
    linux@nohostname:~> dmesg | grep iwlwifi
    5.645395] iwlwifi 0000:02:00.0: can’t disable ASPM; OS doesn’t have ASPM control
    5.648824] iwlwifi 0000:02:00.0: Direct firmware load for iwlwifi-6000g2b-6.ucode failed with error -2
    5.648831] iwlwifi 0000:02:00.0: no suitable firmware found!

  • firmware file present in /lib/firmware:
    linux@nohostname:~> ll /lib/firmware/iwlwifi-6000g2b-6.ucode
    -rw-r–r-- 1 root root 679436 Sep 13 16:14 /lib/firmware/iwlwifi-6000g2b-6.ucode

  • lspci -k:
    02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6235 (rev 24)
    Subsystem: Intel Corporation Centrino Advanced-N 6235 AGN
    Kernel modules: iwlwifi

  • lspci -n snippet:

02:00.0 0280: 8086:088e (rev 24)

Update function from dvd:

  • installer doesn’t show the Intel 6235 adapter as a choice.

As I said, Leap 42.1 installs fine and the adapter works okay with it. Would like to use the Update function on a wire and then correct the problem with the Intel adapter if possible.

Thanks in advance for any information.


Make sure you’re running the latest TW, if necessary run the following to update

zypper dup

You should always post information about which TW your’e running, the following displays your release and more

cat /etc/os-release

Particularly for any Intel hardware,
It’s unlikely that any better alternatives exist to what is distributed through the mainline kernel,
So if you have any problems you should create a bug report (be sure to include the above info as well)

If you post all that information here, you can probably just post a link to this Forum thread in your bug report, but be sure to add at least a summary or top level description of your issue.


Point made. I was trying with the most recent (as of yesterday) Tumbleweed Live and DVD images available on the download site.

Live CD /etc/osrelease:

NAME=“openSUSE Tumbleweed”


PRETTY_NAME=“openSUSE Tumbleweed”

Does it work, if you unload the driver (sudo rmmod iwlwifi) [FONT=courier new]and load it again (sudo modprobe [FONT=courier new]iwlwifi)?
([FONT=courier new]if “[FONT=courier new]iwlwifi” is the name of the module)



That took care of it. Common sense, right? My inexperience is showing.

I remember reading a post somewhere that the firmware load was being attempted prior to the device becoming available but didn’t make the connection.

Many thanks for the assist.

A footnote: Use the Tumbleweed dvd to do an upgrade while on the wire (couldn’t figure out how to exit installer to reload iwlwifi firmware). After upgrade completed, and restarted, the iwlwifi driver was loaded automatically and is working fine.

This was interesting.

For what it’s worth having the same issues with a Lenovo X1 and an Intel 8260. Booting the live cd, I can remove and reload the iwlwifi firmware and then it works. During the tumbleweed dvd install, it’s not seen so I have to use the same install-on-the-wire tecnique.

I have the same problem using a live usb of the latest tumbleweed in a HP zbook Studio G3 and . Unloading the driver (sudo rmmod iwlwifi) [FONT=courier new]and loading it again (sudo modprobe [FONT=courier new]iwlwifi)[/FONT][/FONT], turns on the wireless and works perfectly. I have not tried from an install on disk.

I also have this with live usb. Does anyone know if there is a more convenient solution (configuration), or has anyone filed a bug report?

i believe this bug is now solved with: