Intel 5300 disconnect problems after upgrading 11.3

I’m inclined to agree with this. I was experiencing the network dropouts and slow throughput with an Atheros card too before trying the Intel 5100 card. The Intel is slightly better but not perfect and the symptoms are remarkably similar for both cards which makes me think it may be something to do with oS11.3 or the hardware. I haven’t tried these cards in oS11.2 but may do so this weekend just to prove or disprove the point.

What is your signal strength like? I’ve noticed that the card or the Intel driver seems to be very sensitive to signal strength. I’ve noticed anything below 60% causes the card to drop the connection and slow throughput considerably more than if the signal is above 60%.

There was a new kernel released today. Have you tried it?

nobled/suse_tpx60s, further to this querry, did you try having a terminal open, constantly pinging your wireless router? Does that enable the wireless connection to be maintained without the disconnect problems you report?

I still have not been able to reproduce this disconnect problem on my Intel 5300AGN. I did apply the 11.3 libiw30, wireless-tools, krb5 and krb5-32bit updates, and I have had my wireless running for 15-minutes. So far no disconnects. I may update to the latest kernel today.

After 20 minutes I did get a disconnect. I’m going to let this run for a few hours and see how many times (if at all) it happens again …

nobled/suse_tpx60s, did you try rolling back libiw30, wireless-tools, krb5 and krb5-32bit to see if that made a difference ?

Turns out what I saw was an application problem (ping and also dolphin), and I did not have a disconnect. I’m testing further, but thus far still not able to reproduce the reported disconnect problems. I’m leaning more and more to updating my kernel on this PC (with the Intel 5300 AGN wireless) to see if I get the same reported problem.

Edit - I just completed transfer over wireless of a 1.2 GByte file (with filezilla) at an average speed of 4.3MB/sec (sometimes speed is closer to 10MB/sec). No disconnects.

Ok, I now have the kernel-default of a 64-bit openSUSE-11.3 installed on my Dell Studio 1537 with the Intel 5300 AGN graphics and wireless is working. I have not observed yet any differences between this and the previous 2.6.34-12 kernel that I had installed. I do not have any noticeable disconnects.

Note I say noticeable disconnects. There is a known problem with the firmware of the Intel 5300 AGN (and likely also the 5100 AGN) that Intel are purportedly working on. I have not checked into this for over 6 months, so I do not know if there is a firmware update yet.

If one looks in one’s dmesg one will see a number of entries of something like this (for the 5300 AGN):

  834.189403] iwlagn 0000:04:00.0: Microcode SW error detected.  Restarting 0x2000000.

ie there was a disconnect followed by an immediate restart/connect. That disconnect/reconnect has been transparent to me, but perhaps others are finding this does not work as well for them ?

Having noted that firmware problem (which is being worked around in software in the kernel) the wireless is working for me.

Typical firmware error, happens from time to time but shouldn’t (and didn’t) affect the connection in a way noticable for the user, so nothing to worry here.


Maybe, but in contrast to all problems reported here, wireless cards from Intel work well under linux in most cases and using recent kernel drivers (>= 2.6.34) does not automatically mean “all hell breaks loose”.

I have a 5300 AGN here, running under 11.2 but using drivers from compat-wireless stable (= “drivers from 2.6.35”) and have no problems at all.

Ok I let this run for 7.5 hours on my Dell Studio 1537 with the Intel 5300 AGN wirless and the openSUSE-11.3 kernel. No wireless disconnects on this Dell Laptop’s implementation of the Intel 5300 AGN wireless. None.

I’m going to turn my laptop off now (as I need to clean up / go to bed, so to go to work tomorrow). Clearly I was not able to reproduce the problem reported in this thread.

OK, I have rolled back the ibiw30, wireless-tools, krb5 and krb5-32bit packages and will see how things go. After a cold boot I did get a disconnection about 20 seconds after KDE started and the wifi came up. Later today when I have more time I’ll reboot the system and note the logs to see what’s happening and compare to the previous logs.

My problem isn’t only the disconnects but the slow connection speeds once connected. With a signal strength of 67% I never see the connection above 11Mb/s. A lot of the time it connects at 2 to 5Mb/s. I’ve tried changing channels on the router which made no difference.

I’m considering trying oS11.2 on the PC just to compare how well the wifi works under 11.2. If it is better then the problem definitely points to oS11.3 or the more recent drivers.

@oldcpu, what is your signal strength on the laptop when you were doing your tests? I found that anything less than 60% would kill the speed down to 2Mb/s and the disconnects would become more frequent. I need to be virtually at >90% signal to get a 54Mb/s connection. Conversely my Thinkpad with the older Intel 3945abg card can connect at 54Mb/s at 45% signal strength.

I don’t recall the signal strength on my Dell’s 5300AGN being exceptionaly good. We live in a small apartment, and the router is in a closet in a central location. Unfortunately the walls are cement with a steel mesh inside. Ergo it likely interfers with transmission. My room (with my computers) is adjacent to the room with the router and it has an excellent connection. We have had difficulty in connecting from the kitchen ( ! ) which is the furthest room away, but I have not tried recently (my wife uses a laptop in the kitchen ! currently she uses our old Fujitsu-Siemens Amilo with the Intel 2100 wireless). We were able to connect with our Dell (5300AGN) outside on our apartment patio, but that connection was not good. But inside in my room (next room to router’s closet) connection is excellent.

What command/program do you use for your signal strength figures ?

2 to 5MB/s is what I get (I use “B” instead of “b” as that upper case “B” is what is on the GUI, but I am not certain the GUI is correct). I have seen as high as 10 to 11 MB/s. Needless to say, there is a big difference between “b” and “B”. :slight_smile:

I also found a significant difference in speed between applications. Dolphin in KDE gets pathetic transfer speed. However filezilla gets superb transfer speeds.

I’m definitely getting Mb/s (small b - mega bits not mega bytes). The figures of 2-5Mb/s I mentioned above are the connection speed, i.e.the speed that the card and router negotiated between them which is very low - it should really be 54Mb/s for the signal level (67%) I’m getting. It can take up to 40-50s to open this forum page, that’s how slow the connection is. It’s not the connection to the internet but purely the connection between this card and the router.

Your transfer speeds are about normal I believe. Can you say what speed your card is connected to your router at? What speed does iwconfig show and what signal level? Are you using Network Manager of just the plain traditional setting?

Reference connection speed, here is a Fedora thread with some ideas you may wish to experiment with: VERY slow speed - Intel 5300AGN - F12 -

Note I have not yet tried any of those ideas as I have not yet seen the need with my Dell Studio 1537 (with the 5300AGN). Note also, that I have ipv6 disabled from the initial openSUSE install.

Thanks. I’ll look at that thread. To answer your previous question, which missed - sorry.
I’m using wicd to manage my wifi connections. For the speed and signal I use iwconfig which gives the same results as what wicd displays.

I’ve now uninstalled wicd and am trying just the traditional setting from YAST Network devices. For some reason it takes about 7mins for it to actually connect after a reboot which is causing with the nfs drives mounting. The connection speed is still slow and I haven’t had a chance to monitor if there any drops yet.

On another note: When I switch to the console (Atl Ctrl F1), I can see the boot messages. The wifi related ones with wlan0 show failed. How can I see these in the logs? Is the info shown in the dmesg the same log?

EDIT: ipv6 has been disabled from the start.

7 minutes is too long. I typically see a connection with seconds after KDE4.4.4 booting on openSUSE-11.3. I note that for KDE-4.4.4 to get the knetworkmanager to work I had to create a new user account. My previous user from my openSUSE-11.2 install with KDE-4.3.5 (? - I’m unsure of exact version and I’m not at my pc) would not connect in openSUSE-11.3 … as there was likely something in the /home/user directory left from 11.2’s KDE that was corrupting knetworkmanger in 11.3 with same user (and same /home/user directory). But a new user had no problems with knetworkmanager in 11.3.

But 7 minutes? No way. I get a connection in seconds after KDE-4.4.4 boots. Something must (?) be setup wrong in your KDE (or Gnome) or your PC’s hardware implementation of the Intel 5300AGN is substandard. I’m no network nor wireless guru, so I unfortunately can not help here, but therre is NO WAY it should be 7 minutes.

I agree - it’s way too long. I’ve just downloaded a 11.2 KDE live cd to try and see if it’s better with the older kernel / drivers. Failing that I’ll reinstall oS11.3 and start with a clean account. I’ve read comments that this card works fine out of the box for Ubuntu users on my hardware so the hardware implementation should be fine.

Some progress and then back to where I was before.

I tried the 11.2 live CD but for some reason that would not boot properly on my pc. So I decided to go for a complete 11.3 re-install keeping my /home folder. After the install (with no updates applied yet) to my delight I found that after the reboot the network was coming up immediately. No network errors in the logs, no drops but still the connection speed was only 11Mb/s max. I tried a number of reboots and each time the network came up immediately and reliably. I was only using the traditional method with no wicd or networkmanager. I was thrilled and thought problem solved so proceeded to configure the nfs-client and switched KDE to 4.5.2. And that was it - BAM. Back to the network problems >:)

The network was associating and disassociating multiple times with reason 2, when it finally connected after 5+ minutes it only connects at 1Mb/s. I tried disabling the nfs service but it didn’t help. I am now back to square one.

I note that network-remotefs, nscd and postfix services are failing to start for some reason.

For nscd it says that no such file exists /var/run/nscd/socket. I checked and nscd is not installed but unscd is installed which is an alternative. I looked on my other PCs and they too only have unscd instead of nscd but they do have the /var/run/nscd/socket file. I wonder why one was not created for this install.

Why would upgrading to kde4.5 mess up the network? Nothing else has been upgraded yet. Perhaps enabling and configuring the nfs-client changed something?

Its a good question … you could raise this on the KDE mailing list. Also, could this be an NFS service problem, where once enabled, some configuration is left which causes the problem (even though it is disabled afterward)? I note my laptop with the 5300AGN does not use NFS and it is using only KDE-4.4.4.

Right. I decided to start again - Again. And this time try monitor more closely what’s happening.

Reinstalled oS11.3 keeping my home folder. After the install the network came up immediately and connected at 18Mb/s - a good result. But after subsequent reboots the network was not connecting at more than 1Mb/s. So it’s acting slightly differently to what I experienced with my previous re-install of oS11.3. I’ve not applied any updates at this point. Looking at the logs shows that the wlan0 was associating and de-associating with reason 2 and authenticating and de-authenticating with reason 3 repeatedly before making a stable connection.

After some major googling I found a reference that it’s a known problem with dhcp and network manager conflicting on some systems. The solution was to remove network manager and delete everything in the /etc/NetworkManager directory. After doing this my network has started behaving itself. I’ve upgraded to the latest kernel, applied the updates to KDE4.4.4 and applied all updates from the oS11.3 update repo and my wifi is still connecting immediately after reboot. I’m not seeing any of the association / de-association or authentication / de-authentication issues in the logs anymore. The wifi is connection at 11Mb/s and sometimes at 18Mb/s and I’ve not seen any drop outs in the last hour. The connection speed is still not as good as I get on my laptop with the older 3945abg card which connects at 54Mb/s but it’s still better than what I’ve got in the past with the 5100agn card.

So it appears that network manager was the cause of all my problems - at least it appears that way for now. Later I’m going to attempt to install wicd to manage the network connections and upgrade to KDE4.5.2.

I’ll let you know the result.

After deleting Network manager and its subsequent directory, did you then re-install network manager ? or is it still removed ?

Glad to read you are having some success.