intel 5300 chipset on suse 11.0

I have an intel 5300 wireless chipset which is not supported in kernel 2.6.25. I am currently using opensuse 11.0, I downgraded from 11.1 since I faced so many other problems.

can I setup my wireless driver under kernel 2.6.25? if so, how could i do this?

thanks in advance

No, my understanding is it needs the 2.6.27 kernel.

You could try to find a 2.6.27 kernel for your openSUSE-11.0, but you would likely have to :

  • custom build your graphic driver,
  • custom build your sound driver,
  • custom build your webcam driver,
  • custom build your wireless driver,
  • have other unexpected effects with the non-stock kernel that you would need to sort

I don’t know what your problems were with 11.1, but IMHO if you migrate to 11.0 and update the kernel (to 2.6.27) to get the wireless working under 11.0, you will face many more problems with 11.0 than you did with 11.1.

I’ll second that, it’s most likely far easier to resolve your 11.1 issues then to get a kernel supporting the 5300 into 11.0.

College of mine never got it working under 11.0 but it’s working fine under 11.1.

My Dell Studio 15 has an Intel 5300 AGN wireless chipset. I never tried to install it on openSUSE-11.0, but I did install it on openSUSE-11.1 starting with alpha5 (I think) and tracked 11.1 development since then, to ensure it would be supported in 11.1 GM.

I currently having openSUSE-11.1 (and the 2.6.27 kernel) running on my Dell Studio 15 with the Intel 5300 AGN wireless. The wireless works reasonably well, although its not perfect and there is IMHO room for improvement with the driver. I find its range is not what I had expected (given it is an AGN) and I also have to keep a konsole open, with a continual ping of my router, to avoid it pausing and dropping the connection. Since the other wireless devices in our house do not have this problem (an older intel and a dlink atheros) with our router, I assume this is a driver problem with the Intel 5300, where more improvement would still be useful to obtain the optimum performance.

I have the latest build of OpenSuse, and running on a Dell Latitude E4300, with this wireless card and I am not able to enable it.

Granted I am rather new to Linux, and don’t know where the “Device Manager” is, can you tell me where you would go to check out “unknown devices?” So I can try reinstalling the device driver?

Thanks!

What is the latest build of openSUSE ? That ‘term’ latest build has different meaning to different people.

What desktop are you using? KDE ? Gnome ? Xfce ? Lxde ? other ?

The driver for this wireless should be included in openSUSE-11.3 and there should be no need to install any new driver.

Hello,

You have a VERY good point… I should have been more specific.

The build is 11.3 64bit. I run gnome, and have updated the system.

I have read a few places that say that the drivers are included, but I don’t know of a way to tell if the device is being loaded or with the proper driver.

In the networking, I have the ability to set the SSID and encryption key, but it doesn’t say if there is a card that is recognized.

Additionally, in the past I have used ubuntu 10.4 and the drivers did install… yet when I used ubuntu 10.10… the drivers weren’t automatically loaded.

I thought maybe I fried the card or something, but I reloaded ubuntu 10.4, and it worked again. So, I know it is the load.

Any thoughts? Also, thanks in advance!

The drivers for the Intel 5300AGN wireless come with the kernel and the other required packages are included as a nominal openSUSE install. Did you have problems with the Install.

GNOME has an EXCELLENT network manager and hence one should just need click on the small computer icon in lower right corner, select the SSID (if showing) and type in the user/name and password (and maybe reselect the encryption method if not correct).

When I boot to a GNOME live CD with my Dell Studio 1537 with the Intel 5300AGN wireless, the wireless ‘just works’.

Hence I would be suspicous that you have wireless switched OFF (if there is a hardware switch) or the wireless hardware is bad, or your openSUSE software install was bad.