Intel 4965 Wireless not working

Alright, I’ve read around and do know that this is a common problem, or at least it was on older kernels. But I have not yet found a fully comprehensive solution. I am using kernel, openSUSE 11 with KDE4.1 beta, I have iwl4965 from the repositories installed, and I am using a Linksys wireless hub. All other laptops can connect to my wireless fine, and I could on this computer as well while I was using K/ubuntu.

Once installing openSUSE I had wireless problems from the start. I could connect, but only about half the time. I would occasionally have to restart my network service or reset before I could get wireless to work. Once it was connected it would stay connected perfectly fine, though. When it doesn’t work it still SEES the wireless and attempts to connect to it when I tell it to, but it will fail, and for a few moments KNetworkManager will take up 100% of my CPU use before it settles back into off-line mode.

Since last night, though, I’ve been completely unable to connect at all through wireless. It acts the same way it previously did when it was unable to connect. But I now can’t connect at all, no matter what I try.

Somehome help, please! I don’t want to half to switch back to Kubuntu, I like openSUSE’s KDE4 implementation too much. ):

Thread moved to Wireless

Oh. Whoops! Sorry. I didn’t notice there was another subfolder… hehe. >.>

I have the same exact problem. I’ve tried compiling the compat wireless drivers but I still get nothing. Anybody out there that can help?

For a start, I’d like to know what is the right download from this directory:

Index of /download/compat-wireless-2.6/

(there are 2, released in the same day).

one of them doesn’t work…so presumably it’s the one that downloads :smiley:

I also have Intel 4965AGN wireless card and it is working fine with openSUSE 11.0 /KDE 3.5 out of the box. I didn’t have to do anything except configure wireless card during installing. It even got connected to the router before the installing was done and updated Firefox and nVidia graphic card. The installed driver in my laptop is iwl4965-ucode, version (from non-oss repo). I have the same version of kernel as “thorjelly”.

By the way did you try KDE 3.5. I also have gnome installed and wireless works fine there. I also played with KDE 4.0 for few days and the wireless was fine (KDE 3.5 is always my default DE).

Hope this info might help.

Right! Good point :smiley:

Ok, I had a problem with KNetworkManager and got my wireless working by doing this. It might be of help:

First, configure the network card using the Traditional option in Yast

This should install KInternet. When that’s finished start KInternet from the application launcher. You should see a little icon like a plug on the taskbar.

Then open a terminal. Change to root access, type ‘su’ and password.
Then do this:

Bring up the network

ifconfig wlan0 up

Scan for your wireless network.

iwlist wlan0 scan

Associate your wireless network with the card

iwconfig wlan0 essid [your network name]

Associate your WEP key

iwconfig wlan0 key [your key in hex]

Try and connect

dhclient wlan0

Looks a bit scary but I use this all the time now to connect to the internet. I put it into a shell script. KNetworkManager wouldn’t work for me. It picked up the network but kept getting stuck at 50%…

How are you guys installing the compat drivers? I have noticed people who have been using the RPM’s floating around the internet have not had much success. I personally have had more success by compiling the drivers manually.