Intel 3945abg with Opensuse 11

Hi all!

I’ve done a fresh install of Opensuse 11 Kde4,and immediately i’ve found problems with my intel 3945abg wireless card and my WEP encrypted connection…simply i can’t see it from my laptop

i tried connecting from terminal with

iwconfig wlan0 essid myessid
iwconfig wlan0 key myhexkey
dhclient wlan0

but nothing happened…

then i tried compiling compat-wireless drivers from source! i was able to compile,install and load them,but my wireless card doesn’t recognize anything yet.

I’ve read about a lot of people that solved with these drivers,am I the only person in the world that can’t solve this problem?? O_O

any tips?

P.S. I’m running kernel for i586 architecture.


I’ve been there too.

google for “compat wireless” do everything they tell you to but do not type make unload.

Just load the new drivers over the old ones. Your let won’t work but it solved my isseus.

Cheers, Thomas

as you can read above i’ve already downloaded,extracted,installed and loaded compat-wireless drivers following the instructions on (i did not run “make unload” but only “make load”,like you did),but i can’t have my card working! :frowning:

I know this isn’t a direct answer to your problem, but is there any way you could try changing your encryption to WPA? It’s not like WEP is very secure anyway (Google “aircrack”).

Also, have you tried connecting via Network Manager by manually supplying it with your connection details, including WEP key?

I also tried via Network Manager to manually connect,but it doesn’t works!
now i can’t change my encryption because my brother is unavailable and he’s the only one to remember router’s admin password! :slight_smile: By the way I don’t think it will works…my card doesn’t recognize nothing,and i think this is not an encryption problem! thanks anyway! :slight_smile:

could you post the results of:

dmesg | grep iwl3945

and the nic part of

lspci -v

P.S. i forgot to say that the card is recognized by the system,obviously! :slight_smile:

these are the results:

fabbio@linux-q9xd:~> dmesg | grep iwl3945
iwl3945: Intel(R) PRO/Wireless 3945ABG/BG Network Connection driver for Linux, 1.2.26ks
iwl3945: Copyright(c) 2003-2008 Intel Corporation
iwl3945: Detected Intel Wireless WiFi Link 3945ABG
iwl3945: Tunable channels: 13 802.11bg, 23 802.11a channels
linux-q9xd:/home/fabbio # lspci -v

......03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
        Subsystem: Intel Corporation Device 1001
        Flags: bus master, fast devsel, latency 0, IRQ 219
        Memory at fe1ff000 (32-bit, non-prefetchable) [size=4]
        Capabilities: [c8] Power Management version 2
        Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
        Capabilities: [e0] Express Legacy Endpoint, MSI 00
        Kernel driver in use: iwl3945
        Kernel modules: iwl3945


  • itfsos,

try and disable hw_scan.
Open a console, become root.
touch /etc/modprobe.d/iwl3945

Edit the file and add
alias wlan0 iwl3945
options iwl3945 disable_hw_scan=1



i tried but…nothing!:frowning:

I’ve done that
*try and disable hw_scan.
Open a console, become root.
touch /etc/modprobe.d/iwl3945

Edit the file and add
alias wlan0 iwl3945
options iwl3945 disable_hw_scan=1*

And it recognises my wireless and scans!! Doesn’t connect yet though but presumably that is because the router is set for WEP and not WPA ??

On 07/24/2008 mitch1976 wrote:
> And it recognises my wireless and scans!! Doesn’t connect yet though
> but presumably that is because the router is set for WEP and not WPA
> ??

Dunno, you should be able to configure a connection for WEP through the network manager applet.


Kernel 2.6.26 (released 13 July) has some interesting changes to the iwlwifi driver which can be found here:

Linux 2 6 26 - Linux Kernel Newbies

Some highlights include:

Improvements to 4965 for 802.11n.
Support for hardware WEP.
Support for hardware TKIP.
Support for the LED (most importantly):wink:

Maybe this doesn’t help you right this moment, but it seems like there’s a chance the WEP support improvements may help your situation.

me too! now network manager lets me find wireless connections,but i can’t connect to my WEP encrypted connection…a kernel problem i think…or maybe i can try some other wifi manager like wicd,but i don’t know hw to compile it from source,it isn’t the classic “./configure - make - make install”!

  • itfsos,

there are other network managers included (kdenetwork3-wireless, kwlan), but to find out if it is really the kernel, I’d actually try and configure WEP through Yast and use ifup.


sorry 4 the delay, your dmesg looks good, same here

I have WEP open system with a 64 bit key.
I use the 11g, not 11a part of my linksys router.
I used to have a sweex but that didn’t work.

The device is also the same. I’m clueless.

  • resturp72,

what I noticed with my AVM Fritzbox is that the Networkmanager doesn’t seem to accept the key in ASCII. If I enter the key in Hex, I get a connection immediately.


True, I tried passfrases and ASCI sometimes without success.
I use hexcodes too. maybe we should start a best practice and success section :slight_smile:

ok…this week i can’t try nothing because i’m on the sea and without internet!next week i’ll try with ifup or with the unstable version of opensuse,where i can install the new kernel 2.6.26!

I now see the wireless hub. Thanks and this worked for the 4965 too.