Intallation Problems

Newbie here and having trouble; this is my first post. I downloaded SUSE 11.0 and am attempting to set it up as a SERVER based on this article: -
The Perfect Server - OpenSUSE 11 - Page 3 | HowtoForge - Linux Howtos and Tutorials

On page 3 item 5 Install some software:

The command is:

yast2 -i findutils readline libgcc glibc-devel findutils-locate gcc flex lynx compat-readline4 db-devel wget gcc-c++ make vim telnet cron iptables iputils man man-pages

I then receive this ERROR:
Following package haven’t been found on the medium:
telenet
Compat-readline4

Can someone give this “newbie” a hand with this problem. Thanks in advance for your time and response.

CarolinaGuy

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Sure… you mis-spelled ‘telnet’ (‘telenet’) and have a capital ‘C’ in
Compa-readline4 (vs. the correct ‘compat-readline4’) so don’t do that
and you should be fine.

With that said, without reading the article, why in the world would you
install telnet? Just don’t… it’s been a security risk since the day
it was released and is replaced by default software (ssh) on every box
you’ll ever setup that is secure.

Good luck.

CarolinaGuy wrote:
> Newbie here and having trouble; this is my first post. I downloaded SUSE
> 11.0 and am attempting to set it up as a SERVER based on this article: -
>
> ‘The Perfect Server - OpenSUSE 11 - Page 3 | HowtoForge - Linux Howtos
> and Tutorials’
> (http://www.howtoforge.com/perfect-server-opensuse11-p3)
>
> On page 3 item 5 Install some software:
>
> The command is:
>
> yast2 -i findutils readline libgcc glibc-devel findutils-locate gcc
> flex lynx compat-readline4 db-devel wget gcc-c++ make vim telnet cron
> iptables iputils man man-pages
>
>
> I then receive this ERROR:
> Following package haven’t been found on the medium:
> telenet
> Compat-readline4
>
> Can someone give this “newbie” a hand with this problem. Thanks in
> advance for your time and response.
>
> CarolinaGuy
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFIrIP+3s42bA80+9kRApYVAJ4+xeFkxtldlBPDxeP2jLtFlrQTKwCgh1Zi
cZYFj4URGZKjUYzpLsAFKBo=
=czIT
-----END PGP SIGNATURE-----

> yast2 -i findutils readline libgcc glibc-devel findutils-locate gcc flex lynx compat-readline4 db-devel wget gcc-c++ make vim telnet cron iptables iputils man man-pages

Still receive error - URL not found.

I see telnet is spelled telnet, chg it to telenet still no work, deleted installation of telnet and system froze.
WIKI shows spelling as telnet
TELNET - Wikipedia, the free encyclopedia

Don’t see the capital “C” you talked about; Is it “compat” as listed in the article or “compa” as listed in the response to the query?

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

‘compat’ is probably correct… as is ‘telnet’. Still, I’d never
install the latter and the former should work if it’s available.

Good luck.

CarolinaGuy wrote:
>> yast2 -i findutils readline libgcc glibc-devel findutils-locate gcc
> flex lynx compat-readline4 db-devel wget gcc-c++ make vim telnet cron
> iptables iputils man man-pages
>
> Still receive error - URL not found.
>
> I see telnet is spelled telnet, chg it to telenet still no work,
> deleted installation of telnet and system froze.
> WIKI shows spelling as telnet
> ‘TELNET - Wikipedia, the free encyclopedia’
> (http://en.wikipedia.org/wiki/Telnet)
>
> Don’t see the capital “C” you talked about; Is it “compat” as listed in
> the article or “compa” as listed in the response to the query?
>
>
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iD8DBQFIrInq3s42bA80+9kRAhE3AKCLV+B+9ahtC+UL8+H9TFcjN/YA3QCfT+Ey
3fW8ZKT+ZbzhMpacM9Xmzb0=
=rAvN
-----END PGP SIGNATURE-----

In the above string I changed the l in devel to a numerical 1 and got this error
–unable to locate the following

glibc-devel
compat-readline4
db-devel

So I assume theses must be “L” and not numerical.

CarolinaGuy

OK How about we go from here.

I delete “compat-readline4” from the string and everything loaded fine.

Now where can I find “compat-readline4” rpm and load it. I would assume that the code–
yast2 compat-readline4 along with the location would load this item.

CarolinaGuy

> I delete “compat-readline4” from the string and everything loaded
> fine.
>
> Now where can I find “compat-readline4” rpm and load it. I would
> assume that the code-- yast2 compat-readline4 along with the
> location would load this item.

a problem is that that (compat) package should be on the install
medium you downloaded (from page one of the tutorial)…however, i
noticed that the (otherwise SUPER) tutorial did not direct you to
check the md5sum of the iso PRIOR to burning the DVD…nor to take
the other medium integrity steps advised in

http://tinyurl.com/3vwrzl

pay particular attention to items 2, 3, 4, and 6…

IF compat-readline4 is not on your install DVD, OR if it is corrupt
then you have installed with a DVD image that i wouldn’t trust. period!

i’d recommend you do the md5sum check on the iso (still have it?),
then boot from the DVD, and instead of selecting the “Install” option
from the first menu, select the “Check Media” (or similar, i forget)…

IF both of those check ok, then i don’t know why yast isn’t finding
it!! (if are you sure you typed compat-readline4, and not
compat-read1ine4?)

ps: the code to provoke yast2 to install an off machine .rpm is
available in man yast2 as

yast2 -i compat-readline4

which WILL check for dependencies…however, this (for off machine
rpm installs) will NOT check for dependencies

yast2 -i [full ftp or http path]/compat-readline4-[VERSION info].rpm

on MY machine (SUSE 10.3) i’d expect this to work (baring typos!)

yast2 -i
http://download.opensuse.org/repositories/openSUSE/10.3/standard/compat-readline4-4.3-75.rpm

BUT, i don’t know which version YOU need…and, i’d absolutely try to
find out WHY yast isn’t finding it ON your DVD!!


DenverD (Linux Counter 282315) via NNTP, Thunderbird 2.0.0.14, KDE
3.5.7, SUSE Linux 10.3, 2.6.22.18-0.2-default #1 SMP i686 athlon

I had the same problem with compat-readline4 on suse 11.0 when preparing suse for ispconfig.

Following is what i did:

  1. 1st, go here: Webpin

  2. Search for compat-readline4 and click on the install button

  3. Then execute the original command without “compat-readline4” as follows:

yast2 -i findutils readline libgcc glibc-devel findutils-locate gcc flex lynx db-devel wget gcc-c++ make vim telnet cron iptables iputils man man-pages

Hope this helps.

jaf

If there is a question re what is on the installation media or its correct name or spelling, you can just run the ncurses version of YaST Software Management (as you ran other ncurses screens above). You could also use zypper, which is what is under the hood, from the command line, to do the same.