Installs Catalyst 8.8 but MesaGL still runs.How do I change?

Greetz guys.

I installed OpenSUSE 11 a few days ago in an attempt to learn linux. So far so good. I’ve understood most of what i’ve encountered; had a network connection problem…which is solved now.

The only thing, though, is concerning the ATi drivers.

I had installed the Catalyst 8.7 (and had the same problem). But I downloaded the 8.8 and uninstalled the 8.7’s (via sh ./fglrx-uninstall.sh in the /usr/share/ati folder)…followed by a reboot.

You can switch to super-user (via ‘su’) or run sudo ./ati-driver-installer-8-8-x86.x86_64_2.run

…I ran su, input my password and ran ./ati-driver-installer-8-8-x86.x86_64_2.run

The driver package extracted and the Installer window came up (showing ATi and the penguin).

I chose Install Driver 8.455.2 on X.Org 7.1 and later releases, followed by ‘Automatic’…continued.

It said the drivers installed (with a log file in /usr/share/ati) and that I should run aticonfig --initial…which I also did. Everything worked fine. :slight_smile:

I reboot. It looks like the drivers are working (cause the refresh rate from 60Hz switched to 75Hz)…much better.

The only thing, though, is that when I drag any window or try scroll down a web page or window, it is SLOW!!!

One thing I know is that you have to check if the ATi drivers are rendering or MesaGL…so, I type fglrxinfo to check what’s up…the following is listed:

display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.4 (2.1 Mesa 7.0.3)

My question now…how do I get it to use the ATi driver OpenGL rather than the Mesa GLX? And will this solve the apparent choppiness when dragging/scrolling down windows?

I was recommended using this link:
ATI Installer HOWTO for SUSE/Novell users

But honestly, i’d love to be able to sort this out manually…this is the only way i’m gonna learn linux and start appreciating how it works and how to get around managing issues/future endeavors. Regardless how technical it can be to switch the Mesa GLX to ATi GLX, i’ll do it. So, what should I do?

B.T.W, i’m using an ATi Radeon HD4870.

Once this is done, i’ll be a happy Linux camper.

Cheers. :wink:

r2rX :smiley:

I always follow the ‘Hard Way’ section of this guide to install ATI drivers: ATI - openSUSE It’s a good idea to print it out before you start as you have to leave the GUI at one point. I also have to edit the xorg.conf file as follows for google earth to work properly:

Section “Extensions”
Option “Composite” “false”
EndSection

Thanks for the feedback, Harlequin501. I’ll read through it and test it out.

I’ll post back my progress. :slight_smile:

r2rX :smiley:

Hey guys.

So far, no luck.

I’ve tried compiling the drivers specifically for OpenSUSE using the command line:

./ati-driver-installer-*.run --buildpkg SuSE/SUSE110-IA32

When it runs, this is the result:

r2rX:/home/ready2rumbelx/Documents # ./ati-driver-installer-8-8-x86.x86_64_2.run --buildpkg SuSE/SUSE110-IA32
Created directory fglrx-install.ybDWom
Verifying archive integrity... All good.
Uncompressing ATI Proprietary Linux Driver-8.522........................
.......................................................................................................................
.......................................................................................................................
.......................................................................................................................
.......................................................................................................................
.......................................................................................................................
.......................................................................................................................
.......................................................................................................................
==================================================
 ATI Technologies Linux Driver Installer/Packager
==================================================
Generating package: SuSE/SUSE110-IA32
/tmp/ati.L1fuRI
Package build failed!
Removing temporary directory: fglrx-install.ybDWom

Why is this happening?

On top of that, I checked the thread:

ATI - openSUSE

…and there are packages which are recommended to be present:

* kernel-source
* qt3
* compat
* compat-libstdc++
* libstdc++
* libstdc++-devel
* libgcc
* xorg-x11-libs
* xorg-x11-devel
* Mesa
* Mesa-devel
* fontconfig
* fontconfig-devel
* expat
* freetype
* freetype2
* freetype2-devel
* zlib
* zlib-devel
* gcc
* patch 

Using Yast2, I’ve checked the packages installed on my machine (it updated it’s .xml’s to reference updates). Now, some were installed and some weren’t.

My bandwidth is quite restrictive, so downloading the missing packages is a serious pain. Are these packages not available on the OpenSUSE installer/DVD? Is this, potentially, the reason why the drivers are not working properly? Or why I can’t compile the drivers specifically for OpenSUSE?

…man, this is disheartening…

r2rX :slight_smile:

Yes you need to install all those packages I’m afraid. On top of that lot make sure ‘make’ is installed and also select the ‘Patterns’ filter and tick the ‘RPM Build Environment’ box. You should be good to go then!

You can check the installation source for each package (i.e. a repository or the openSUSE DVD) by clicking the ‘Versions’ tab.

Good luck! :slight_smile: