Installing Xen tools using YaST always failed

I tried many times installing Xen tools using Virtualization utility on YaST but always failed. Once it’s installed on YaST and then rebooted, the booting screens are always corrupted and can’t go on starting the system. So the only VM server I can use on openSUSE Leap 15.0 is KVM.

After you’ve tried to boot a Xen kernel unsuccessfully, run the following command to create a syslog file for the boot that failed

journalctl -b -1 > syslog_xen_boot

Then, upload the contents of that file to a pastebin so others can inspect it.

I’ve generally had a poor record trying to install something “many times,” if its failed twice then I’m generally ready to trash the whole attempt and start over.
I’d recommend the same thing…
First, I’d anticipate the possibility of failure, particularly if I’d failed once… So for instance whenever I install any kind of virtualization host, it’d likely be a brand new install and one I’d be willing to pave and re-build in a moment. I’d be more wary installing and configuring virtualization in an install with history.

The next thing I which I consider SOP
Is to ensure the base system is fully updated and as uncomplex as possible (least amount of extra applications installed).

And lastly before actually installing and making major changes to your system,
Consider whether you want to implement any strategies that might enable you to roll back or restore from backup so you can avoid paving and re-building.
Nowadays you might even consider BTRFS and transactional update installing. If you do consider using BTRFS on your system, you may want to turn off snapshots for your virtual disk storage.


I gave up on Xen since it’s installed and shown on the boot list at the beginning of system boot but its entirely corrupted screens can’t work you through the system boot and totally useless. I’m pretty sure it’s a bug somewhere in the system.

Is there some reason why you didn’t do anything of what I suggested in my prior post?
The journalctl command in particular is intended to be run after an unsuccessful boot, so for instance after unsuccessfully trying to boot with a xen kernel, you can boot to an ordinary kernel and the command will read what happened when you tried to boot to the xen kernel.