Installing X on a textonly openSuSE

Hi all,

Not sure if this goes here or in Applications. Apologizes if in the wrong category.

I have a working text only openSuSE 12.2 machine.

I would now like to install a graphical interface on top of it all but I can’t figure out how to do it and which packages I should install from YaST?
The video controller is a built in intel one coming with office P4 desktops.

Thanks for your help,

On 2012-10-21 02:16, ShaolinSatellite wrote:
> I would now like to install a graphical interface on top of it all but
> I can’t figure out how to do it and which packages I should install from
> YaST?

Just choose one of the graphical patterns.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

I tried installing kdebase3 but it didn’t work. It was a guess as I have no idea which package I really need to install.
I also have to install X11 etc I guess.

On 2012-10-21 03:06, ShaolinSatellite wrote:
>
> I tried installing kdebase3 but it didn’t work. It was a guess as I have
> no idea which package I really need to install.
> I also have to install X11 etc I guess.

I said to choose a pattern, not a package. Repeat: pattern.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 10/21/2012 04:43 AM, Carlos E. R. wrote:
> Repeat: pattern.

for example:
-become root
-open yast
-select Software Management
-when the software management module has loaded, use the Tab button to
navigate to the “Search” block, then press the down arrow and a drop
menu offering Patterns, Languages, RPM Groups, Repositories, Search and
Installation Summary will appear.
-use the up key to nave to highlight Patterns, then press enter
-scroll down (with arrow key) to find ONE of four Desktop Environments
(offered are Lightweight X11 Desktop Environment (LXDE), GNOME Desktop
Environment, KDE4 Desktop Environment and XFCE Desktop Environment)

NOTE: i’d suggest you pick one of those four Desktop
Environments…not all four, and not a bunch of other stuff…if you
just pick a DE, YaST will automatically fill in the needs (like X) for it)

-so, highlight ONE of those four, and press enter
-press Tab key to navigate to “Accept” and press enter again

NOTE: you have not mentioned much about your hardware, RAM, etc, you
will need 1GB of RAM for a snappy KDE or GNOME system…with less i’d
suggest LXDE or XFCE…


dd http://tinyurl.com/DD-Caveat

Thanks, that’s much more helpful. I had no idea about this pattern option in YaST.

The system is a P4 2800Mhz with 1Gb of RAM and an intel integrated video controller. Based on you recommendations, I will pick LXDE or XFCE. Are they both equally advisable?

On 10/21/2012 06:56 AM, ShaolinSatellite wrote:
> I will pick LXDE or
> XFCE. Are they both equally advisable?

depends on what you are used to! and what you need!!

with 1GB RAM you can use any of the four listed–and others which are
not listed but can be installed anyway–by finding the right hoop to
jump through :slight_smile:

if you are a long time MS-Windows or Apple/Mac user you will probably
find KDE4 the most ‘familiar’… all will present some new learning
requirements]

it is also the most ‘heavy’ and resource hungry…
LXDE and XFCE are reasonably ‘familiar’ feeling to exWin users…

GNOME (when version 2) was usually the best fit for previous Mac users,
but with the advent of GNOME3 (which i’ve never used, or even seen
running) i understand that there is a lot of ‘differences’ from any of
Windows, Mac, KDE or even PlayStation…but, you might find it wonderful…

well, it is really difficult to say what is best for you…

you might begin by reading the quick start guides for

KDE:
http://doc.opensuse.org/documentation/html/openSUSE/opensuse-startup/art.kdequick.html

GNOME:
http://doc.opensuse.org/documentation/html/openSUSE/opensuse-startup/art.gnomequick.html

lots to learn here, and learning is FUN!

so Have a lot of fun! (back up first!)


dd http://tinyurl.com/DD-Caveat

Hi,

I can’t experiment in this, but I’d say that the install of the kde4 patterns would force the install of the necessary other patterns/packages.
Do


zypper ref && zypper pt

This will show all available patterns. For KDE4 to be installed do:


zypper in -t pattern kde4_basis kde4

After doing so you would need to adjust runlevel to 5, assuming the machine now runs in 3. You may also have to configure some options in /etc/sysconfig/displaymanager

So, I installed the LXDE pattern. I checked install all of the packages contained in the pattern. It seems the install went with no problem.

But it doesn’t work the way it should:

downloader:~ # startx
xauth:  file /root/.serverauth.6723 does not exist

/etc/X11/xinit/xserverrc: line 51: exec: X: not found
^Cxinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: unexpected signal 2
-------------------------------------------------------------------------------------------
xinit failed. /usr/bin/Xorg is not setuid, maybe that's the reason?
If so either use a display manager (strongly recommended) or adjust /etc/permissions.local


There is no Xorg directory in /usr/bin/

I would think I have to install xorg but then again I don’t know which package to select from the list

I dare to guess - pattern “x11”? Although when I look at my system, half of packages from this pattern are not installed, so there must be some other criteria during installation and it seems to install far too much.

On 2012-10-22 01:06, ShaolinSatellite wrote:

> There is no Xorg directory in /usr/bin/
>
> I would think I have to install xorg but then again I don’t know which
> package to select from the list

At least the minimal graphical environment pattern. There is a pattern
named “X Windows System”.

Just list the available patterns in zypper or yast and select one that
looks promising.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 10/22/2012 01:06 AM, ShaolinSatellite wrote:
> So, I installed the LXDE pattern. I checked install all of the packages
> contained in the pattern.

i did not say to expand the LXDE pattern and check to install all
packages inside the pattern…did i?

so, i don’t know what else you did or what might have gone wrong…but
i did expect YaST to be smart enough to know that LXDE requires X11, and
install it also…if that was a faulty assumption then the others
telling you to install “x11” and “X Windows System” and “kde4_basis” are
probably correct–HOWEVER, if YaST actually installed LXDE without
meeting the dependencies of X11 et al, then you really need to log a bug!!

but, to the next thing: if you are trying to ‘learn linux’ from a book,
wiki page, guide, how-to or whatever and in that book/etc you read to
issue startx as root to launch the X Window system–then you need to
THROW that book/guide away…it is out of date and not suitable for the
version of Linux you are using!

doing startx as root is now and always has been wrong.

and, in 12.x that has been blocked by design.

maybe it works in Ubuntu or Fedora, but not here and that is for your
security…

also, that book (if you have one; or the guides you are following) are
too old to be useful with 12.2 because it does not take into account the
new use of systemd rather than systemv, in which it was possible to do
this to launch windowing:

as root: init 5


dd
http://tinyurl.com/DD-Caveat

Just an added note (in case you are not aware):

While starting X in this manner should work (provided you have the right packages etc. … which, unfortunately, doesn’t read to be the case here) when running as root (which does appear to be the case indicated by the output you’ve provided), however, doing so as a regular user will not work; see http://forums.opensuse.org/english/get-technical-help-here/install-boot-login/456567-cannot-startx-unless-superuser-4.html and the release notes to release 11.4 (which can be found in the wiki) for more information.

oops! I didn’t even notice that there was a second page to the thread and that this was already addressed hours earlier. Anyway,

Note: running “startx” as root still works just fine. Its very useful for testing purposes. It is the initiation of X by the regular user that has been changed (see note in my last post).

Reading your posts, I tried the following:

init 5 under root start a graphical terminal (for a lack of a better description): The background turns grey, I have a pointer controlled with the mouse and a shell prompt occupying 1/8th of the screen surface. But no desktop or menus or anything you could expect from a desktop environment

startx under non root does about the same thing

startlxde under non root does also the same thing

startxfce4 under non root starts what seems to be what I was expecting, i.e. a desktop environment with icons, menus etc.

Is it normal that init 5 ans startx don’t work while startxfce4 works?

How can I have the computer to boot straight into graphical mode?

That would be a barebones X session lol! Sure sounds like X is installed to me. To get a desktop experience you’d want to be launching X along with a client Window Manager (either a standalone or that provided in DE)

startx under non root does about the same thing

startlxde under non root does also the same thing
They do? That’s a surprise. Anyway, you shouldn’t be initiating X as a regular user.

startxfce4 under non root starts what seems to be what I was expecting, i.e. a desktop environment with icons, menus etc.
Again, surprised that it works as a regular user … and, again, noting that you shouldn’t start X that way anyway

Is it normal that init 5 ans startx don’t work while startxfce4 works?
No – nowadays the regular user shouldn’t be able to initiate an X session (period!) … let alone whether its of the bare bones or full blown DE variety

How can I have the computer to boot straight into graphical mode?
With, as mentioned earlier in the thread and in the error output, with a DM (display manager … like KDM, GDM, lightDM, slim etc etc…or even XDM) … but, aside from that, it would also appear that some of the basic inner working / underlying settings are not correct right now, so you may want to investigate that in order to lock down your system a little better.

On 10/22/2012 03:46 PM, Tyler K wrote:
>
> Note: running “startx” as root still works just fine. Its very useful
> for testing purposes. It is the initiation of X by the regular user
> that has been changed (see note in my last post).

ok, i had a “senior moment” when thinking that blocking startx as root
was what had changed…

but, i do not now nor have i ever supported the idea of running X as
root, which is what happens if you launch startx as root…(even just
for “testing purposes” as the only thing you can learn is "it runs as
root so it must be a permissions problem, which can almost always be
learned by finding the “permission denied” note in /var/log/messages)

imo, you should instead launch X with “init 5” or something else (i know
not what) in systemd (maybe, i’ve not studied it at all)

whatever! since i have never tried to add X to an operating non-X
system, i think i’ll back out of this thread…or maybe just watch and
see what i can learn!!


dd

no worries lol!

but, i do not now nor have i ever supported the idea of running X as
root, which is what happens if you launch startx as root…(even just
for “testing purposes” as the only thing you can learn is "it runs as
root so it must be a permissions problem
There are a number of usage cases where launching X as root, via “startx”, is purposeful (e.g. testing additional X servers). So while it may not be as such in this user’s case or context, that statement most certainly does not pertain to all cases. And I guess that is the point that I was alluding to earlier

On 2012-10-22 16:46, ShaolinSatellite wrote:
>
> Reading your posts, I tried the following:
>
> init 5 under root start a graphical terminal (for a lack of a better
> description): The background turns grey, I have a pointer controlled
> with the mouse and a shell prompt occupying 1/8th of the screen surface.
> But no desktop or menus or anything you could expect from a desktop
> environment

Check “/etc/sysconfig/displaymanager”, variable “DISPLAYMANAGER”. It
looks to me as the failsafe “desktop”, which is a plain terminal. It
triggers if the display manager or the desktop can not start (missing
pieces).

Check also “/etc/sysconfig/windowmanager”.

> startx under non root does about the same thing

It should abort with an error, startx as plain user does not run unless
you do some changes.

> startlxde under non root does also the same thing
>
> startxfce4 under non root starts what seems to be what I was expecting,
> i.e. a desktop environment with icons, menus etc.

Then lxde is not really installed.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

[quote="“robin_listas,post:19,topic:84069”]

Then lxde is not really installed[/QUOTE]not necessarily … what he is observing is the default behaviour of xinit when no xinitrc is found (see “man xinit”).

I’m not really familiar with LXDE and (more to the point) the startlxde script, but googling “startlxde” provided an Arch wiki link ( LXDE - ArchWiki ) which provides a few suggestions… on first glance, the one about launching when having no xinitrc seems a little bit circular to me (i.e. I would assume that startlxde is a frontend to xinit similar to startx), but as I said I’m not familiar with this, so perhaps the cmd as written works and launches the desktop.