Installing VMWare Server, and I can't find my kernel headers

I’m attempting to install VMware Server, and it’s asking me where the headers used to compile my kernel are. I’m running kernel Yast says I have 2.6.27-2.28 headers installed, and that’s the latest version. I can’t even find those though. Does anyone know where I can find these files?

Possibly what you actually need is kernel-source
from a su terminal

zypper in kernel-source

I ran that command, and it seems to have downloaded the source files. Where do I now point the VMware installation script to find them?

Are you saying you have run the vmware installer again and it still does not work?

I got similar issue with workstation 6.5.2 and kernel i got sources but i forgot to get the headers and now i’m no more connected to the internet at home.
I tried for five hours to find the kernel headers from the internet in rpm format (for exemple) and i never found it.

Can someone could tell me where i could find kernel headers for ???

Thank you !!

Of your install DVD… the headers don’t change with an updated
kernel as long as the 2.6.27 is there :slight_smile:


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel
up 1 day 0:17, 2 users, load average: 1.24, 0.58, 0.38
GPU GeForce 8600 GTS Silent - Driver Version: 190.18

Thank you, I first thought about using the install dvd… but those headers where not the and vmware still don’t want to compile modules…

I’m now searching for kernel headers… same issue, still not connected but i will bring my computer at my father’s and then set a complete update and hope vmware will work under linux… now i’m using it on windows and it works but i prefer linux because concerning wifi the drivers under linux could inject packets under windows igt is impossible… and linux under vmware won’t inject packets…