Installing virtualbox via zypper

I tried installing virtualbox using zipper instead of downloading rmp from web but I cannot figure out how to run it. Seems to me that there is couple of different things for virtualbox but not the application which enables me to start virtual machines. What is it used for? Should I install virtual box only from rpm from web?

No, not necessary. The openSUSE packages should work just fine.

What packages do you actually have installed?

rpm -qa virtualbox*

You need virtualbox-qt for the GUI, that’s the official one you also get when installing from virtualbox.org. There’s also “vboxgtk” available, but that doesn’t work and was even dropped from the distribution recently because of that.

If virtualbox-qt is installed, you should have an entry in the application launcher. But you can also run it via “VirtualBox” in a terminal window.

Oh, and you also need to add your user to the group “vboxusers” to actually be allowed to start VMs. But a warning dialog should tell you that anyway if you don’t do it.

Ah yes. Actually I also installed virtualbox-qt but did not check application launcher just tried to run “virtualbox” from terminal and then concluded that it is not installed:)

So does it work now?

Yes, the shell is case-sensitive, like filenames in Unix/Linux in general… :wink:

Yep, it works and had worked even before I started this thread:D Thanks . It did not occur to me it could be upper case. Ugh I really don’t like using upper case for files in Linux:)