Installing TW on ASRock X670E Taichi with AMD 7000 CPU

May be a fool’s errand, but here’s what happens.

I created a bootable USB from the latest (10/1/22) offline image, using ImageWriter.

Installation proceeds to “Activating USB devices… OK”, then I lose my keyboard, and it prompts for “Installation Media” and provides options. Which I can’t choose, because, I lose my keyboard.

Any ideas?

For what it’s worth, I was able to use Ubuntu Live CD and use it.

A BIOS USB setting change could make a difference. has a USBwait option maybe you need.

I tried with USBWait=600, and after 5 minutes, all my USB is still gone.

Did you try moving the keyboard among various USB ports while booted?

It’s not unusual for USB2 or USB1 devices to fail in USB3 ports.

Yes. I tried several different ports.

Since I’m using the offline image, and it prompts me for the installation media, the USB storage is also ‘lost’ after Activating USB devices.

It’s not a keyboard/mouse USB thing. I think it’s a USB hub driver thing.