Installing Tumbleweed on a singular USB drive?

So I got myself an USB drive that I want to install Tumbleweed on. Unfortunately I can’t use a separate USB to put installation media on as other ports on my machine are occupied by stuff like USB ethernet adapter (my laptop has only wifi and bluetooth internally) and mouse (trackpad on this thing is really awful, like it often registers swipes or taps when there were none or vice versa - fails to register taps/swipes when you want it to). Therefore I need to install it on a single USB from the get go. My questions are as follows:

  1. How hard is it to blow liveUSB image from the stuff that’s in it to fully working Tumbleweed installation? How do I do that?
  2. If above is too hard, is there any tool that would take installation media iso and instead of creating “install usb” it would create a liveusb from it? The laptop is on Windows10 and I cannot just install Linux on it due to other users of this machine having the wrong idea of what a good operating system is.

Hi and welcome to the openSUSE Forums!
Maybe you are not aware that a live Tumbleweed image when burned to an USB stick has a “persistent” feature built in, so that what you install or configure is superimposed to the “original” image at runtime.
Not sure what you intend to “blow” from the live image, but you can give it a try and see if it fits your needs.
Please be aware that some Win* burning tools don’t preserve the original openSUSE configuration of the image, so if you cannot burn your stick on another linux ask here for the right hints.

I was concerned with this passage:

         Please be aware of the following limitations of the live images:
  • They should not be used to install or upgrade Tumbleweed. Please use the Tumbleweed media instead
  • They have a limited package and driver selection, so cannot be considered an accurate reflection as to whether Tumbleweed will work on your hardware or not

The second one in particular. Also, which image writing tool should I use? One of the wiki pages suggested SUSE Studio Image Writer, but the ftp it’s on is passworded?

The two lines you quoted are correct, but:

  1. Live images cannot install or upgrade an existing system, there is no installer on them; but they run fine from the media they are burned to.
  2. Yes, there is a limited selection of packages, but as said you can install more (if you have room on the USB stick) and those changes will persist (if the image was burned correctly).
    You can download SUSE Studio ImageWriter from here: https://software.opensuse.org/package/imagewriter (pick the version that suits your OS version)

In case you have nothing but Win* to create your bootable drive, this page might help:
https://en.opensuse.org/SDB:Create_a_Live_USB_stick_using_Windows
There is also a link for ImageWriter for Win*, but it seems that version has not been maintained since years, so maybe it doesn’t work as expected with current systems or images: use it at your own risk!
https://github.com/downloads/openSUSE/kiwi/ImageWriter.exe

Nevermind. Lots of AHCI errors, making the thing unbootable. Also, when I put the image on the disk (used Etcher), it created one tiny 912mb partition for data instead of using full capacity of my 64gb flash drive.

Hi
Correct, then after first boot it will expand and use the rest of the disk space. Might want to try rufus in dd mode, this worked for me in my tests.

The other option is to use Studio Express (or kiwi locally) to create an image to your requirements…
SUSE Studio Express

This is what I see on my Tumbleweed live image (created locally with kiwi);


sdc      8:32   1  14.8G  0 disk 
├─sdc1   8:33   1   443M  0 part /run/media/user/CDROM
└─sdc2   8:34   1  14.3G  0 part /run/media/user/cow

One problem with the live ISO images is that the default grub options are forever burned as read-only state, and cannot be adjusted from within the live session. I had to use a binary editor on the raw ISO image to change the defaults, hah! The “failsafe” line has a lot of room once you change the failsafe options to spaces …

I did this not too long ago. But you might not be setup for the method that I used.

Basically, I did it in a virtual machine. I attached the install iso to the virtual machine (as a virtual DVD drive). I then booted the installer iso, and plugged in the USB as it started booting. With “virt-manager”, I can “forward” a USB device to the virtual machine.

Once it was all done, I then tested booting the newly installed USB system on a real machine. And that worked. So the install had done what I wanted.

You don’t need ethernet for a basic install, so why can’t you unplug that adapter (or the mouse) just for the time needed to install a basic system? Or burn the installer image to a physical DVD if the laptop has an optical drive and connect the destination drive to an USB port?

Interesting