Installing Tumbleweed in AHCI mode

I’m having trouble with installing openSuse Tumbleweed with SATA devices working in AHCI mode. Here’s what I did:

  1. Made sure that AHCI mode was enabled in BIOS (actually, it’s been enabled for some time already, with working Ubuntu installation).
  2. Installed openSuse Tumbleweed wiping out the hard drive (well, the partition table) completely. The default partition layout (suggested by the installer) and bootloader settings were chosen.
  3. Rebooted.

Now the PC freezes during AHCI devices detection by BIOS. This means I cannot go any further, not even to BIOS settings screen, letting alone trying to boot anything. It does not seem like a hardware issue though (since evenrything worked fine before the openSuse installation), and I can get the drive being detected correctly by unplugging it, switching the BIOS settings to IDE mode, plugging the disk back again, then booting a live CD and clearing the drive’s boot sector and partition table (dd if=/dev/zero of=/dev/sda bs=512 count=1). This leads me to believe that openSuse messed up the MBR causing the problem with device detection, but this should be possible to overcome by tweaking the settings somehow.

What can I do to get it working? Any help would be appreciated.

Are you using legacy BIOS or EFI boot?

Standard BIOS.