Installing to single specific partition on multiboot system with many partitions

I have a multiboot system with more than 15 partitions of Linux and around 8 Windows installations on three physical hard drives. I fromatted my Opensuse 13 partition and attempted to replace it with Leap 42.3 At some point I was lookng at a proposal list to format the first two Linux OS partitions 6 and 7. I need to get to something like the “something else” option in Ubuntu. I tried the Expert Partitioner but did not know how to specify the mount point / for the 11th partitio which is the one where I need to install the OpenSuse.I have been using Grub2 boot loader and Daniel Richter’s grub customizer. I didn’t want to create any new Home or Swap partitions. Any pointers would be much appreicated. I can provide more details if necessary.

You were almost there. In expert partitioner choose the partition and then hit the edit button. I think double clicking the partition should also work. The next screen asks whether you want to format the partition and what its mount point should be. Just place a “/” in the dropdown field.

Unless you are doing hardware testing, I would suggest going for virtual machines. You could have all 15 installations running at the same time, provided you have enough computing resources.

If the target partition is completely empty,
Then probably the easiest is to simply remove it, leaving free, unpartitioned space.

The openSUSE install should then find the free space and offer to install new partitiones, format and install into that space.


Expert partitioner. Select the hard drive and make the desired changes …

Thanks for the replies. When I went to select / for the mount point I got a choice of /var /opt /boot /tmp /usr/local
I have never seen these before. Which should I choose?

BTW here is the long list of partitions:

To the best of my memory Grub2 is saved to sda/

 	 	 	   arch@arch-System-Product-Name:~ > sudo fdisk -l

[sudo] password for arch:

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
255 heads, 63 sectors/track, 121601 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x5d7d47e1

Device Boot      Start         End      Blocks   Id  System

/dev/sda1 * 63 287547434 143773686 7 HPFS/NTFS/exFAT
/dev/sda2 287547435 532876049 122664307+ 7 HPFS/NTFS/exFAT
/dev/sda3 532876050 778204664 122664307+ 7 HPFS/NTFS/exFAT
/dev/sda4 778204666 1953520064 587657699+ 5 Extended
/dev/sda5 778204729 1953520064 587657668 7 HPFS/NTFS/exFAT

Disk /dev/sdb: 640.1 GB, 640135028736 bytes
255 heads, 63 sectors/track, 77825 cylinders, total 1250263728 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0xc4102f2e

Device Boot      Start         End      Blocks   Id  System

/dev/sdb1 * 203929110 455426684 125748787+ 7 HPFS/NTFS/exFAT
/dev/sdb2 455426690 687919364 116246337+ 7 HPFS/NTFS/exFAT
/dev/sdb3 687919428 893358584 102719578+ 7 HPFS/NTFS/exFAT
/dev/sdb4 65 1249616024 624807980 f W95 Ext’d (LBA)
/dev/sdb5 128 203929109 101964491 7 HPFS/NTFS/exFAT
/dev/sdb6 893358648 1168198604 137419978+ 7 HPFS/NTFS/exFAT
/dev/sdb7 1168214732 1249616024 40700646+ 7 HPFS/NTFS/exFAT

Partition table entries are not in disk order

Disk /dev/sdc: 320.1 GB, 320072933376 bytes
255 heads, 63 sectors/track, 38913 cylinders, total 625142448 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x2b7fa170

Device Boot      Start         End      Blocks   Id  System

/dev/sdc1 * 2048 29296969 14647461 83 Linux
/dev/sdc2 29298686 625141759 297921537 f W95 Ext’d (LBA)
/dev/sdc5 29298688 39452671 5076992 82 Linux swap / Solaris
/dev/sdc6 39454720 82075647 21310464 83 Linux
/dev/sdc7 82077696 123844607 20883456 83 Linux
/dev/sdc8 123846656 154687487 15420416 83 Linux
/dev/sdc9 154689536 185438207 15374336 83 Linux
/dev/sdc10 185440256 218402815 16481280 83 Linux
/dev/sdc11 218404864 259850239 20722688 83 Linux
/dev/sdc12 259852288 294955007 17551360 83 Linux
/dev/sdc13 294957056 331900927 18471936 83 Linux
/dev/sdc14 331902976 366860287 17478656 83 Linux
/dev/sdc15 366862336 402122751 17630208 83 Linux
/dev/sdc16 402124800 435568639 16721920 83 Linux
/dev/sdc17 435570408 466913159 15671376 83 Linux
/dev/sdc18 466913280 500070399 16578560 83 Linux
/dev/sdc19 533502648 625141759 45819556 7 HPFS/NTFS/exFAT
/dev/sdc20 500072448 533501951 16714752 83 Linux

Partition table entries are not in disk order

Disk /dev/sde: 31.9 GB, 31914983424 bytes
256 heads, 63 sectors/track, 3864 cylinders, total 62333952 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

Device Boot      Start         End      Blocks   Id  System

/dev/sde1 * 2048 62333951 31165952 c W95 FAT32 (LBA)
arch@arch-System-Product-Name:~ >

Start over.

When you are given a partitioning proposal, click “Create partitioning”.
On the next screen, select “Custom partitioning”.

That should give you a screen listing only the existing partitions. The right click on any partition to select what you want to do with that.

The problem was that I couldn’t find the option of a single forward slash for my mount point only a drop down menu with a choice of /var /opt /boot /tmp or /user/local. Is there a way to get the single forward slash for my mount point or did I miss it?

You probably did not see / in the list because / is already used. From the existing partitions first “unuse” those you want to use for something different. Then give the partitions the use you want the to have. Thus you avoid “doubles”.

Just type /

Partition can have any mount point so you just type what you want. For home is is /home

It is my experience that when one of the prepared list is not in that list (and / should be there), it is already in use in the setup at that moment in time. Thus forcing it by typing / by yourself will probably create a weird situation when you will not undo the other one before carrying in with the installation (two file systems mounted on /, is possible, but the result will depend on the sequence of mounting and it is most probably not what one wants).

When I type / then /var comes up. When I backspace to get just / it says “already in use.” When I leave it blank it says “cannot be empty.” Another complication came up this time that I did not notice in prior attempts. My network card was listed and said it was not set up with “Edit” being one of the options. I have no idea what to put in here. I have cable Internet. I notice that my IP number is left blank. I don’t know if my IP is static or dynamic, if I should find out what it is via the Inernet and write it down to put it in when that comes up.

When I typed / I got /var. Backspacing to leave just / gave me, “already in use.” Not entering anything gave me, “must not be empty.”

Check my comment #6 in this thread.

If you do it that way, nothing should be already in use with the possible exception of swap. It gives you a clean start on setting the partition usage.

As I already tried to explain two times (but I failed for some reason), It is exact as the installer tells you:
**You can not have two mounts on the same mount point **(/ in this case).
You must first look into the partition table shown where / is already in use. And change that. else you will never be allowed to use another partition for /.

I am afraid I can not make it more clear. The only thing you can do is make a picture of the partition table window and post it on , them maybe we can take you by the hand and guide you through it.

Sorry, I missed the page 2 link, so I thought one of the posts didn’t get posted.

Sorry, do not understand all you say here, but you seem to have missed them.

The most important thing now is of course if you understand what I posted and if you see on your partition screen that / is already in use.

So far I have not been able to see that / was already in use but I did get that reply when I tried to type / Sorry I have been out of town for the last two or three days. I presume I supposed to see / already in use on the expert partitioner screen. I will run it again and have another look.

I didn’t see anything different this time other than the fact that all the partitions are listed as /dev/sdc with a number after the c with /dev/sdc/11 being the partition that I formatted originally in gparted from another linux distro. The reason I didn’t delete the partition is that I thought it might throw out the paritioning sequence for booting. I do not understand very much. I do not know how to look into the partition table.

Is that really what is there? I do not understand that at all.

We need a picture from the proposal at installation. Where you said you want to change the originall proposal and choose to go for changing all and where the whole disk layout can be seen.

Make a photo and up load it to
insert the URL in your post. As long as we can not see what you see it is very difficult to help you.

Once I marked Btrfs formatting the option of the single slash / appeared at the top of the list. I was impressed with the slick installation progress.