Installing suse11 on Parallel MacBookPro can't get 1440x900

Hi,

I am new to opensuse, just have a fresh installing thru DVD image, am having a bit of issue with the video resolution. I have installed ubuntu in parallels - I have a 15" Macbook pro. And I can get 1440x900 wide resoultion.

Is there any help for getting opensuse11 to work on parallels on the same resolution? 1440x900 is a wide screen resolution.

thanks in advance if you guys can provider any help.

Cheers!
pin

What have you tried so far?

Typically, in openSUSE Linux, your PC’s graphic settings are stored in the configuration file /etc/X11/xorg.conf.

What I typically do, in such a case is first backup that file!! Then I boot to run level 3 (a text/ascii mode) and run a program called sax2 to configure the graphics.

What graphics card does your mac book pro have? nVidia? If so, do you know if you are using the vesa graphic driver ? or openGL (opensource) graphic driver ? or proprietary nVidia driver?

You can tell which graphic driver by typing in a konsole or terminal:
grep -i driver /etc/X11/xorg.conf

  • If the driver is “nvidia” you are using the proprietary driver
  • If the driver is “nv” you are using the openGL driver
  • If the driver is “vesa” you are using the vesa driver

DETAILS:

So, armed with that information, reboot your PC to run level 3. I’m not sure how this works on a MacBook pro. If you get the grub menu (which is where you select which operating system you wish to boot to) then press “3” (no quotes) to enter ‘3’ into the options line in the grub menu for the openSUSE boot. This will then boot your PC to run level 3 (ie boot to an ascii / text login). [If that does not work you will need to boot to a GUI and instead type “init3” with root permissions and someone else can explain how that works]

So login to the text/ascii login prompt as your regular user. Enter your regular user password. Then type ‘su’ (no quotes) to get root permissions. Enter root password. Then backup your /etc/X11/xorg.conf file with:
cp /etc/X11/xorg.conf /etc/X11/xorg.conf.mybackup

Then take note if your driver was ‘vesa’ or ‘nv’ or ‘nvidia’ from above. Lets say it was ‘nv’. In which case, still with root permissions, type the following to run sax2 and configure:sax2 -r -m 0=nvand then carefully choose the resolution you want. That may take time to run. And be certain to do the test function.

Once that is done, type “shutdown -r now” to restart. This time do not press “3” in the grub menu.

If instead, you had “vesa” graphics driver, then the command would have been “sax2 -r -m 0=vesa”, or if you had “nvidia” graphics driver (ie the proprietary graphics driver), the command would have been “sax2 -r -m 0=nvidia”.

Note since you backed up the /etc/X11/xorg.conf file, you can always restore it (ie copy it back to xorg.conf) if things get screwed up.

Good luck.

Thanks,

for the help, it took me a couple of tries to get the right resolutions.

Cheers!
pin

Glad to read it worked. Congratulations.

Hindsight being 20-20, I should have passed to you the “xrandr” information command, which will tell you about your computers resolution.