Installing Sun Java 6_30 64 bit

I have a couple of applications that do not work with the Open source Java shipped with SuSe 12.1 and am going to install Sun Java in lieu of the default offering. My question is do I need to have YAST uninstall the existing Java before I install the Sun Java? Also I have seen references to needing icedtea-web to get it to work.
Can anyone comment on these questions.
In case you ask about the two applications not working withh the OpenJDK one is E*TRADE Market Caster, and the other is an application provided by the US Department of Interior that provides a VPN for employee use and requires Sun Java.

Ther is an extensive thread on exact the same subject. I am too lazy to search for ir (have to do some painting work), but I guess yoy can find it.

BTW this here is about openSUSE, not about SuSe.

download this pdf file.

software.opensuse.org: Search Results

On 01/04/2012 04:06 PM, KentSzabo wrote:
> My question is do I need to have YAST uninstall
> the existing Java before I install the Sun Java?

i have not yet installed 12.1 so can’t verify what i’m about to advise,
but in the past (and on 11.4) i have always used YaST to completely
remove the open Java prior to then installing the SUN version…

and, when i get to 12.1 i plan to do the same…that said, do track
down the threads already active on this subject:

http://www.google.dk/search?q=“12.1”+sun+java+site%3Aforums.opensuse.org


DD http://tinyurl.com/DD-Caveat
openSUSE®, the “German Engineered Automobiles” of operating systems!

Thank you all above for the information.