Installing Steam Linux Beta

on 12.2 64bit, this is how I done it:

open the .deb with ark
open the data.tar.gz with ark
extract the /lib/steam/bootstraplinux_ubuntu12_32.tar.xz file to any directory where you want, lets say Steam for now
execute ./ from that directory and let it update
enter your login

and that is it

Hmm, I tried installing it following your steps. It ran the updater and updated successfully but when i try to run now it exits with this message:

> ./
Installing breakpad exception handler for appid(steam)/version(1352224866_client)

Do i need any other 32 bit packages besides libX11? I’m running openSUSE 12.2 x64 w/ KDE 4.9.
Edit: also I noticed the font in the updater window was really ugly, don’t know if that’s a clue or not.

Same here, I’ll try to solve it and see if I can help. (Looks like lots of problems are in x64 versions of Linux)

Alright, it runs:
openSUSE 12.2 x64 Gnome 3.4

On Gaming for Linux someone posted he was a Bumblebee user and had to run it with optirun… not sure that helps you, else maybe Tanshaydar can say what he did as he got same error

I have a similar problem. After launching “public/steambootstrapper_english.txt”. error appears in my terminal and then small Steam updater (similar to the one from windows), but with ugly fonts. Even those in wine are better. :stuck_out_tongue:
Then the updater extracts some files (png, tar etc. ) to the directory with and disappears with the second line printed in my terminal (the one with 1352224866_client error).
Another thing is it created new and empty folder called ‘Steam’ in my home directory. (my is in /home/programs/steam_beta/

> ./ 
ILocalize::AddFile() failed to load file "public/steambootstrapper_english.txt".
Installing breakpad exception handler for appid(steam)/version(1352224866_client)
> echo $?

//Running 12.2 (64) + Gnome 3.4

that sort of sounds like the patcher/updater did not get all ?

OK, how?

I’m running openSUSE with KDE (12.2 - x64). Maybe the reason is GNOME instead of KDE?

going from 12.10 - Installing breakpad exception handler for appid(steam) while trying to run Steam - Ask Ubuntu
I ran

strace -E LD_LIBRARY_PATH=~/Steam/ubuntu12_32/ -e trace=open ~/Steam/ubuntu12_32/steam

to figure out what packages it was wanting. The last line should tell you what library it was looking for.
Last thing I installed was libpng12-0-32bit. Not sure what others were required. I was installing a bunch of 32bit libs before that, so not sure what else it needed, but that strace command should let you figure it out.
I used the output of that and ran

zypper se 32bit|grep [libname]

for example

zypper se 32bit|grep png

and saw libpng12-0-32bit which matched up with the output of the strace.
kept doing this until it ran.

Hope that helps.

Thanks! I will. :slight_smile:

Huh, steam client needs, but I can’t find 32-bit package with this library. (zypper & grep return nothing)

mozilla-nss-32bit contains

Assuming I already have all the necessary libraries installed as it worked right away on 12.2 KDE 4.9.3 64 bit. Some of them I recognize as dependencies of skype so that could be why I already have them.

Yes, I found by myself.

Thanks! Now works!

list of 32bit libraries i had to install on my system (had some 32 bit libs installed before for other software, so most likely not complete)

  • libpango-1_0-0-32bit
  • libgtk-2_0-0-32bit
  • mozilla-nss-32bit
  • libgcrypt11-32bit
  • libopenal1-soft-32bit
  • librtmp0-32bit

~/Steam/Ubuntu12_32 is a hard-coded STEAMROOT in steam binary.

I even rewrite the shell scripts it use to setup environment to ~/Steam/openSUSE_12.2. but after update…Ubuntu comes back.

Now it works! :slight_smile: Thanks!

Hi all steam run good on opensuse 12.2 but list game is empty why ?](

Just wrote a small script to install Steam and it’s dependencies
automatically on openSUSE 12.2 x86_64 and thought I should share it here

openSUSE Ambassador

What was that you were saying about Linux being a headache?
Sorry, I couldn’t hear you over the sound of openSUSE being awesome.
– Helen South on opensuse-marketing Mailinglist

Because it shows your Steam library. If you didn’t buy some game before, this library is empty. Try activate some game code if you previously bought game via Humble Indie Bundle, for example. Then it shows your purchased games. To see more games click to Store :wink: