installing software after extracting it ???

hi … I recently downloaded a .tar file from the web … I used the tar command on the terminal … then after the file was expanded into another directory … ok … how do I run the main file for installation onto opensuse 11.1 ?example : like showing up on the applications menu with an icon … ??? in this case the file is

Most of the softwares you can find in software management, so you can install it from there.
About the the file you downloaded, there are may different ways to get it working.
It depends on the package you downloaded. Maybe you need to use:

make install

Or maybe there is to run.
All are guesses, because you did not provide much info.

i see this is your first post, so -WELCOME-

you may have made a common new guy error in believing the common FUD
that installing software on Linux is really really hard…

it is not, normally…

most of the mainstream software is available for EASY installation via
YaST…just click click and the system does all the “dirty work”,
unlike the more popular operating system from Redmond Washington you
don’t even have to browse to a site, download, and unzip prior to
click click…

the long and the short of of it here: <start reading at post #5 for this topic

oh, and that “” file sounds like a Python (programming
language) script which needs to be executed…(but, you probably will
have to install Python first, using YaST…so, why don’t you FIRST use
YaST to see if what you are trying to install with that script is
already in the repos and easily available to YaST…

if you know all of this already, sorry!


ok … I tried the second approach which is platinum’s post , to this problem by using Yast … what should I be looking for in the repository ??? how do I know ? oh yea puzzled penguin … I’ll try those commands on the terminal … right ?? to give you some more info it’s this … I’m trying to install Moovida 1.0.6 … when I clicked the 1 click install on the open suse geek site it made an error during the installation process … now I’m trying to install via .tar.gz and I don’t know the commands for Gzip … I’m fairly new to linux … I was used to all that tyranny from the evil one who calls his OS … “Precious”

it reads out … bash : make: command not found and it goes on and on for the other cmds on gnome .

no actually … I don’t know … I need help just getting used to installing software from the net onto the linux OS … I guess from scratch when a 1 click installer isn’t available … Kinda new to linux . and found out that opensuse is maybe one of the best and easiest to use . what’s the difference with the commands for expanding (using) a .tar.gz ? and .tar ??

First all, I recommend you brush up on some basic openSUSE concepts, so that you have a conceptual idea as to what is being recommended: Concepts - openSUSE

You should also read our new users installation stickie: NEWBIES - Suse-11.1 Pre-installation – PLEASE READ - openSUSE Forums

Now, I always recommend new users set up their Software Package Manager with 4 software repositories. OSS, Non-OSS, Update, and Packman. Just those 4. No others. None. Just those 4. There is guidance here how to add those 4: Repositories/11.1 - openSUSE-Community Again, despite the massive selection available, ONLY enable the 4 I recommend and disable any others. You will likely find OSS, Non-OSS, and Update already added/enabled, and you only need to add Packman.

To explain:

  • OSS
  • applications that are typically on the packaged DVD - these are typically tested by Novell and by the community
  • Non-OSS
  • typically applications that are not open source free software, but for one reason or another, Novell/SuSE-GmbH have decided to include these applications with openSUSE - these are typically tested by Novell and by the community
  • Update
  • these are official Novell/SuSE-GmbH updates to OSS and Non-OSS - usually security updates, although if there is a really serious bug, one may also see bug fixes - test are typically tested in house in Novell/SuSE-GmbH
  • Packman
  • this is a 3rd party repository put together by a group of volunteers, and contains lots of multimedia, some utilities, games and other neat 3rd party packages. The testing is limited but I believe there are non-enforced guidelines that the Packman packagers follow, which means the Packman repositories tend to have a higher quality than most of the other repositories
    Now the remaining repositories you see are not official updates nor official repositories. Their applications may or may not have been built against OSS/Non-OSS/Update, and they may introduce applications that will cause breakage in either existing or other repositories. And typically they have mininal to absolutely no testing.

Which means typically only experienced average users , or advanced users can identify and then sort any problems.

So stick with the 4 I mentioned. OSS, Non-OSS, Update and Packman.

To install applications, after those 4 repositories are added, go to YaST > Software > Software Management, and change the filter to “search” and search for the application you wish to install.

I suggested some applications to consider installing toward the end of this post:
openSUSE Forums - View Single Post - opensuse multimedia

Cypher7 wrote:
> ok … I tried the second approach which is platinum’s post , to this
> problem by using Yast … what should I be looking for in the repository
> ??? how do I know ?

did you READ about YaST, it was introduced in at least one of the
cites i gave you??

do you know what you are trying to install? like if you want to
install Python you go:

YaST > Software (on left) > Software Management (on right) > WAIT for
all the actions end and the search blank to appear, then > type in
python and click “Search” > pick (in the search results on the right)
the python bits you know you need (how do you know? read or ask) by a
left click to place a check mark next to those you want > then click
“Accept” > it will download, unpack, install, update your menu, update
all config files that need it and ask if you wanna install more

ps: in my YaST is checked:

CAVEAT: i have NO idea if that list is right for you (or me) but it
works here

> I’m trying to install Moovida 1.0.6

if you want Moovida you type in moovida (instead of python) and …

but, i’ve never heard of any using Moovida…you might ask around…i
kinda like VLC Media player, but have several (MPlayer, Kaffiene,
Totem, Amarok, Banshee . . .)

> … now I’m trying to install via .tar.gz and I don’t know the commands
> for Gzip …

for files ending in .tar.gz, use:

tar -zxvf <filename>

(replacing with the name of the file).

for files ending in .tar.bz2, use:

tar -jxvf <filename>

for files ending in .zip, use:

unzip <filename>

but, once unpacked then you need to read README and/or INSTALL, and
follow directions, probably:

make install

here is a longer:
there may be better

> I’m fairly new to linux … I was used to all that tyranny
> from the evil one who calls his OS … “Precious”

initially, the climb is steep…lots of reading and head
scratchin’…it is worth it…

Give a hacker a fish and you feed him for a day.
Teach YaST and you feed him for a lifetime.

Cypher7 wrote:
> it reads out … bash : make: command not found and it goes on and on
> for the other cmds on gnome .



As you inferred, moovida is packaged by Packman. This is seen by doing a search on webpin: Webpin search for moovida

and by searching the packman site: PackMan :: Search results for moovida

If you setup your repositories, like I recommended, with ONLY the 4 that I recommended, you should have no dependency problems. If however, you deviated from that recommendation, you could be facing a major PITA to undo what ever has been done.

oh yeah … platinum

I had installed moovida before but never in .tar
the readme doc explained that there’s a file called which has to be renamed in order for the media player to run . after installation…

Is it just me or no one uses this as a logical .avi .mpeg or .wmv player ???

on totem . I keep getting the same msg … no codec support . after searching for it and installing through the software manager … it still won’t play anything even close to a movie file … any suggestions ???

I confess I took a look at the moovin web page (when I first noticed it on Packman some time back) and immediately decided it was not for me. Moovida, the free media player - play all your files - AVI, mp3, MKV, DivX, MOV, MP4

Maybe if I had a linux box that was only for TV shows, tunes and photos, then I may have taken a second look, but I’m happy now with my current apps designed for movies (smplayer, vlc) and music (amarok) and photos (gtkam) that I decided not to bloat my PC with moovin.

However Packman packagers make a major effort to ensure their packaged applications will install with no problems, as long as a user sticks to the OSS, Non-OSS, and Update (and Packman) repository poplulation philosophy. If one deviates from that, then all bets are off. Hence if the repository philosophy of only OSS, Non-OSS, Update and Packman was followed, Moovin should install with no problems from the repositories, as I described above.

I included those 4 as you said … and only those 4 . I’m still reading about it …

Ok … I know about the repository now …

Ok… I have found a simple solution to this … I installed Mplayer which was originally for the purpose I intended to use it for … playing movies … I guess there’s some conflict with moovida … thanks !