Installing, screen goes blank (no signal detected) on a 3070 Displayport

I’m attempting to install (dual boot with win11), and I get as far as booting from thumb drive, choosing install, it then shows me a shell that scrolls past a bunch of things too fast to read… then my dual monito setup goes blanks and tells me no signal detected and the screen shut down as if they cant tell they’re plugged in (its a daisy chain over display port).

Any idea’s why this might be? or what i can do about it?

One thing to try is to disconnect one display until after you get the installation completed and boot the first time after a power off. If you cannot get the display to stay on when only one is connected, at reaching the first installation boot menu screen, strike the E key to put the bootloader in edit mode, then navigate to the end of the (usually wrapped) line that begins with linu, and append the two strings nomodeset and plymouth.enable=0. Also from that same line, remove quiet and splash=silent if you find them there.


thank you, will give that a try tonight!

Hi I am new to OpenSuse, and this is my first openSuse installation. But chime in as I think we have very similar setup: I have a daisy chin Displayport setup with 3060 Ti card.

My installation was done about a month ago, I think the main thing for installation to display is the nomodeset line, as far as I can remember anyway.

thank you all, this got me through.

Now to figure out how to extend not mirror the two screens! :slight_smile:
I suspect its an nvidia driver thing from what i’ve been reading.

I had a Display Port issue that turned out to be the cable - OpenSUSE i915 drivers expects to see the EDID of the monitor and the cable was not displaying the screen os it assumed no display - I could ssh into the box to issue reboot and shutdown commands…
Replacing the cable with one that did EDID fixed the black screen past the grub.
The irony is Windows did not see a problem with the cable - just OpenSUSE Linux (I tried Tumbleweed and 15.5).

hmm My screen setup is a HDMI, plugged into a Screen that is plugged in to a DP nvidia card.
I wonder if thats a part of the issue… Windows handles it easily

Mine is PC to display port which diasy chained via display to a secondary monitor.

So it might be display port is better support in this kind of setup.

And I assume you are using Nvidia’s driver rather than the open source one.

Also what’s stop you from setup extend monitors instead of mirror, is it some error message?

There is no option for extend… it seems to be mirroring because its not aware of the 2nd screen… in fact its definitely doing that because the two screens have different native resolutions but its only displaying the first screens (in the chain) resolution on both.

It thinks there is only one screen.

I’m guessing yes. Your description of displays and cabling connections here is clear as mud. Input/output pasted here using pre tags to preserve output formatting from inxi -SGaz might clarify. The only way MST has ever worked here is by using DisplayPort connections exclusively. IIRC, it also has required all connections be made and displays powered up before booting the PC.

I’m not sure what " inxi -SGaz" is?

But I apologize, its not HDMI to Display port, Its a straight up Displayport to Displayport daisychain.
There is no HDMI involved. Not sure where i got that idea from.

Either way, the original issue I had for this thread is solved by @ [mrmazda] by adding nomodeset and plymouth.enable=0 to the boot loader.

My new problem of being unable to extend the screens and the nvidia driver making it impossible to sign into GNOME (which seems to be an issue that others have as well) should probably be in a separate thread and this one put to sleep I think.
thanks all that assisted, I’m starting to catch up with linux again, the community is as wonderful as always

It’s a command you execute at the command line. It provides information about the system. The idea is to execute it, and post back results.

1 Like

Thanks for clarifying

I’m back to not being able to sign into gnome unless i bit using the recovery and add nomodeset and plymouth.enable=0

inxi -GSaz includes the often crucial output for graphics troubleshooting: parameters:.

–display is only needed if inxi must be run remotely, e.g. a vtty or ssh, instead of within X.

> inxi -G	| wc -w
> inxi -Gx	| wc -w
> inxi -Gxx	| wc -w
> inxi -Gxxx	| wc -w
> inxi -Ga	| wc -w
> inxi -SGa	| wc -w
> inxi -zSGa	| wc -w
> man inxi
       In  order  to  maintain  basic privacy and security...
       Because inxi is often used on forums for support, you can
       also trigger this filtering with the -z option