Installing Ruby - problems encountered and some solutions

After using openSUSE and SUSE before for many years and almost never posting anything I find myself wishing to share experiences. This time installing ruby
I develop websites using Drupal and use the ruby gem compass family. So on a new installation I selected ruby to be installed during the installation thinking to save time.
Then installed compass and when I tried typing compass clean I go the command not found response. Tried adding the compass path to the path command and still nothing.
So I decided to uninstall and re-install and this is how i did it.

Uninstall all gems

gem list | cut -d"   " -fl | xargs gem uninstall

Uninstall ruby

zypper rm ruby

Download the source file from
I followed the helpful instructions on
Then when everything was safely installed

Re-install compass
Using the following commands

gem update --system
gem install compass

Going to the previous project typed in compass clean and eveything worked as before!

Well, I guess installing compass via the openSUSE rpm would have worked as well, without having to install ruby from source: Install package devel:languages:ruby:extensions / rubygem-compass

Wonder what the upgrade problem might have been.

FWIW - I also recently installed(new, not upgrade) compass from rubygems without a problem.
BTW - “bundle” must be installed from the openSUSE repo, I describe it here
User:Tsu2/Kibana - openSUSE