Installing proprietary Nvidia drivers breaks my system (GTX 970)

Hey, I’m a newbie and Leap is my first ever distribution. I followed instructions to install nvidia drivers via the repository with the g04 packages but when I reboot I have a black screen with multiple error screens : Plasma “plasmashell aborted” 3 or 4 windows, and 1 Krunner “krunner aborted” window. I can’t do anything past that, reloading Plasma and Krunner doesn’t work. I had to load a snapper snapshot, I already did this 2 times.

I’m now a bit afraid to touch these drivers… Why doesn’t it work ?

I’m using an older Nvidia card (GeForce 6150LE). That worked fine with KDE4.

On Plasma 5, I had to change compositing to use XRender (instead of OpenGL). Otherwise Kwin loops.

I don’t know if that has any relevance to your problem.

If you want to try that, then before you install the Nvidia driver, boot with “nomodeset”. That should be stable enough that you can disable compositing or set it to XRender. The setting is under “Display and Monitor” in the desktop settings.

Hey… same issue here for my GTX 970 so I installed them manually. Here’s how.

Go to the official Nvidia site and download the latest drivers for your GPU. Once it’s downloaded you MUST disable Nouveau like this

echo "blacklist nouveau" > /etc/modprobe.d/50-blacklist-nouveau.conf

then do


mkinitrd

After that reboot but here it gets tricky!

You will be greeted with a no-gui shell (tty) and from there you must install the nvidia drivers.

First give/set yourself root :

sudo -i

after that cd to the directory where the nvidia drivers are located at. I am assuming it’s in your download folder so in that case it would be :

cd /home/yourname/Downloads

from there run

ls

incase you forgott the name of the nvidia driver package, which you probably did.

Now let’s install the driver by doing :

./Nameofyourpackage

It will eventually greet you with a ugly looking installer. After you finished the installation reboot by typing :

reboot

It will restart with nvidia drivers rotfl!

IINM first you have to make the package executable, as it’s not an installable rpm but an executable script. There’s a command line to do this, but I usually do from a GUI.

Also, the installation will require some development packages (kernel headers and/or sources, gcc, etc.) to compile the driver. This is not necessary when you install from the nvidia repo - when it works, of course.

I followed CTXz instructions, and it worked ! Fantastic. Though as you just said brunomcl I had the installation get canceled multiple times because it missed something, first gcc, then kernel-devel and some other stuff… But I’ve been able to install everything needed from the terminal and managed to complete the installation.

Though I read on Nvidia’s site (actually a link to suse.org iirc) that by doing this method I would have to do it all over again each time my kernel is updated.

So… how often is a kernel updated ? Does it mean when I update it my system will break again, meaning I have to uninstall the nvidia drivers then update kernel and reinstall them ? Alternatively, can I stop the kernel auto-updating or something, and is it a good idea ?

I really don’t want to be forced to fetch a snapshot of my system again because it broke.

Thanks again.

Not sure if this is relevant to your issues but the way to install Nvidia proprietary drivers has changed in leap. You now need to do:

Yast >Software->Software Repositories->Add->Community Repositories->NVIDIA Graphics Drivers)

then

zypper inr

this will pull in all the necessary supplements needed for the drivers to work properly.

them reboot.

This page gives fuller details and it worked like a charm for me:
*
https://en.opensuse.org/SDB:NVIDIA_drivers*